LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Locale trouble. (http://www.linuxquestions.org/questions/linux-from-scratch-13/locale-trouble-873118/)

illusionoflife 04-05-2011 09:32 AM

Locale trouble.
 
Hi,
i have some problems with my new LFS-6.8.
With the following variables
LANG=ru
LC_ALL=ru_RU.UTF-8
FONT=UniCyr_8x16
CHARSET=ru4
UNICODE=1
i get well-written russian system messages(like "комманда не найдена"), but when i type russian text myself i get incorrect characters(like "?"). What did i forgot to do and say? Also, altho it may be related, in lynx i get russian cites translited. Any suggestions?

druuna 04-05-2011 12:16 PM

Hi,

Have you checked your content of: /etc/sysconfig/console and /etc/profile. No typo's or other mistakes?

Also: UTF-8 isn't well supported (BLFS - Locale Related Issues).

Hope this helps.

EDIT:

I found this, not mentioned in the later versions but it might help:

LFS 6.3 - Configuring the Linux Console (Bottom of the page, last console example).

illusionoflife 04-05-2011 01:49 PM

Hi,
I tried a lot of combinations of LC_ALL KEYMAP and FONT variables values.
Configuration you pointed i tried also with different LC_ALL. No effect.
Will try to find out what variables are set on other comp's Debian.Any more ideas to try?
EDIT:
Combination found:
UNICODE=1
KEYMAP=ruwin_alt-UTF-8
LANG=ru
LC_ALL=ru_RU.UTF-8
Switches with right ALT.
Lynx still translite. No idea. Configured with nls.

druuna 04-05-2011 03:27 PM

Hi,

Good to read you got the main problem fixed.

About lynx: did you check the Options Menu (start lynx, press o (not zero, the letter) to see if the settings are correct? Display character set is the first that came to mind....

Also look at:
- Preferred document language
-Preferred document character set

Hope this helps.

illusionoflife 04-17-2011 11:29 AM

Was easy, just set display set as UTF-8.
Also, its seems best to set FONT=LatArCyrHeb-14. This font looks best for me with ncurses application, like mcabber. Thanks a lot.

druuna 04-17-2011 11:41 AM

You're welcome :)


All times are GMT -5. The time now is 02:13 AM.