LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-01-2004, 07:36 PM   #1
letdoit
Member
 
Registered: Mar 2003
Posts: 38

Rep: Reputation: 15
How to change the locale by setting the system default locale


the LANG is "en_US.UTF-8" which is set to default. As I typed $gedit at root, the error appear " Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale". I have to use comand $export LANG=C each time I work under terminal environment to avoid the error message above.

Do you have any solution?
 
Old 06-02-2004, 01:15 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 47
you can put it .bashrc in your home directory.
 
Old 06-02-2004, 03:27 AM   #3
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,578

Rep: Reputation: 127Reputation: 127
For LANG env variable, you can set it by edit /etc/profile.d/lang.sh and lang.csh
 
Old 11-13-2007, 03:07 AM   #4
bwzhou
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
You can change default locale in /etc/sysconfig/i18n
 
0 members found this post helpful.
Old 11-13-2007, 01:21 PM   #5
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 512

Rep: Reputation: Disabled
Quote:
You can change default locale in /etc/sysconfig/i18n
This does not apply to Slackware.
 
Old 08-17-2011, 06:05 PM   #6
forrie
Member
 
Registered: Sep 2003
Distribution: RedHat
Posts: 37

Rep: Reputation: 15
I found this older post via a Google search. I have a RHEL 5.6 system which, for the most part, has never had any issues with locale. I'm now getting these types of errors from different code:

Quote:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US.us-ascii",
LC_ALL = "en_US.us-ascii",
LC_MONETARY = "en_US.us-ascii",
LC_NUMERIC = "en_US.us-ascii",
LC_MESSAGES = "en_US.us-ascii",
LC_COLLATE = "en_US.us-ascii",
LC_CTYPE = "en_US.us-ascii",
LC_TIME = "en_US.us-ascii",
LANG = "en_US.us-ascii"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
It's driving me right up a wall.

I have checked the output of "locale -a" to make sure that /etc/sysconfig/i18n is correct (it is). Something got messed up, probably during a recently "yum update".

I'd really like to fix this, as I think it's going to screw some other processes up. After reading around, I'm still not sure about how to resolve the issue.

Any pointers would be appreciated.


Thanks.
 
Old 08-18-2011, 03:34 AM   #7
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 512

Rep: Reputation: Disabled
You are in the Slackware forum. I'd suggest you ask this question in the proper forum to have better chances at solving the issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
C locale and system locale johnnydangerous Fedora 4 04-11-2005 03:37 PM
locale setting ’ mnaumanca Linux - Software 0 02-18-2005 03:39 PM
Change locale for an application? codec Linux - General 0 04-18-2004 05:57 AM
Changing default locale/GNOME language elluva Linux - Software 5 01-13-2004 02:20 PM


All times are GMT -5. The time now is 01:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration