LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 04-28-2008, 08:50 PM   #1
gh0st
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Rep: Reputation: 0
Exclamation after-Installation errors. locale error. unsupported locale settings and two more


Ok here's the story. to start-off here's my machine specs

Proc: P4 2.8
Mobo: Asus P4GE-MX
Mem: 1GB
Video Card: 64MB geforce mx 400
Hard Disks:
•80 gig (windows xp) [Primary Master]
•40 gig (this is where i plan to install FC 8) [Secondary Primary Master]
optical drives:
•CD drive [Primary Slave]
•DVD drive [Secondary Primary Slave]

so there, i booted up my pc with my Fedora-8-i386-DVD, everything went fine. the from choosing whether to rescue etc, media testing, language selection and the keyboard. then here's the 1st problem i encountered.

fedora recognizes my hdd's as sda and sdb. i tried installing slackware 12 and centos 5 before and they all see my hdd's as hda so on..

still i pushed through, made my custom layout unchecked sda and chosed sdb as the path to install FC8 so on, default bootloader settings upto optional packages installation. Everything went fine, packages are installed up until it says reboot.

here's the 2nd problem i had. DVD ejects FC8 dvd, then i clicked reboot,
i noticed something but i wasnt able to get all the lines that said error, i only remembered this line

locale error. unsupported locale settings

then my machine rebooted.

then here's the 3rd problem. grub / bootloader doesnt show. initially my machine boots up to windows xp rightaway. btw my boot order was:

1st boot: cd/dvd
2nd boot: hd-0 (windows installed)
3rd boot: hd-1 (fedora installed)


so i changed the boot order to

1st boot: hd-1 (fedora installed)
2nd boot: hd-0 (windows installed)
3rd boot: cd/dvd


boot loader showed up. i choosed fedora then this came up

Booting `fedora (2.6.23.1-42.fc8)
Root (h1,0)
filesystem type unknown, partition type 0x7 kernel /vmlinuz-2.6.23.1-42.fc8 ro root=/dev/sdb2 rhgb quiet

Error 17: cannot mount selected partition.


i rebooted. chosed windows xp instead. then this came up.

Booting Windows XP

rootnoverify(hd0,0)
chainloader +1


any suggestions, how to make it work? as of the moment im redownloading a new .iso from fedoraproject.org.

Last edited by gh0st; 04-28-2008 at 09:05 PM.
 
Old 05-02-2008, 05:06 AM   #2
bibh_lnxq
Member
 
Registered: Nov 2004
Location: Leiden, Netherlands
Distribution: SuSE; Fedora;Slackware
Posts: 58

Rep: Reputation: 15
What the errors are telling you is this:

You have installed GRUB to the second HD (sdb2, it *is* sdb, not hdb in Fedora, and in other Linux distributions too), but if you want to dual boot with WinXP via GRUB (and I think you do ;-))then the best way is to install GRUB to the MBR of HD0 (= the first).

The " filesystem type unknown, partition type 0x7" tells you that it is finding an NTFS partition. It should be 0x83 for Linux.

Fedora installer will format the second drive for you properly, including a swap partition, but you can prepare your second HD by formatting with a generic Linux partition and a swap partition using a standalone partition manager, e.g. GParted.

All you have to do first before reinstalling Fedora is to change your BIOS settings to your old ones. There is nothing wrong with them.

Finally, I would advise you to watch the info/choices of the Fedora installer carefully. In my experience installing Fedora for dual booting is quite straightforward, and you do not have to change a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
locale: Cannot set LC_ALL to default locale: Invalid argument GadgetWiz Mandriva 1 03-31-2006 11:38 PM


All times are GMT -5. The time now is 11:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration