LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-19-2005, 01:19 AM   #1
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Rep: Reputation: 15
enable ssh


I am a newbie for debian, I used fc3 before. when I ssh to my debian's server, it doesn't work, how to enable it?

[root@localhost ~]# ssh <ip>
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
16:db:86:a3:3b:50:46:81:2c:4d:11:2c:83:3a:26:6g.
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
RSA host key for <ip>has changed and you have requested strict checking.
Host key verification failed.
 
Old 08-19-2005, 01:43 AM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
You shouldn't run ssh as root even if it is encrypted. After all a man-in-the-middle attack is possible like the error says. If you really want to, remove the corresponding line from /root/ssh/known_hosts , that is, the line beginning with the <ip> you snipped off. It will then ask you to accept the new key when you try to connect.
 
Old 08-19-2005, 02:27 AM   #3
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by makuyl
You shouldn't run ssh as root even if it is encrypted. After all a man-in-the-middle attack is possible like the error says. If you really want to, remove the corresponding line from /root/ssh/known_hosts , that is, the line beginning with the <ip> you snipped off. It will then ask you to accept the new key when you try to connect.
I want to know how to access ssh by other user?
I understood ssh by root will cause some security problems.
 
Old 08-19-2005, 03:46 AM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Umm, what do you mean by how to access?
I usually do "ssh username@ip" as user. Also I have disabled root login in sshd_config. If I want to, I can still su to root when already logged in.

EDIT: btw, I made a typo in the previous post. The file is "/root/.ssh/known_hosts" I forgot the dot before ssh

Last edited by makuyl; 08-19-2005 at 03:48 AM.
 
Old 08-19-2005, 12:38 PM   #5
davidhk
Member
 
Registered: Jun 2005
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by makuyl
Umm, what do you mean by how to access?
I usually do "ssh username@ip" as user. Also I have disabled root login in sshd_config. If I want to, I can still su to root when already logged in.

EDIT: btw, I made a typo in the previous post. The file is "/root/.ssh/known_hosts" I forgot the dot before ssh
1) when I did "ssh user@ip, the result was the same:-

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
16:db:86:a3:3b:50:46:81:2c:4d:11:2c:83:3a:26:6g.
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
RSA host key for <ip>has changed and you have requested strict checking.
Host key verification failed.
 
Old 08-19-2005, 01:09 PM   #6
rbochan
Member
 
Registered: Dec 2004
Location: Central New York
Distribution: Debian
Posts: 218

Rep: Reputation: 30
Quote:
Originally posted by davidhk

Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
RSA host key for <ip>has changed and you have requested strict checking.
Host key verification failed.
If you'd have actually read what was shown you, the warning told you what to do.
"Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts"

If you know for a fact that the system is ok, you can remove the offending entry from your known_hosts file.
 
Old 10-09-2007, 04:54 PM   #7
jorian1
LQ Newbie
 
Registered: Feb 2006
Posts: 3

Rep: Reputation: 0
Unhappy Enable SSH

I have a problem, when I try to login to my computer via ssh from another one I get the following: "ssh: connect to host ip port 22: Connection refused", I know that is because the service is not active, I want to know how do I enable it. Anyone can help me?
 
Old 10-09-2007, 05:49 PM   #8
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,609

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
Yes, if you stop bumping two-year old topic and make your own.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh-agent, ssh-add and ssh-keygen AND CVS raylpc Linux - General 2 11-19-2008 02:50 AM
Mac OS X ssh client / linux sshd : ssh hangs/disconnects Apollo77 Linux - Networking 1 05-24-2006 11:53 AM
Enable SSH carlosinfl Linux - Networking 11 09-17-2005 11:27 PM
Enable ssh to server Kdr Kane Suse/Novell 1 06-20-2005 01:06 PM
How do I enable SSH in suse 9.1 pro? wearetheborg Linux - Software 3 10-16-2004 03:13 PM


All times are GMT -5. The time now is 03:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration