LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-01-2005, 05:57 AM   #1
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Debian
Posts: 2,896

Rep: Reputation: 73
Enable SSH


I just installed Debian Linux on a server at home and am not sure if I can login via SSh to the machine. Is there a way I can find out if SSH is enabled and if not, how to enable SSH connections on the machine?
 
Old 06-01-2005, 06:09 AM   #2
MikeAtVillage
Member
 
Registered: May 2005
Location: Mid Wales (UK)
Distribution: Slackware 8.0, Suse 10.0/1/2, CentOS (SMEServer7)
Posts: 38

Rep: Reputation: 15
you should be able to find if the ssh daemon is running by typing..

ps -C sshd



HTH
 
Old 06-01-2005, 06:14 AM   #3
huibert.alblas
Member
 
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
I don't think I understand you correctly...

to test if sshd is up and running, simply try
"ssh myuser@localhost"

If you get a passwordprompt, sshd is running.....

Or do you mean something else?
 
Old 06-01-2005, 07:25 AM   #4
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Debian
Posts: 2,896

Original Poster
Rep: Reputation: 73
I was trying to see if there is a way to see in my system settings if SSH was enabled.

Can I try "ssh myuser@localhost" in my firefox browser to test this?

If it does not work, how do I enable SSH on my system?
 
Old 06-01-2005, 07:35 AM   #5
MikeAtVillage
Member
 
Registered: May 2005
Location: Mid Wales (UK)
Distribution: Slackware 8.0, Suse 10.0/1/2, CentOS (SMEServer7)
Posts: 38

Rep: Reputation: 15
No, you need to issue that command at a system prompt NOT a browser.
 
Old 06-01-2005, 09:00 AM   #6
rhinux
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
typing...
netstat -a |grep ssh

start ssh
/etc/init.d/sshd start | stop | restart
 
Old 06-01-2005, 04:31 PM   #7
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Debian
Posts: 2,896

Original Poster
Rep: Reputation: 73
Quote:
Originally posted by MikeAtVillage
you should be able to find if the ssh daemon is running by typing..

ps -C sshd



HTH
Code:
carlos@debian:~$ ps -C sshd
  PID TTY          TIME CMD
 1581 ?        00:00:00 sshd
Quote:
typing...
netstat -a |grep ssh

start ssh
/etc/init.d/sshd start | stop | restart
Code:
debian:~# /etc/init.d/sshd start
-su: /etc/init.d/sshd: No such file or directory
I tried to login from work usin Putty and it failed so I am now in front of my machine and am not sure what the problem is.
 
Old 06-01-2005, 07:38 PM   #8
ARC1450
Member
 
Registered: Jun 2005
Location: Odenton, MD
Distribution: Gentoo
Posts: 290

Rep: Reputation: 30
Well, it seems SSH is running on your machine.

Are you behind a router of any sorts? Have you tried to log in from a computer on your home network?

I think Debian uses the "service" function to start things. Try "service sshd start" and see what that gives you.
 
Old 06-01-2005, 08:13 PM   #9
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Debian
Posts: 2,896

Original Poster
Rep: Reputation: 73
Yes, SSH is running and working fine. I just had to set SSH to forward to my debian LAN IP.

I still can't figure out how to start | stop | restart SSH service.

Code:
debian:~# service ssh restart
-bash: service: command not found
 
Old 06-02-2005, 01:14 PM   #10
ARC1450
Member
 
Registered: Jun 2005
Location: Odenton, MD
Distribution: Gentoo
Posts: 290

Rep: Reputation: 30
http://www.linuxquestions.org/questions/history/320881 << There you go.

Just type cd /etc/init.d and see how ssh is started. It may be with sshd or simply ssh. Hard telling. If it's not there, you can always apt-get it again and hopefully the correct script will be installed.

[edit]You are logged in as root when you try to do /etc/init.d/(servicename) start|stop|restart|zap, right?

Last edited by ARC1450; 06-02-2005 at 01:15 PM.
 
Old 09-17-2005, 03:33 PM   #11
codiesmokie
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
Fedora 3 problem with ssh

Hi all,


I just installed Fedora 3 and I disabled Firewall already.

I connected my Fedora box behide my DSL rounter.
I forward port 22 to my Fedora box.
I can log in to ssh by local IP but I cannot access by external IP.
I got an message "Server Responded Connection closed by remote host."

I look on sshd_config. I did enble everything but it still does not work.

If any one can help, I will be appreciated.

Thank you
 
Old 09-17-2005, 11:27 PM   #12
Snowbat
Member
 
Registered: Jun 2005
Location: q3dm7
Distribution: Mandriva 2010.0 x86_64
Posts: 338

Rep: Reputation: 30
It would help if you mentioned which DSL router it is.

Do you need to reboot the router for the port forward to activate?

Is port 22 reserved for the router's own use? This may not be obvious. Try forwarding a high port number on your router to port 22 on your Fedora box and see if that works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh-agent, ssh-add and ssh-keygen AND CVS raylpc Linux - General 2 11-19-2008 02:50 AM
enable ssh davidhk Debian 7 10-09-2007 05:49 PM
Mac OS X ssh client / linux sshd : ssh hangs/disconnects Apollo77 Linux - Networking 1 05-24-2006 11:53 AM
Enable ssh to server Kdr Kane Suse/Novell 1 06-20-2005 01:06 PM
How do I enable SSH in suse 9.1 pro? wearetheborg Linux - Software 3 10-16-2004 03:13 PM


All times are GMT -5. The time now is 07:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration