LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   enable ssh (http://www.linuxquestions.org/questions/debian-26/enable-ssh-354780/)

davidhk 08-19-2005 01:19 AM

enable ssh
 
I am a newbie for debian, I used fc3 before. when I ssh to my debian's server, it doesn't work, how to enable it?

[root@localhost ~]# ssh <ip>
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
16:db:86:a3:3b:50:46:81:2c:4d:11:2c:83:3a:26:6g.
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
RSA host key for <ip>has changed and you have requested strict checking.
Host key verification failed.

makuyl 08-19-2005 01:43 AM

You shouldn't run ssh as root even if it is encrypted. After all a man-in-the-middle attack is possible like the error says. If you really want to, remove the corresponding line from /root/ssh/known_hosts , that is, the line beginning with the <ip> you snipped off. It will then ask you to accept the new key when you try to connect.

davidhk 08-19-2005 02:27 AM

Quote:

Originally posted by makuyl
You shouldn't run ssh as root even if it is encrypted. After all a man-in-the-middle attack is possible like the error says. If you really want to, remove the corresponding line from /root/ssh/known_hosts , that is, the line beginning with the <ip> you snipped off. It will then ask you to accept the new key when you try to connect.
I want to know how to access ssh by other user?
I understood ssh by root will cause some security problems.

makuyl 08-19-2005 03:46 AM

Umm, what do you mean by how to access?
I usually do "ssh username@ip" as user. Also I have disabled root login in sshd_config. If I want to, I can still su to root when already logged in.

EDIT: btw, I made a typo in the previous post. The file is "/root/.ssh/known_hosts" I forgot the dot before ssh

davidhk 08-19-2005 12:38 PM

Quote:

Originally posted by makuyl
Umm, what do you mean by how to access?
I usually do "ssh username@ip" as user. Also I have disabled root login in sshd_config. If I want to, I can still su to root when already logged in.

EDIT: btw, I made a typo in the previous post. The file is "/root/.ssh/known_hosts" I forgot the dot before ssh

1) when I did "ssh user@ip, the result was the same:-

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
16:db:86:a3:3b:50:46:81:2c:4d:11:2c:83:3a:26:6g.
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
RSA host key for <ip>has changed and you have requested strict checking.
Host key verification failed.

rbochan 08-19-2005 01:09 PM

Quote:

Originally posted by davidhk

Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
RSA host key for <ip>has changed and you have requested strict checking.
Host key verification failed.

If you'd have actually read what was shown you, the warning told you what to do.
"Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts"

If you know for a fact that the system is ok, you can remove the offending entry from your known_hosts file.

jorian1 10-09-2007 04:54 PM

Enable SSH
 
I have a problem, when I try to login to my computer via ssh from another one I get the following: "ssh: connect to host ip port 22: Connection refused", I know that is because the service is not active, I want to know how do I enable it. Anyone can help me?

AlucardZero 10-09-2007 05:49 PM

Yes, if you stop bumping two-year old topic and make your own.


All times are GMT -5. The time now is 04:45 PM.