LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-16-2004, 04:32 AM   #1
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Rep: Reputation: 31
How do I enable SSH in suse 9.1 pro?


I cannot SSH TO my machine. Whenever I try ssh localhost it says:
ssh: connect to host localhost port 22: Connection refused


I can connect to other computers by ssh, I'd like to connect from other computers to mine.

My computer is connected by a router I think ( my wireless card has caught hold of a connection in my complex). Is there a way to access my computer? I looked up my ip address on a website, then on a remote computer tried to ping that IP address, no response.
 
Old 10-16-2004, 04:52 AM   #2
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
the sshd (the server) has to be running and connections to port 22 have to be allowed (via firewall and sshd_config).
the sshd mostly is configured somewhere in /etc/ssh on your system.

some distributions have a file called "not_start_sshd" there, so the server will not be started from your ssh init script.
there should be some interface for starting services that come with your suse?

sl mritch.
 
Old 10-16-2004, 05:09 AM   #3
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Most likely the router has port 22 closed, and since you are "borrowing" someone elses bandwidth you will probably have to live with what you have.

Something you could try is go to one of the online ip scanners and run a scan to see if any ports are open. If you find one then edit the sshd config file to use that port.

man sshd
man sshd_config
 
Old 10-16-2004, 03:13 PM   #4
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Original Poster
Rep: Reputation: 31
I used http://msv.dk/ms125.asp
It did not get response from any of the ports. So I guess I cannot connect from outside. Will that prevent me from SSHing from my computer to my computer locally? I someimes need to run some graphical utilies as root and I dont want to log out and log in as root.

How can I know whther sshd is running? I think firewall has SSH enabled.

Last edited by wearetheborg; 10-16-2004 at 03:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enable ssh davidhk Debian 7 10-09-2007 05:49 PM
Enable SSH carlosinfl Linux - Networking 11 09-17-2005 11:27 PM
can you enable touchpad scrolling in suse 9.1 pro? ojasom Suse/Novell 1 10-30-2004 10:09 PM
SuSe 9.0 Pro and SSH gblue Linux - Security 2 11-15-2003 10:41 AM
How do I enable internet connection sharing under suse 8.2 pro? bruno buys Linux - Networking 1 11-10-2003 11:48 AM


All times are GMT -5. The time now is 01:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration