LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-30-2013, 10:54 PM   #1
zaxonus
Member
 
Registered: Jul 2005
Posts: 52

Rep: Reputation: 15
Cannot use Japanese in the terminal.


Hi,

I just installed Debian 6.0.6 on an old laptop machine.

In order to handle Japanese language I added the following packages, using aptitude:
otf-ipaexfont, ibus, anthy, ibus-anthy.

I can now see home pages in Japanese using IceWeasel, as well as edit documents in Japanese.

But if I want to type in Japanese at the terminal, it does not work anymore.
Why is that? Did I forget something?

I also have a somewhat similar configuration on another computer running Arch linux and there I can type in Japanese at the terminal.

Thanks for any tip.
 
Old 01-30-2013, 11:00 PM   #2
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Sitting in front of my computer.
Distribution: Debian
Posts: 1,004
Blog Entries: 2

Rep: Reputation: 252Reputation: 252Reputation: 252
Have you installed a multi-lingual terminal package? I have mlterm, but there are others.
 
Old 01-31-2013, 10:37 AM   #3
zaxonus
Member
 
Registered: Jul 2005
Posts: 52

Original Poster
Rep: Reputation: 15
Ibus-anthy icon missing in KDE.

Thanks for the tip.
Finally it worked after I rebooted, without doing anything.
This is using LXDE.

In the meanwhile I installed the same OS (Debian 6.0.6) on a different computer, this time with KDE and I got a related but slightly different problem.
I can use Japanese input based on Ibus-anthy, but this time the icon does not show up in the panel as it should, that prevents me from choosing the options I would like to use with anthy.

Any hint would be welcome.

Thanks in advance.
 
Old 01-31-2013, 04:42 PM   #4
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Sitting in front of my computer.
Distribution: Debian
Posts: 1,004
Blog Entries: 2

Rep: Reputation: 252Reputation: 252Reputation: 252
Does KDE not have an Ibus (or Input Method) entry somewhere in its Settings menu?
 
Old 01-31-2013, 07:32 PM   #5
zaxonus
Member
 
Registered: Jul 2005
Posts: 52

Original Poster
Rep: Reputation: 15
Well, after I installed it, Ibus got an entry. I do not think it could have had one before.

But in any case this entry gives me the choice between [several] possible method[s] to use with Ibus (in my case only anthy, since this is the only one I installed). Nevertheless it does not let me set the way anthy itself works.
And this is my very problem. Normally I would set the options for anthy using its icon (which is now missing).
 
Old 01-31-2013, 07:46 PM   #6
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Sitting in front of my computer.
Distribution: Debian
Posts: 1,004
Blog Entries: 2

Rep: Reputation: 252Reputation: 252Reputation: 252
In neither Ibus nor SCIM have I seen a way to modify the inputs methods. If it can be done, I do not know how. It is not a concern with Chinese, but I am unfamiliar with the set-up of Japanese.
 
Old 01-31-2013, 07:48 PM   #7
zaxonus
Member
 
Registered: Jul 2005
Posts: 52

Original Poster
Rep: Reputation: 15
Smile I just found a solution.

For those who might encounter the same problem. Here is the solution I just found.
In the General tab of Ibus Preferences, set Show language panel: to When active and it will make the icon appear when needed.

The previous setting was Embedded in menu and I do not quite know what that means.
(The icon was probably hidden somewhere in some menu)
 
Old 01-31-2013, 09:51 PM   #8
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Sitting in front of my computer.
Distribution: Debian
Posts: 1,004
Blog Entries: 2

Rep: Reputation: 252Reputation: 252Reputation: 252
Quote:
Show language panel
Ah. I forgot about that. (Too simple to remember.) The third option, Always, places an icon at the bottom right of the screen that cannot be moved. It is really annoying.
 
  


Reply

Tags
input, japanese, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to stop gnome terminal 2.16.0 suddenly switching to Japanese input gnreeke Linux - Newbie 3 06-03-2009 03:44 PM
Terminal problems with Japanese characters sadarax Linux - Software 1 02-11-2007 08:22 AM
Japanese in slackware xushi Slackware 9 05-12-2005 09:18 PM
Japanese in KMail linuxfond Linux - Newbie 24 07-09-2004 09:39 AM
Japanese Telnet Slartybartfast Linux - General 0 09-04-2003 05:50 AM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration