LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Cannot use Japanese in the terminal. (http://www.linuxquestions.org/questions/debian-26/cannot-use-japanese-in-the-terminal-4175447931/)

zaxonus 01-30-2013 10:54 PM

Cannot use Japanese in the terminal.
 
Hi,

I just installed Debian 6.0.6 on an old laptop machine.

In order to handle Japanese language I added the following packages, using aptitude:
otf-ipaexfont, ibus, anthy, ibus-anthy.

I can now see home pages in Japanese using IceWeasel, as well as edit documents in Japanese.

But if I want to type in Japanese at the terminal, it does not work anymore.
Why is that? Did I forget something?

I also have a somewhat similar configuration on another computer running Arch linux and there I can type in Japanese at the terminal.

Thanks for any tip.

Randicus Draco Albus 01-30-2013 11:00 PM

Have you installed a multi-lingual terminal package? I have mlterm, but there are others.

zaxonus 01-31-2013 10:37 AM

Ibus-anthy icon missing in KDE.
 
Thanks for the tip.
Finally it worked after I rebooted, without doing anything.
This is using LXDE.

In the meanwhile I installed the same OS (Debian 6.0.6) on a different computer, this time with KDE and I got a related but slightly different problem.
I can use Japanese input based on Ibus-anthy, but this time the icon does not show up in the panel as it should, that prevents me from choosing the options I would like to use with anthy.

Any hint would be welcome.

Thanks in advance.

Randicus Draco Albus 01-31-2013 04:42 PM

Does KDE not have an Ibus (or Input Method) entry somewhere in its Settings menu?

zaxonus 01-31-2013 07:32 PM

Well, after I installed it, Ibus got an entry. I do not think it could have had one before.

But in any case this entry gives me the choice between [several] possible method[s] to use with Ibus (in my case only anthy, since this is the only one I installed). Nevertheless it does not let me set the way anthy itself works.
And this is my very problem. Normally I would set the options for anthy using its icon (which is now missing).

Randicus Draco Albus 01-31-2013 07:46 PM

In neither Ibus nor SCIM have I seen a way to modify the inputs methods. If it can be done, I do not know how. It is not a concern with Chinese, but I am unfamiliar with the set-up of Japanese.

zaxonus 01-31-2013 07:48 PM

I just found a solution.
 
For those who might encounter the same problem. Here is the solution I just found.
In the General tab of Ibus Preferences, set Show language panel: to When active and it will make the icon appear when needed.

The previous setting was Embedded in menu and I do not quite know what that means.
(The icon was probably hidden somewhere in some menu)

Randicus Draco Albus 01-31-2013 09:51 PM

Quote:

Show language panel
Ah. I forgot about that. (Too simple to remember.:o) The third option, Always, places an icon at the bottom right of the screen that cannot be moved. It is really annoying.


All times are GMT -5. The time now is 11:27 AM.