LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 06-02-2009, 03:04 PM   #1
gnreeke
LQ Newbie
 
Registered: Mar 2009
Distribution: Redhat & Centos
Posts: 4

Rep: Reputation: 0
Unhappy How to stop gnome terminal 2.16.0 suddenly switching to Japanese input


There are many threads about how to input in Japanese.
I have the opposite problem. My installation is RedHat 5,
64 bit. I use gnome terminal 2.16.0 on a gnome desktop.
Every once in a while, while typing, my finger slips and
I hit some unknown key, perhaps a function key? and suddenly
my subsequent input turns into Japanese characters (not Chinese,
I know the difference). Anybody know how to change it back
to whatever the default English mode is?
I tried checking all the menus at the top of the terminal
window, also the Keyboard Indicator 2.16.0.1 that I have on
my control panel, but the keyboard preferences there is
already set to U.S. English, so it seems the gnome terminal
is not looking at this. The only thing that works is to
kill the terminal and start a new one.
Thanks,
gnreeke
 
Old 06-02-2009, 06:23 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946
If you're getting full Japanese input, and it's not just an improper keyboard mapping, then you have to be running some kind of IME. This is most probably scim or uim, in which case you should also have an icon in your system tray for it, or a floating toolbar or something in which to access it.

I believe the default toggle switch for most of these systems is shift+space, or perhaps ctrl+space, but it could be different depending on your settings. If you're using scim and can't find an icon for it, you can run scim-setup to get the settings control panel, where you can confirm/change the global trigger hotkey. Not sure what you'd need to do if you're using something else.
 
Old 06-02-2009, 06:27 PM   #3
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Now that is a question I don't think I've ever seen

To fix the symptom and not the problem, you could just type in reset, as opposed to restarting the thing, but as David the H. shift+space is usually the switch for this
 
Old 06-03-2009, 03:44 PM   #4
gnreeke
LQ Newbie
 
Registered: Mar 2009
Distribution: Redhat & Centos
Posts: 4

Original Poster
Rep: Reputation: 0
Smile How to stop gnome terminal 2.16.0 suddenly switching to Japanese input

Thanks esp to David the H.
scim is indeed running; I was just not familiar with it.
scim-setup tells me that Ctrl-Space is indeed the toggle character,
and typing it brings up a little window that tells me the input is
English/European. The Ctrl-Alt keys that are supposed to change the
input method don't do that, instead they change workspaces. Both
English and Japanese input are shown as being enabled. Since I
don't need Japanese input, I just unclicked the enable button on
the Japanese and clicked APPLY. Hopefully this will cure the
problem for good, but if it doesn't, I will post to this thread
again.
gnreeke
 
  


Reply

Tags
gnome, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
stop gnome terminal from starting kafnir Linux - General 1 10-10-2007 12:20 PM
switching from command line terminal to gnome or kde odiliko Linux - Newbie 2 08-15-2006 11:27 PM
Ctrl+Shift Unicode input gone, after installing Japanese Input Methodes polemon Linux - Newbie 1 09-20-2005 05:17 PM
Stop gnome terminal startup notification manobes Linux - Software 0 11-04-2004 09:42 AM
Japanese & Chinese input methods on English Gnome / Fedora Core 2 + Gimlet shortcuts sunwukong Linux - General 0 09-02-2004 04:55 AM


All times are GMT -5. The time now is 05:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration