LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-28-2004, 07:10 AM   #1
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Rep: Reputation: 30
Japanese in KMail


Helo,
I wonder if anyone here had this problem:
when you type Japanese in KMail and hit the space-bar to select an appropriate kana, the little select box where a character appears is all black so that you can't see the character being displayed.
I don't have this problem in konqueror or OpenOffice.
 
Old 06-28-2004, 08:20 AM   #2
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
I never fully appreciate receiving a response like this myself, but I use Thunderbird all the time to type emails to Japanese friends, and it works well for me. I wish that I could help you otherwise.

Now I doubt this is the problem, but I am sometimes annoyed by the cannaserver popup window because it jumps up at the bottom of, for instance, firefox so that I have to right click on the top boarder and drag it up in order to see the possible options. (I usually use Fluxbox so there is very little space between the bottom of maximized apps and the bottom of the screen.) That isnt your problem is it? Sometimes I make sure to move up the lower edge of my apps to make sure that the popup window is fully visible.
 
Old 06-28-2004, 03:12 PM   #3
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Thunderbird? Never heard of it! Can you post a link to its website or a download location?
I also use fluxbox. My problem is in the KMail, that is, when I hit the spacebar in order to select a kanji, I can't see the kanji because it appears in a black rectangle.
In oowriter it appears in a white rectangle so I can see what kanji's there are to choose from. Thanks for your response!
 
Old 06-28-2004, 03:14 PM   #4
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Oh, I see. Is it @ http://www.mozilla.org/projects/thunderbird/?
I will check it out.
 
Old 06-28-2004, 09:22 PM   #5
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
Hope Thunderbird works out for you. I find it to be very useful myself.

Later
 
Old 06-28-2004, 09:45 PM   #6
Micrll
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10 Offical Release
Posts: 18

Rep: Reputation: 0
I know that this is mostly unrelated but how do you get mandrake to accept japanese text input from a american keyboard? From what it sounds like, it seems to work like the IME pad in windows?
 
Old 06-29-2004, 12:53 AM   #7
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
This got me started:
http://merkel.ZoneO.net/Linux/japinput.php?lang=en

Kroenecker, thanks for the Thunderbird hint. It's a nice program. I don't know however what happened in my PC, but Japanese input now works also in KMail. Maybe I stick with the latter, because it seems I can't import messages from Outlook Express into Thunderbird (maybe, I am wrong).

Now the "IME pad" works. I have however some desires, I wonder if that's possible to fix in Linux at all. I guess, Japanese users would not use Linux if that would be a common problem for all.

1st problem: there is no memorization of the recently used kanji. This is annoying, specially if you have to type, say, "ya", and there are dozens of "ya" to cycle through till you get the right one.

2nd problem: some common words do not convert easily into kanjis. For example: tosugiru in Windows naturally appears in kanji, in Linux I have to type "toi", then delete the "i", and add "sugiru". Hope there is a fix for this. If not, typing Japanese becomes unnecessary slow process...

3rd problem: the line doesn't break at a desired column - you can type miles long lines it won't break unless you hit the return key.

4th problem: zip codes do not automatically add postal addresses.

All these problems are possibly related to the imprefections in kinput2, and they result in inputting Japanese about 10-15 times slower in Linux than in Windows.

Is there a fix for it? Do you, maybe, use other ways to input Japanese in Linux?

Thanks for your ideas!

Last edited by linuxfond; 06-29-2004 at 12:58 AM.
 
Old 06-29-2004, 08:37 AM   #8
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
Nope. I use Kinput2 and cannaserver. The thing is that my machine remembers what I last entered for me (like windoz~).

You are correct about some words having to be entered in a more modular way in order to get the kanjis to appear. I don't know what the solution to that might be.

I am not sure what you are referring to when you talk about the line break problem.

As for zip codes I dont find it too difficult to type 〒 (ゆうびん ) at the beginning.

Of your complaints I agree with second one. It would be nice if some "compound" words were more easily input without having to type full words and then delete the unnecessary dangle at the end.

If you do find a solution to number two, please post. I know I will.

Later.

Last edited by Kroenecker; 06-29-2004 at 08:38 AM.
 
Old 06-29-2004, 10:46 AM   #9
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Kroenecker
Nope. I use Kinput2 and cannaserver. The thing is that my machine remembers what I last entered for me (like windoz~).
Fantastic! This makes me hope for the fix. Now I use kinput2 and jserver. Probably cannaserver is better.
I'll give it a try later tonight after the work.

Quote:
I am not sure what you are referring to when you talk about the line break problem.
Well, this is not really a big problem and here is what I meant.

Let's say I type some text in oowriter, where I got very clear page margins.
I type in romaji and everything is fine: once I reach the right margin, the line breaks and I continue typing on a new line. I don't have to hit Enter in order to get there.
However when I type canna, oowriter does not see the margins. Thus the line go far
beyond the right margin. If I print such a page, the lines outside printable area won't be printed.
This is, as I said, not a big issue because I can see when the line ingore margins.

Quote:
As for zip codes I dont find it too difficult to type 〒 (ゆうびん ) at the beginning.
This is OK on my PC too, but if I type, say 560-0012, my PC doesn't know that this code corresponds to Osaka-fu, Toyonaka-shi etc.
Well, this is not a serious problem either because I can either type it or copy and paste.

Quote:
Of your complaints I agree with second one.
It would be nice if some "compound" words were more easily input without having to type full words and then delete the unnecessary dangle at the end.
If you do find a solution to number two, please post. I know I will.
Of course, if I find it I let you know.

Thanks again for your advise.
 
Old 06-30-2004, 12:43 PM   #10
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
I did not try yet canna, but I am struggling with an unexpected problem.
When I try to import my years old address books (CSV) into KMail or Thunderbird, neither will display the names written in Japanese correctly. Any tip?
 
Old 07-04-2004, 02:55 PM   #11
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Dear Kroeneker,
What E/J-J/E dictionary do you use?
Now my japanese system seems to work quite well, except that I don't find what the dictionary to compile into it.
Btw, now the kinput2 + jserver works well. I changed "kinput2 &" into "kinput2 -xim -kinput &"
 
Old 07-04-2004, 06:31 PM   #12
GaijinPunch
Member
 
Registered: Aug 2003
Location: Tokyo, Japan
Distribution: Gentoo
Posts: 130

Rep: Reputation: 22
My first guess on your address book would be an encoding issue. My Suse 8.1 system encodes everything in EUC by default, but some of the applications like to use Shift-JIS. There is unfortuantely no easy way around this that I can think of.

Other question:
What exactly is jserver? Is it substitute for cannaserver? I've been using kinput2 & cannaserver for a couple of years now (basically as long as I've used linux). I'm very used to it, but I can't say that it's fantastic. I find it to be rather stupid, almost always choosing the most obscure kanji from a list of 50.
 
Old 07-04-2004, 09:05 PM   #13
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
NOTE: I just found a very nice looking dictionary here --> http://gjiten.sourceforge.net/

I usually just use Jim Breens website to do conversions. It is really nice because I can enter a paragraph of Japanese text, and in response I get back a list of Japanese words and their definitions. You should check it out. As for Kmail/Thunderbird and exporting, I havent done much of that myself so I can't help you out. Since you already have fonts that work for the rest of your system, I would also have to say that it is some kind of encoding problem.... If you look around in the tool bar (I dont recall which directory you have to look under) you can find a list of possible encodings to use to view the screen. You might try that.

Gaijinpunch, I noticed you live in Tokyo. I live in Toyama and am looking for a job. You wouldn't happen to be involved in IT would you? Ive just started trying to interview. It is going to be an uphill battle, I think, but my Japanese has hit the breaking point where everyday life is easygoing, and I want to continue living here in Japan. Anyway, suggestions are more than welcome.

Last edited by Kroenecker; 07-04-2004 at 09:48 PM.
 
Old 07-04-2004, 09:36 PM   #14
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
To add a bit...

you can check what encoding you system uses by default by typing set at the command line. This will print out your environmental variables. Look for one labeled LANG (do a google to find the other possible environmental variables to do with encoding on your system...most of them have an LC prefix). If you are not sure what to do you can simply type export LANG=ja_JP.eucJP which should give you the proper encoding in that terminal. Then type set again to see the changes. Then run Kmail/Thunderbird to see if this helps out.

I wont admit to being a pro at the encoding stuff. It took me a long time to get everything on my system to be Japanese friendly. (Like xterm...) But in the end it shouldnt be too hard.

Random note:

1 I havent tried this yet but I read that in order to get Kinput2 to run using utf8 you have to add an entry to the configure file (Kinput2) to get this to work.

2 I had to edit that same config file because in Firefox (and I usually use Fluxbox) when the cannaserver pop up window appears it was getting the focus! MAN THAT was EVIL. So everytime I typed something and searched for Kanji I had to refocus Firefox with my mouse.

NOTE: here are the entries for the Kinput2 file (/etc/X11/app-defaults/Kinput2). Notice that comments are preceeded by two exclamation points.

!! I added the .input entries below (three). Should solve the prob!
*SeparateConversion.title: Kana-Kanji Conversion
*selectionShell.title: Candidate Selection
*auxShell.title: Auxiliary Control
*SeparateConversion.input: false
*selectionShell.input: false
*auxShell.input: false


3 What else... to get Openoffice to properly display Japanese characters, I made an alias soffice='GDK_USE_XFT=1 soffice'. This changes what fonts gdk tries to use, I think. I went from illegible toolbar entries and filenames to something useable.

Yeah, Ive had to mess with my system a lot because I use LFS. Oh well. Its been a good challenge in flexing my google skills as well as patience.

So, what have you guys had to do to get your system running Japanese?

Oh and I just found this while surfin

http://im-ja.sourceforge.net/im-ja-doc.html

im-ja....I hadnt heard of it, but it looks pretty.

Last edited by Kroenecker; 07-09-2004 at 09:03 PM.
 
Old 07-06-2004, 02:42 AM   #15
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Thanks for the tips. set and export staff did not work, but, thanks anyway, I learnt smething. I changed the LANG, but the Thunderbird does not want to be typed in Japanese. KMail works.

Anyhow, at the moment I decided to stick with KMail.

Now I will try to get the dictionaries work.

I am happy to see that now there are some experts in getting the things up in the Japanese Linux. When about two years ago I posted couple of questions like that here, nobody replied for weeks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kmail - how to get it to see old Kmail folders? pseudofilosofen Suse/Novell 1 04-19-2005 05:52 AM
Kmail - how to get it to see old Kmail folders? pseudofilosofen Suse/Novell 1 04-18-2005 01:53 PM
Japanese input? clausawits Fedora 4 08-02-2004 06:59 AM
Japanese Input Phil Healey Linux - General 3 07-18-2003 01:10 PM
AIM in Japanese??? phishead Linux - General 1 01-06-2002 05:25 PM


All times are GMT -5. The time now is 04:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration