LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 04-23-2005, 11:21 AM   #1
leemoreau
Member
 
Registered: Jan 2004
Posts: 48

Rep: Reputation: 15
Absolutely CANNOT change folder permissions help!


Hey everyone I had this problem in Warty and now Hoary too , I don't know what I'm doing wrong here. My second hard drive is mounted to /sachi and my apache directory is /sachi/webserver. I'm trying to change the permissions of the webserver folder to 777 because I want to use a photo gallery and its saying all its files and folders must be set to 777. First I tried "chmod 777 /sachi/webserver/ -R" nothing happens. Then I followed the guide and opened nautilus as root "sudo nautilus /sachi", I right clicked different folders and went to permissions. It's set as owner has read write execute checked, group has read and execute, and others has read and execute. If I click on the check mark for write, the check appears then disappears which wont' let me change it at all! If I FTP in and try to change it to 777 it says unable to change permission. All th e guides i've read online make it sound so easy saying just use chmod but it does not work at all. I don't know what I'm doing wrong. Thanks!
 
Old 04-23-2005, 11:53 AM   #2
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Rep: Reputation: 15
I don't know what wrong you are doing, but I would definitely advise not to set the webserver permissions to 777. Anyway, using the command 'chmod -R 777 /path/to/folder' has always worked for me. Again, think of a better option than to open up your entire webserver folder.
 
Old 04-23-2005, 12:02 PM   #3
leemoreau
Member
 
Registered: Jan 2004
Posts: 48

Original Poster
Rep: Reputation: 15
It still doesn't work. I'm not going to open the whole directory, just an example. The photo galelry is coppermine, its under /sacehi/webserver/coppermine but the include, albums, etc folders in there need to be 777. I just did what you said and it still doesn't work. I don't know why this won't work, I had the same problem with warty and now with hoary. It's so weird, nothing will work. It's strange even in nautilus it won't let me do it. I really LOVE ubuntu but I always have this problem, I'm writing exactly as said "sudo chmod -R 777 /sachi/webserver/coppermine/include" it doesn't say any confirmation just gives me the prompt but still hjasn't changed
 
Old 04-26-2005, 09:26 PM   #4
coldsalmon
Member
 
Registered: Mar 2005
Location: USA
Distribution: Kubuntu Breezy
Posts: 79

Rep: Reputation: 15
Have you tried using a different syntax? You could use a+rwx (I think that's what you want) instead of 777 and see if that works.

--C
 
Old 04-26-2005, 10:30 PM   #5
leemoreau
Member
 
Registered: Jan 2004
Posts: 48

Original Poster
Rep: Reputation: 15
I figured it out the reason was because it was on my FAT32 slave drive which obviously doesn;t work well wi th permissions. Formatted it EXT3 worked fine, thanks!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FOLDER permissions change automatically Echo Kilo Linux - Newbie 5 08-21-2005 03:09 AM
permissions difference between /home/..../folder and /root/folder darkleaf Linux - General 3 07-21-2005 05:23 PM
Script to change folder permissions waitingforOES Linux - Newbie 1 03-07-2005 01:34 PM
Change folder permissions eggoz Linux - Newbie 2 03-17-2003 01:35 AM
Folder permissions fatboyjim Linux - Newbie 12 06-05-2002 02:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 05:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration