LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Absolutely CANNOT change folder permissions help! (https://www.linuxquestions.org/questions/ubuntu-63/absolutely-cannot-change-folder-permissions-help-316394/)

leemoreau 04-23-2005 12:21 PM

Absolutely CANNOT change folder permissions help!
 
Hey everyone I had this problem in Warty and now Hoary too , I don't know what I'm doing wrong here. My second hard drive is mounted to /sachi and my apache directory is /sachi/webserver. I'm trying to change the permissions of the webserver folder to 777 because I want to use a photo gallery and its saying all its files and folders must be set to 777. First I tried "chmod 777 /sachi/webserver/ -R" nothing happens. Then I followed the guide and opened nautilus as root "sudo nautilus /sachi", I right clicked different folders and went to permissions. It's set as owner has read write execute checked, group has read and execute, and others has read and execute. If I click on the check mark for write, the check appears then disappears which wont' let me change it at all! If I FTP in and try to change it to 777 it says unable to change permission. All th e guides i've read online make it sound so easy saying just use chmod but it does not work at all. I don't know what I'm doing wrong. Thanks!

usercsr 04-23-2005 12:53 PM

I don't know what wrong you are doing, but I would definitely advise not to set the webserver permissions to 777. Anyway, using the command 'chmod -R 777 /path/to/folder' has always worked for me. Again, think of a better option than to open up your entire webserver folder.

leemoreau 04-23-2005 01:02 PM

It still doesn't work. I'm not going to open the whole directory, just an example. The photo galelry is coppermine, its under /sacehi/webserver/coppermine but the include, albums, etc folders in there need to be 777. I just did what you said and it still doesn't work. I don't know why this won't work, I had the same problem with warty and now with hoary. It's so weird, nothing will work. It's strange even in nautilus it won't let me do it. I really LOVE ubuntu but I always have this problem, I'm writing exactly as said "sudo chmod -R 777 /sachi/webserver/coppermine/include" it doesn't say any confirmation just gives me the prompt but still hjasn't changed :(

coldsalmon 04-26-2005 10:26 PM

Have you tried using a different syntax? You could use a+rwx (I think that's what you want) instead of 777 and see if that works.

--C

leemoreau 04-26-2005 11:30 PM

I figured it out the reason was because it was on my FAT32 slave drive which obviously doesn;t work well wi th permissions. Formatted it EXT3 worked fine, thanks!!!


All times are GMT -5. The time now is 06:11 PM.