LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 11-06-2005, 12:24 PM   #16
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492

Just buy the blastwave DVD and you'll have all dependancies on it.

Otherwise, you can look at the initial package dependancies in it, and follow them recursively. Of course, you should limit that to the CSW packages.

They are displayed in the package pages, e.g.:
http://www.blastwave.org/packages.php/gcc4core
 
Old 11-06-2005, 02:20 PM   #17
AgentX
Member
 
Registered: Sep 2005
Posts: 43

Rep: Reputation: 15
rsync'ing the x86 repository right now. Will definitely buy a DVD or subscription.
Thanks for the packages page, it's really useful and exactly what I needed. Don't know how I missed it.
 
Old 11-07-2005, 01:47 AM   #18
saudoi
Member
 
Registered: Aug 2004
Location: VietNam
Distribution: Sun Solaris 10
Posts: 117

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jlliagre
Put the CD-ROM containing gcc in your drive, then run something like:
Code:
cd /cdrom/cdrom0/Solaris_10/Product
pkgadd -d . SUNWgccmn
pkgadd -d . SUNWgccruntime
pkgadd -d . SUNWgcc
Then, get gcc patches from sunsolve, as it seems the initial Solaris 10 gcc had several bugs.
Alternatively, you can install gcc from blastwave:
Code:
pkg-get -i gcc
Finally, you can go the Solaris Express way, and use Sun's own compiler for free as a member of the OpenSolaris community.
I'm sorry but I have some questions:
1- I've tried to use pkgadd command to add gcc package from Solaris CDROMs, it's ok. I have no problem. I will check th patches from SUN later.

2- When I try "pkg-get" command, i see the error: "Command not found". And I don't understand what does "blastwave" mean?

3- It's the same as "Blastwave", I'm confused by "Solaris Express" and "Sun's compiler for free"

However, if I was successful with pkgadd -d ......, is it okay? "pkg-get" and "Solaris Express" are only another ways to install packages in Solaris, rite ?

Thx.
 
Old 11-07-2005, 02:28 AM   #19
saudoi
Member
 
Registered: Aug 2004
Location: VietNam
Distribution: Sun Solaris 10
Posts: 117

Original Poster
Rep: Reputation: 15
hmm, after I installed gcc, I still have this error:
Code:
-bash-3.00# ./configure
checking build system type... sparc-sun-solaris2.10
checking host system type... sparc-sun-solaris2.10
checking target system type... sparc-sun-solaris2.10
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
I try some ways to add /usr/sfw/bin to $PATH as:

1. Edit files:
Code:
-bash-3.00# cat /etc/skel/.profile
#       This is the default standard profile provided to a user.
#       They are expected to edit it to meet their own needs.

PATH=/usr/sbin:/usr/bin:/usr/sfw/bin
MAIL=/usr/mail/${LOGNAME:?}
-bash-3.00# cat /etc/skel/local.profile
#
# Copyright (c) 2001 by Sun Microsystems, Inc.
# All rights reserved.
#
# ident "@(#)local.profile      1.10    01/06/23 SMI"
stty istrip
PATH=/usr/bin:/usr/ucb:/etc:/usr/sfw/bin:.
export PATH
-bash-3.00#
Howerver, after logout / login, $PATH isn't changed.
Code:
-bash-3.00# echo $PATH
/usr/sbin:/usr/bin
2. try to export directly:
Code:
-bash-3.00# PATH=/usr/sbin:/usr/bin:/usr/sfw/bin/; export PATH
-bash-3.00# echo $PATH
/usr/sbin:/usr/bin:/usr/sfw/bin/
-bash-3.00#
It work but can not "make" also


Last edited by saudoi; 11-07-2005 at 02:34 AM.
 
Old 11-07-2005, 03:37 AM   #20
AgentX
Member
 
Registered: Sep 2005
Posts: 43

Rep: Reputation: 15
1. pkgadd/pkgrm etc are native Solaris programs to manage packages. Use them as root, and you should have no problems.
2. You need to install pkg-get from www.blastwave.org. Only then you'll be able to use it to install packages from the Blastwave repository.
3. Blastwave is www.blastwave.org. Solaris Express is is the latest version in beta release. Solaris 11 will be based on the same codebase.
4. SUN's free compiler is available as Sun Studio 10 for OpenSolaris developers. Get it from www.opensolaris.org Downloads section.
5. pkgadd -d is okay. pkg-get is only an enhanced version, designed for use with Blastwave and similar repositories with dependency resolution.
6. Remove /usr/ucb from PATH or at least move it to the last.
7. DO NOT edit /etc/skel/.profle or any file in that directory. Make necessary changes to ~/.profile.
8. Editing /etc/skel/.profile isn't working because the file .profile in that directory is copied to the user's HOME dir only when the user is created.
9. The global profile is /etc/profile
10. Try gmake with GCC.
 
Old 11-07-2005, 10:30 AM   #21
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
AgentX
newbie
Definitively not

Last edited by jlliagre; 11-07-2005 at 12:13 PM.
 
Old 11-07-2005, 10:56 AM   #22
AgentX
Member
 
Registered: Sep 2005
Posts: 43

Rep: Reputation: 15
I'm only learning.
 
Old 11-07-2005, 08:32 PM   #23
saudoi
Member
 
Registered: Aug 2004
Location: VietNam
Distribution: Sun Solaris 10
Posts: 117

Original Poster
Rep: Reputation: 15
Thx AgenX.

Root doesn't have ~/.profile file and "gmake" also has error like this:

Code:
-bash-3.00# PATH=/usr/sbin:/usr/bin:/usr/sfw/bin; export PATH
-bash-3.00# echo $PATH
/usr/sbin:/usr/bin:/usr/sfw/bin
-bash-3.00# pwd
/usr/src/proftpd-1.2.10
-bash-3.00# gmake
echo \#define BUILD_STAMP \"`date`\" >include/buildstamp.h
cd lib/ && make lib
/bin/sh: make: not found
gmake: *** [lib] Error 1
 
Old 11-08-2005, 12:55 AM   #24
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
Root doesn't have ~/.profile file
You are free to create one, or to set the global /etc/profile file instead.
You are also free to use a regular account instead of root, it is in fact recommended never to use the root account but when absolutely necessary.
Quote:
/bin/sh: make: not found
Add /usr/ccs/bin to your PATH.
 
Old 11-08-2005, 02:18 AM   #25
saudoi
Member
 
Registered: Aug 2004
Location: VietNam
Distribution: Sun Solaris 10
Posts: 117

Original Poster
Rep: Reputation: 15
okie, I can install it now, thx jlliagre.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with proftpd abudabis Linux - Software 0 02-11-2005 07:08 AM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 10:27 AM
Proftpd problem kelper Linux - Networking 11 04-01-2004 12:07 PM
proftpd problem thesnaggle Linux - Software 1 10-27-2003 11:20 AM
proftpd problem dsgdevil Linux - General 5 10-13-2003 12:02 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 02:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration