LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-02-2019, 11:52 AM   #1
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,404
Blog Entries: 1

Rep: Reputation: Disabled
Angry xterm is being terrible customized in -current


It just obvious. Xterm is almost unresponsive to its standard built in menu. With predefined fonts is completely useless for commands with long listings: eg. mail clients. It is supposed to be functional tool - so lets go back to its previous predefined settings - even konsole in KDE 4 is better customized - and what is important it allows easy done settings. If someone is looking for more nicer looking terminal emulator there is of course xfce-terminal. Do you believe that in fully maximized xterm on my 1200x800 screen is exactly 37 lines of input/output? In other words full screen terminal listing contains 37 lines. This almost VGA standard 24 lines on terminal. Manipulating font sizes does not help much - they are just being almost unreadable. Of course I can always switch to virtual console - and I often do - which ha 80 lines of input.
 
Old 11-02-2019, 12:59 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,731

Rep: Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296Reputation: 6296
I have no idea what you are talking about. XTerm looks perfectly fine to me, also in fullscreen 1920x1024 resolution. Slackware-current has a new set of defaults for XTerm since January 2019 annd use Terminus as the default font, Do you have the correct app-defaults file installed?

And what do you mean with 'unresponsive'? I can not understand what you are hinting at, You mention 'mail client'. I use pine in a 1920x1024 pixels XTerm and my inbox has over 17,000 emails in it. Page-by-page scrolling is instantaneous, no visible delay when scrolling through the list with emails.
 
Old 11-02-2019, 01:19 PM   #3
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,404

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
I was not precise enough. It is number of line per screen - on my listing of mail box there were all 37 lines on whole visible area. I hope you will agree it is definitely to few to work comfortable with long listings. I tried to help myself and I used menu to change font settings but none combination of settings was satisfactory. Even if I obtained greater number of lines text was difficult to read because font is set to bold and I can't change that through the menu. I am not complaining xterm does not work - but is poorly configured by default. On my Slackware 14.2 there is 61 lines per 1 screen. Just try seq n with correct n. So it is as twice as it offers xterm in -current. Of course problem is - what to consider default setting - shipped just with Slackware - versus custom. Because I can only make my own custom settings. So the question is: why default settings for xterm were changed? What was wrong with previous?
 
1 members found this post helpful.
Old 11-02-2019, 01:28 PM   #4
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,787

Rep: Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724
Previous settings were the upstream defaults. I pretty much never used xterm, and I'd have to say that was mostly because the stock settings with a white background and tiny fonts were mostly unreadable for me. So when GazL offered some improvements to the default settings, I had a look at them and agreed that they were an improvement and added them to the package.

If you don't agree, just do this and you'll be back at the old starting point:

Code:
cp /etc/X11/app-defaults/XTerm.upstream.default /etc/X11/app-defaults/XTerm
The new settings were put in place on January 1st, so if they were truly "terrible" I'd have expected more torches and pitchforks by now ;-), but you or anyone else may feel free to weigh in here with their suggestions.
 
4 members found this post helpful.
Old 11-02-2019, 01:49 PM   #5
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,404

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
I agree that black small font on white background is difficult to read - myself I use green fonts on black which in full screen mode is quite readable and some apps just need densely packed lines. However this is can be done with simple command xterm -bg black -fg green. And it is easy to reconfigure xterm on fly with build in menu. Eg. to obtain large font. I was referring to xterm in 14.2. Now in -current when one starts xterm and use ctrl+rigth button menu - many option can't be changed - don't know - this comes from upstream or is it how xterm is being compiled for Slackware?

Last edited by igadoter; 11-02-2019 at 01:57 PM.
 
Old 11-02-2019, 02:10 PM   #6
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,787

Rep: Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724
Quote:
Originally Posted by igadoter View Post
I agree that black small font on white background is difficult to read - myself I use green fonts on black which in full screen mode is quite readable and some apps just need densely packed lines. However this is can be done with simple command xterm -bg black -fg green. And it is easy to reconfigure xterm on fly with build in menu. Eg. to obtain large font. I was referring to xterm in 14.2. Now in -current when one starts xterm and use ctrl+rigth button menu - many option can't be changed - don't know - this comes from upstream or is it how xterm is being compiled for Slackware?
Other than the app-defaults, the only changes in how xterm is built on -current are the addition of --enable-regis-graphics and --enable-sixel-graphics. I don't think those build options would impact the crtl+right button menu. But I see in your previous comments that you were trying to disable bold fonts and not noticing an effect. Perhaps this is because the default font is terminus-bold.

Maybe it would be better if we specified the non-bold terminus font and then set XTerm*boldMode: true, so that it could be disabled through the menu?
 
1 members found this post helpful.
Old 11-02-2019, 02:24 PM   #7
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,404

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by volkerdi View Post
Maybe it would be better if we specified the non-bold terminus font and then set XTerm*boldMode: true, so that it could be disabled through the menu?
Yeap, agree. Bold fonts how they looks it depends much on display in use. So I think it is better to have option to enable/disable bold fonts.
 
Old 11-02-2019, 02:52 PM   #8
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,787

Rep: Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724Reputation: 5724
Quote:
Originally Posted by igadoter View Post
Yeap, agree. Bold fonts how they looks it depends much on display in use. So I think it is better to have option to enable/disable bold fonts.
OK, I'll start with that change then. Thanks!
 
3 members found this post helpful.
Old 11-02-2019, 03:05 PM   #9
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,249
Blog Entries: 18

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991
Not everyone has good eyesight and I find the new defaults comfortable, and 37 lines more than sufficient, and there's always shift-keypad-minus if you need more columns/lines, but feel free to change it however you want. I'm quite content to customise it to my own needs, like I always have done.

The Xterm xresources I posted are just what suit me. I never expected Pat to adopt them as the defaults (not least because I turned off things like underline to more accurately emulate the linux virtual terminals).

I actually prefer the bold variant of terminus to the non-bold one, but like I said, I'm happy to go my own way, so do whatever keeps most people happy.
 
1 members found this post helpful.
Old 11-02-2019, 03:18 PM   #10
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 197

Rep: Reputation: 84
I use Dejavu sans mono with uxterm and tried the same with xterm, but it does not seem to care what i specify in .Xdefaults
anymore. Maybe I'm doing something wrong. Command line options work as usual though.
I do agree that xterm becomes beefy with default fonts. On a 1920x1080 it takes up most of the screen, On my 4k ist just perfect!
 
Old 11-02-2019, 03:36 PM   #11
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 479

Rep: Reputation: 253Reputation: 253Reputation: 253
Philosophically I prefer the idea of keeping things as vanilla to upstream as possible.

But I have to say, GazL's settings to me look terrific because they allow xterm to match the look of the Linux console on Slackware.

If you try running just 'xterm' from your xinitrc on current you'll see what I mean especially.
 
1 members found this post helpful.
Old 11-02-2019, 03:40 PM   #12
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,249
Blog Entries: 18

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991
Rogan, try setting the vt100.renderFont: true, otherwise it'll just use the bitmap fonts and ignore the ones specified in facename.

Also, use .Xresources not .Xdefaults which only gets used if there are no resources loaded into the Xserver's RESOURCE_MANAGER string.

----
that's also a good way of switching back to ttf fonts for anyone who doesn't like the bitmap ones.

Last edited by GazL; 11-02-2019 at 05:42 PM. Reason: oops meant true
 
2 members found this post helpful.
Old 11-02-2019, 03:43 PM   #13
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,249
Blog Entries: 18

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991
Quote:
Originally Posted by Poprocks View Post
If you try running just 'xterm' from your xinitrc on current you'll see what I mean especially.
or just press alt-enter to fullscreen it. Making it look exactly like the console was why I wrote those resources in the first place.


I accept that some folks will find the fonts a little too big, especially on low dpi screens.
 
Old 11-02-2019, 04:55 PM   #14
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,249
Blog Entries: 18

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991
Pat, speaking of xterm. I noticed that the 'rep' feature has been added to xterm-256color/xterm-16color terminfo entries at some point along the way, so the customisation that we've been doing to the xterm-new def to add it is no longer of any use.

edit:
Code:
Sat Nov  2 18:52:12 UTC 2019
a/aaa_terminfo-6.1_20191026-x86_64-1.txz:  Upgraded.
a/cryptsetup-2.2.2-x86_64-1.txz:  Upgraded.
a/lvm2-2.03.06-x86_64-1.txz:  Upgraded.
d/Cython-0.29.14-x86_64-1.txz:  Upgraded.
l/ncurses-6.1_20191026-x86_64-1.txz:  Upgraded.
  Restore the --without-normal option to skip static libraries as used in 14.2.
  Thanks to Richard Narron.
x/xterm-349-x86_64-2.txz:  Rebuilt.
  In /etc/app-defaults/XTerm, use terminus-medium instead of terminus-bold.
  Thanks to igadoter.
Oops, guess my timing could have been better.

Last edited by GazL; 11-02-2019 at 05:48 PM.
 
Old 11-02-2019, 06:13 PM   #15
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 197

Rep: Reputation: 84
Quote:
Originally Posted by GazL View Post
Rogan, try setting the vt100.renderFont: true, otherwise it'll just use the bitmap fonts and ignore the ones specified in facename.

Also, use .Xresources not .Xdefaults which only gets used if there are no resources loaded into the Xserver's RESOURCE_MANAGER string.

----
that's also a good way of switching back to ttf fonts for anyone who doesn't like the bitmap ones.
Thanks Gazl!
I did not know about the XTerm.VT100.renderfont thing. Is it a new option?. I've been scrolling through
that manpage som many times now I should have remembered it. I usually force .Xdefaults loading with xrdb
in .xinitrc but it's good to finally know the difference between .Xresouces and .Xdefaults.
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xterm -display remote:0.0 Can't open display - xterm from tru64 to debian 3.1 loopy69 Linux - Software 2 04-01-2008 07:54 PM
xterm - howto lauch an xterm into a specific directory jobano Linux - Software 8 02-26-2008 04:18 PM
When I tries to execute the xterm i got this message: xterm: no available ptys johnsanty Other *NIX 4 09-20-2006 01:29 PM
xterm alt becomes compose? Only xterm affected. -0- Linux - Software 0 09-13-2006 12:59 AM
how is black xterm background in IceWM when issue a xterm command? BRAHmS Linux - Software 1 02-14-2005 04:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration