LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-02-2019, 07:36 PM   #16
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,250
Blog Entries: 18

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991

It's not new, it's been around a while, but it's set to false in the app-defaults file that I use and which Pat adopted in current.

You can actually switch between bitmap and ttf fonts by holding down ctrl and right clicking: there's a truetype option about half way down the menu that pops up.


RE: .Xdefaults vs .Xresources. It varies with Distro.

Back before X11R5 (or possibly 4), there was the app-defaults file for the app, and then the user's ~/.Xdefaults. The applications would read that file directly from the local disk when it ran: usually during the libXt initialisation routines. Then with R5 someone had the idea that it'd be cool to store the resources in the XServer itself so that they could be accessed from any host that uses the display server (remember that X is network transparent so an Xserver can be shared), and xrdb and the RESOURCE_MANAGER string was invented.

What confused things is that some UNIX vendors/linux distro's chose to invent a new file from which the xrdb resources were to be loaded into the Xserver: ~/.Xresources, while others just decided to repurpose ~/.Xdefaults and load that into the Xserver.

For compatibility, apps should fallback to directly reading the resources from ~/.Xdefaults on disk, but should only do so if there is no xrdb RESOURCE_MANAGER string present in the Xserver.

Which of these two approaches is more correct I'm not entirely sure, but that's the story behind the two files to the best of my understanding.

I believe Redhat still uses a .Xdefaults for this.

----
alternatively, .Xresources came along later, but not everyone adopted it. Either way, we ended up with some using .Xdefaults, and some using .Xresources.

Last edited by GazL; 11-02-2019 at 07:47 PM.
 
2 members found this post helpful.
Old 11-02-2019, 07:52 PM   #17
gus3
Member
 
Registered: Jun 2014
Distribution: Slackware (x86 and ARM)
Posts: 207

Rep: Reputation: Disabled
I know Slackware tends to be "old-school," but this thread just went "older-school."
 
2 members found this post helpful.
Old 11-03-2019, 06:42 AM   #18
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,405

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by GazL View Post
Not everyone has good eyesight and I find the new defaults comfortable, and 37 lines more than sufficient, and there's always shift-keypad-minus if you need more columns/lines, but feel free to change it however you want.
To obtain 61 lines per screen marks font to be unreadable in xterm menu. Which is evidently not correct cause in my setting green color font on black background they are quite comfortable to read. In default xterm settings to choose font to be unreadable has funny effect. Never figured out what is the purpose of this option except of course some fun. Now just came to my mind it can be useful in ascii art.
 
Old 11-03-2019, 06:52 AM   #19
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,405

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by rogan View Post
Thanks Gazl!
I did not know about the XTerm.VT100.renderfont thing. Is it a new option?
I appreciate GazL work cause one can spend life time on learning all possible settings xterm allows. It is just one of most complex terminal emulator. I never dare ventured too deep. Say: what is tektronic mode in xterm? But maybe I should be more honest and instead of whining sit down and provide myself some useful customization for xterm.

Edit: I have just upgraded xterm - but switching bold or or not makes no difference. Bold face looks exactly the same as non-bold. I just give up.

Last edited by igadoter; 11-03-2019 at 07:22 AM.
 
Old 11-03-2019, 07:34 AM   #20
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,250
Blog Entries: 18

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991
Yes, I'm aware that "unreadable" is actually readable. I set it to the smallest size provided by the terminus font.

Ig' this will probably be what you want:
XTerm.vt100.initialFont: 1
 
2 members found this post helpful.
Old 11-03-2019, 08:26 AM   #21
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 197

Rep: Reputation: 84
You can try the "upstream default" trick mentioned by PV on the previous page
or you can just use uxterm, the xterm wrapper for unicode environments instead
as I understand it's basically the same. I use that version normally since I
like the unicode support.

Xterm is one of the oldest X appliactions around and like almost all
open projects it has gotten it's fair share of 'creeping featuritis'
The amount of features this thing has is, well, overwhelming.
Reading the man page to solve a problem may end up consuming the
better part of your day.

If you would like to try uxterm, hese options should give you a nice
looking terminal with AA fonts:

! UXTerm*loginShell: true
UXTerm*faceName: Dejavu Sans Mono
UXTerm*faceSize: 9
! UXTerm*font: -*-terminus-*-*-*-*-22-*-*-*-*-*-*-*
UXTerm.saveLines: 4096
UXTerm*geometry: 80x40
! hacks to make alt-x and backarrow work
! with emacs in uxterm:
UXTerm*eightBitInput: false
! UXTerm.backarrowKeyIsErase: true
 
2 members found this post helpful.
Old 11-03-2019, 11:57 AM   #22
Markus Wiesner
Member
 
Registered: Mar 2016
Distribution: Slackware
Posts: 47

Rep: Reputation: 83
Quote:
Originally Posted by igadoter View Post
Edit: I have just upgraded xterm - but switching bold or or not makes no difference. Bold face looks exactly the same as non-bold. I just give up.
The "Bold Fonts" switch from Ctrl+Right_Click apparently does not force but allow bold font to be used (resource allowBoldFonts). Assuming the latest patch that changed the default font to terminus-medium, you can see the difference (only with bitmap fonts = "TrueType Fonts" unchecked!) e.g. in Midnight Commander (mc) or with
Code:
echo -e '\e[37;1mbold\e[0m'
When "Bold Fonts" is unchecked it's only brighter (color15 instead of color7 in the echo example), when checked it's really bold (and brighter).
 
1 members found this post helpful.
Old 11-03-2019, 08:42 PM   #23
gus3
Member
 
Registered: Jun 2014
Distribution: Slackware (x86 and ARM)
Posts: 207

Rep: Reputation: Disabled
Thumbs up

Quote:
Originally Posted by rogan View Post
If you would like to try uxterm, these options should give you a nice
looking terminal with AA fonts:
If we were on FB I'd friend you immediately. This is the ancient spell I've been looking for.
 
Old 11-04-2019, 03:54 AM   #24
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 197

Rep: Reputation: 84
I'm happy it was of use
 
Old 11-04-2019, 12:20 PM   #25
EdGr
Member
 
Registered: Dec 2010
Location: California, USA
Distribution: Slackware
Posts: 225

Rep: Reputation: 90
You may want to try vte-2.91

It has command-line options for all settings.
Ed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xterm -display remote:0.0 Can't open display - xterm from tru64 to debian 3.1 loopy69 Linux - Software 2 04-01-2008 07:54 PM
xterm - howto lauch an xterm into a specific directory jobano Linux - Software 8 02-26-2008 04:18 PM
When I tries to execute the xterm i got this message: xterm: no available ptys johnsanty Other *NIX 4 09-20-2006 01:29 PM
xterm alt becomes compose? Only xterm affected. -0- Linux - Software 0 09-13-2006 12:59 AM
how is black xterm background in IceWM when issue a xterm command? BRAHmS Linux - Software 1 02-14-2005 04:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration