LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-29-2010, 07:00 AM   #1
Barx
Member
 
Registered: Jun 2004
Distribution: Slack x86 current
Posts: 134

Rep: Reputation: 16
some graphic corruption with radeon driver after Apr 27 updates


Hi.

Yesterday I've installed last -current updates. My system is always kept to -current.

From today I have some graphic corruption in kde. Until yesterday all was ok. I'm not using compositing engine. My laptop has an X700 mobile

I'm using an xorg.conf config file because I've a multimonitor setup and I have saved xrandr settings directly in xorg.conf

In the xorg.conf file I'm using the radeon driver (not fglrx)

I'm getting some strange behaviour by example when I scroll text, where some line disappear from the screen, and sometimes some grafic element (icons, by example) is replaced by weird elements.

Do someone has got same kind of errors?

Thank you

Goodbye
 
Old 04-29-2010, 08:11 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,421

Rep: Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181
I can't tell anything for sure as I use a nVidia GPU.

But I did notice that there has been a lot of activity about radeon and KMS in Linus' kernel tree recently.

So if you are a bit adventurous you could try a newer kernel, for instance 2.6.34-rc5 (or wait for -rc6, probably soon to be released).
 
Old 04-29-2010, 08:29 AM   #3
LuckyCyborg
Member
 
Registered: Mar 2010
Posts: 341

Rep: Reputation: 108Reputation: 108
Barx, activate the modesetting for the radeon drm module and everthing will be fine.

The easy way is:

echo "options radeon modeset=1" > /etc/modprobe.d/radeon-drm.conf

and reload the radeon drm module or reboot the system
 
Old 04-29-2010, 12:05 PM   #4
Barx
Member
 
Registered: Jun 2004
Distribution: Slack x86 current
Posts: 134

Original Poster
Rep: Reputation: 16
Ok I'have activated the modesetting. Now I cannot restart the system, tomorrow I'll check if the problem is solved.

About the kernel I'm using the last one included in the -current, but I prefer to use this one to avoid time waste on every kernel upgrade
 
Old 04-30-2010, 06:28 AM   #5
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 906
Blog Entries: 4

Rep: Reputation: 136Reputation: 136
Quote:
Originally Posted by Barx View Post
Ok I'have activated the modesetting. Now I cannot restart the system, tomorrow I'll check if the problem is solved.
In addition to the activation of modesetting in /etc/modprobe.d/radeon-drm.conf, I had to load the kernel module at startup to make Xorg work correctly. I added the line:

Code:
/sbin/modprobe radeon
in /etc/rc.d/rc.local

Do not forget to change permission of this file to executable (if it's not already set)

Code:
chmod +x /etc/rc.d/rc.local
 
Old 04-30-2010, 10:54 AM   #6
Barx
Member
 
Registered: Jun 2004
Distribution: Slack x86 current
Posts: 134

Original Poster
Rep: Reputation: 16
Ok .. With modesetting activated the problem seems solved.

I haven't added modprobe radeon in rc.local because radeon module is already loaded automatically

Thank you all for the help

Best regards

Alessandro
 
Old 04-30-2010, 01:46 PM   #7
LuckyCyborg
Member
 
Registered: Mar 2010
Posts: 341

Rep: Reputation: 108Reputation: 108
Well, our friend gegechris99 is right.

If you want a proper 3D acceleration you should load the radeon drm module before to start the X.org server.
 
Old 04-30-2010, 02:18 PM   #8
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 906
Blog Entries: 4

Rep: Reputation: 136Reputation: 136
Quote:
Originally Posted by LuckyCyborg View Post
Well, our friend gegechris99 is right.

If you want a proper 3D acceleration you should load the radeon drm module before to start the X.org server.
From my own investigation (I may be wrong), I need to load the kernel radeon module before X starts because the Slackware generic kernel is not shipped with parameter CONFIG_DRM_RADEON_KMS set:

Code:
less /boot/config-generic-smp-2.6.33.2-smp | grep RADEON
CONFIG_DRM_RADEON=m
# CONFIG_DRM_RADEON_KMS is not set
CONFIG_FB_RADEON=m
CONFIG_FB_RADEON_I2C=y
CONFIG_FB_RADEON_BACKLIGHT=y
# CONFIG_FB_RADEON_DEBUG is not set
I compiled a custom kernel in which CONFIG_DRM_RADEON_KMS=y and the kernel radeon module loaded automatically.

More precisely here are changes for RADEON in my custom kernel:

Code:
less /boot/config-2.6.33-custom | grep RADEON
CONFIG_DRM_RADEON=m
CONFIG_DRM_RADEON_KMS=y
# CONFIG_FB_RADEON is not set

Last edited by gegechris99; 04-30-2010 at 02:21 PM. Reason: info about my custom kernel
 
Old 05-03-2010, 03:58 AM   #9
Barx
Member
 
Registered: Jun 2004
Distribution: Slack x86 current
Posts: 134

Original Poster
Rep: Reputation: 16
Thank you all for the hints.

Now I have some more questions ..

The option CONFIG_DRM_RADEON_KMS should be enabled to have the radeon module loaded correctly on X startup.

But I should get the same result loading manually the module before starting X, is correct?

Instead of putting 'modprobe radeon' in rc.local can I put the line in rc.modules? I think it's the right place. The effect should be identical .. it's only a question of order and coherence.

Thank you
Alessandro
 
Old 05-03-2010, 04:28 AM   #10
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,421

Rep: Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181
As the configure help states, CONFIG_DRM_RADEON_KMS configure kernel mode setting by default when loading the radeon module.

This is highly recommended if your card is supported to take advantage of KMS features.

If not set may be you can get the same result adding the "modeset=yes" or whatever in the modprobe command. You can check that with "modinfo radeon" and have a look at /usr/src/linux/Documentation/kernel-paramleters.txt too (if hopefully it's up to date).

If you want to make sure this module be loaded, yes rc.modules (that is to say the file rc.modules links to) is a good place for the modprobe command.

Last edited by Didier Spaier; 05-03-2010 at 04:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 7600GS Graphic Corruption at POST kipp Linux - Hardware 1 03-26-2009 06:25 PM
Radeon propriety driver, graphic glitches x_terminat_or_3 Linux - Hardware 3 12-30-2007 04:36 PM
Ubuntu with ati's fglrx driver doesn't updates graphic like scrolling, please help! firehorizon Linux - Laptop and Netbook 0 09-02-2006 10:26 AM
IBM T30 with Knoppix 3.3 (Debian) need graphic driver for Radeon 7500 Shengren Linux - Hardware 2 02-21-2004 10:18 AM
Graphic corruption ratman96 Linux - Hardware 2 01-07-2004 07:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration