Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-29-2004, 04:35 AM   #1
Registered: Nov 2003
Location: NE England
Distribution: Slackware 9.1
Posts: 52

Rep: Reputation: 15
Question Slackware Virtual Terminal Problem

I installed Slackware 9.1 last week and I am very happy with it. I think it is much better than Red Hat! Anyway I have a problem:
Only Virtual Terminal 6 works (Ctrl+Alt+F6), the other terminals just show a blinking white cursor. Terminal 1 shows all the boot-up messages.

I have tried searching for an answer but I couldn't find anything that was relevent.

Thanks in advance for your help.

Old 02-29-2004, 06:14 AM   #2
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Rep: Reputation: 31
Make your Slackware boot into text mode ( init 3 ) not graphical one ( init 4 ) by editing /etc/inittab. Now, edit your startup script ( /etc/rc.d/rc.local ).
Add :
/opt/kde/bin/kdm ( if you use KDM )
/usr/bin/gdm ( if you use GDM )

Voila, now you have 6 virtual console......
Old 02-29-2004, 02:44 PM   #3
Senior Member
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Or edit /etc/inittab and add a 4 to c1-5 in these lines
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

That's what controls which terminals are started at what runlevel and Patrick turned off all but 6 in runlevel 4 for whatever reason. (I mean, 6 was left open because there were problems with turning them all off - but I don't get why to turn *any* off.)

Better than either option is just to switch to runlevel 3 and leave it at that. Startx!
Old 02-29-2004, 04:48 PM   #4
Senior Member
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
I have c1 only for 1235, and I added 4 to 2-5, so 2-6 are accessable for rc.4
I left c1 as 1235 because then I can see any error messages that occur before X loads, and then I also don't have to worry about the messages scrolling away because I accidentally log in using TTY1
Old 03-02-2004, 12:01 PM   #5
Registered: Nov 2003
Location: NE England
Distribution: Slackware 9.1
Posts: 52

Original Poster
Rep: Reputation: 15
Thanks Guys

Sorry I haven't posted for a while but thanks for all your suggestions. I ended up using the rc.local approach because I can't work without X at the moment



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual terminal Nawas111 Linux - Hardware 4 11-27-2004 05:02 PM
Problem with Slackware 10 on MS Virtual PC 2004 robo555 Linux - Software 0 10-20-2004 09:43 PM
Virtual terminal problem under kernel2.6.7 expander Linux - General 2 07-07-2004 02:59 PM
problem switching to a virtual terminal sattath Linux - General 3 10-22-2003 07:21 AM
problem switching to a virtual terminal sattath Linux - Newbie 2 10-19-2003 05:43 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:38 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration