LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-11-2018, 11:00 AM   #1231
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,042

Rep: Reputation: 149Reputation: 149

Quote:
Originally Posted by ponce View Post
you can version-bump it to 1.2 and that should build

Code:
diff -Naur aircrack-ng.orig/aircrack-ng.SlackBuild aircrack-ng/aircrack-ng.SlackBuild
--- aircrack-ng.orig/aircrack-ng.SlackBuild     2018-06-10 19:43:52.649273000 +0200
+++ aircrack-ng/aircrack-ng.SlackBuild  2018-06-11 17:33:06.891273000 +0200
@@ -3,7 +3,7 @@
 # Written by Yalla-One <yallaone@gmail.com>
 
 PRGNAM=aircrack-ng
-VERSION=${VERSION:-1.2_beta1}
+VERSION=${VERSION:-1.2}
 BUILD=${BUILD:-1}
 TAG=${TAG:-_SBo}
 
@@ -48,6 +48,8 @@
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
+./autogen.sh
+
 CFLAGS="$SLKCFLAGS" \
 CXXFLAGS="$SLKCFLAGS" \
 make ${OPT}
diff -Naur aircrack-ng.orig/aircrack-ng.info aircrack-ng/aircrack-ng.info
--- aircrack-ng.orig/aircrack-ng.info   2018-06-10 19:43:52.649273000 +0200
+++ aircrack-ng/aircrack-ng.info        2018-06-11 17:32:21.444273000 +0200
@@ -1,8 +1,8 @@
 PRGNAM="aircrack-ng"
-VERSION="1.2_beta1"
+VERSION="1.2"
 HOMEPAGE="http://www.aircrack-ng.org"
-DOWNLOAD="http://download.aircrack-ng.org/aircrack-ng-1.2-beta1.tar.gz"
-MD5SUM="f1cc7e19563bd64964f3584048a1031b"
+DOWNLOAD="https://download.aircrack-ng.org/aircrack-ng-1.2.tar.gz"
+MD5SUM="bb11ec14e1fe505d8d0d51cee0c54df9"
 DOWNLOAD_x86_64=""
 MD5SUM_x86_64=""
 REQUIRES=""
Indeed! Thank you Ponce!!! I could have sworn the website was still listing the beta version.
 
Old 06-11-2018, 07:42 PM   #1232
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 384

Rep: Reputation: 123Reputation: 123
Quote:
Originally Posted by ponce View Post
I just tested it also on stable and pushed the patch on my branch on SBo: the maintainer should be ok with it, but please still try to ping him about it...

https://git.slackbuilds.org/slackbui.../ponce/updates
Thank you ponce and andrew! Right now d2x-rebirth builds correctly.

I wrote the current maintainter as you wished ponce. Let's hope he answers.
 
Old 06-11-2018, 07:45 PM   #1233
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 384

Rep: Reputation: 123Reputation: 123
SDL_sound fails to build in -current; specifically, playsound.c. Seems like PhysFS has again something to do with it:

Code:
make[2]: Entering directory '/tmp/SBo/SDL_sound-1.0.3/playsound'
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..   -DSUPPORT_PHYSFS=1 -O2 -fPIC -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -MT playsound-playsound.o -MD -MP -MF ".deps/playsound-playsound.Tpo" -c -o playsound-playsound.o `test -f 'playsound.c' || echo './'`playsound.c; \
then mv -f ".deps/playsound-playsound.Tpo" ".deps/playsound-playsound.Po"; else rm -f ".deps/playsound-playsound.Tpo"; exit 1; fi
In file included from playsound.c:51:0:
physfsrwops.h:42:1: error: unknown type name ‘__EXPORT__’; did you mean ‘__FXSR__’?
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
 ^~~~~~~~~~
 __FXSR__
physfsrwops.h:42:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
                      ^
physfsrwops.h:54:1: error: unknown type name ‘__EXPORT__’; did you mean ‘__FXSR__’?
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
 ^~~~~~~~~~
 __FXSR__
physfsrwops.h:54:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
                      ^
physfsrwops.h:66:1: error: unknown type name ‘__EXPORT__’; did you mean ‘__FXSR__’?
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
 ^~~~~~~~~~
 __FXSR__
physfsrwops.h:66:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
                      ^
physfsrwops.h:78:1: error: unknown type name ‘__EXPORT__’; did you mean ‘__FXSR__’?
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
 ^~~~~~~~~~
 __FXSR__
physfsrwops.h:78:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
 __EXPORT__ SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
                      ^
playsound.c: In function ‘init_archive’:
playsound.c:215:17: warning: ‘PHYSFS_getLastError’ is deprecated [-Wdeprecated-declarations]
                 PHYSFS_getLastError());
                 ^~~~~~~~~~~~~~~~~~~
In file included from playsound.c:50:0:
/usr/include/physfs.h:654:25: note: declared here
 PHYSFS_DECL const char *PHYSFS_getLastError(void) PHYSFS_DEPRECATED;
                         ^~~~~~~~~~~~~~~~~~~
playsound.c: In function ‘rwops_from_physfs’:
playsound.c:242:9: warning: ‘PHYSFS_addToSearchPath’ is deprecated [-Wdeprecated-declarations]
         if (!PHYSFS_addToSearchPath(archive, 0))
         ^~
In file included from playsound.c:50:0:
/usr/include/physfs.h:851:17: note: declared here
 PHYSFS_DECL int PHYSFS_addToSearchPath(const char *newDir, int appendToPath)
                 ^~~~~~~~~~~~~~~~~~~~~~
playsound.c:245:21: warning: ‘PHYSFS_getLastError’ is deprecated [-Wdeprecated-declarations]
                     PHYSFS_getLastError());
                     ^~~~~~~~~~~~~~~~~~~
In file included from playsound.c:50:0:
/usr/include/physfs.h:654:25: note: declared here
 PHYSFS_DECL const char *PHYSFS_getLastError(void) PHYSFS_DEPRECATED;
                         ^~~~~~~~~~~~~~~~~~~
playsound.c:250:18: warning: implicit declaration of function ‘PHYSFSRWOPS_openRead’; did you mean ‘PHYSFS_openRead’? [-Wimplicit-function-declaration]
         retval = PHYSFSRWOPS_openRead(path);
                  ^~~~~~~~~~~~~~~~~~~~
                  PHYSFS_openRead
playsound.c:250:16: warning: assignment makes pointer from integer without a cast [-Wint-conversion]
         retval = PHYSFSRWOPS_openRead(path);
                ^
playsound.c: In function ‘close_archive’:
playsound.c:292:9: warning: ‘PHYSFS_removeFromSearchPath’ is deprecated [-Wdeprecated-declarations]
         PHYSFS_removeFromSearchPath(archive_name + 1);
         ^~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from playsound.c:50:0:
/usr/include/physfs.h:878:17: note: declared here
 PHYSFS_DECL int PHYSFS_removeFromSearchPath(const char *oldDir)
                 ^~~~~~~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [Makefile:313: playsound-playsound.o] Error 1
make[2]: Leaving directory '/tmp/SBo/SDL_sound-1.0.3/playsound'
make[1]: *** [Makefile:422: all-recursive] Error 1
make[1]: Leaving directory '/tmp/SBo/SDL_sound-1.0.3'
make: *** [Makefile:272: all] Error 2
 
Old 06-11-2018, 09:34 PM   #1234
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 900

Rep: Reputation: 194Reputation: 194
Quote:
Originally Posted by sombragris View Post
Thank you ponce and andrew! Right now d2x-rebirth builds correctly.

I wrote the current maintainter as you wished ponce. Let's hope he answers.
Good news is that I have had an exchange of emails with the current maintainer who is happy to look at things. I am a little curious though: with the release version of D2x-rebirth and PhysFS 3.0.1 do you see a loss of some animations? Specifically these are the animations of the robots seen in the briefings before each new level. I am running the latest git which has addressed these issues but confirmation of the issue would be nice. Bug report exists.

Moving a little away from the purpose of this thread, my apologies..
 
Old 06-11-2018, 09:41 PM   #1235
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,328

Original Poster
Rep: Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265
Quote:
Originally Posted by sombragris View Post
SDL_sound fails to build in -current; specifically, playsound.c. Seems like PhysFS has again something to do with it
add this line between the configure options in SDL_sound.SlackBuild
Code:
  --enable-physfs=no \

Last edited by ponce; 06-11-2018 at 09:42 PM.
 
Old 06-12-2018, 07:58 AM   #1236
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 384

Rep: Reputation: 123Reputation: 123
Quote:
Originally Posted by andrew.46 View Post
Good news is that I have had an exchange of emails with the current maintainer who is happy to look at things. I am a little curious though: with the release version of D2x-rebirth and PhysFS 3.0.1 do you see a loss of some animations? Specifically these are the animations of the robots seen in the briefings before each new level. I am running the latest git which has addressed these issues but confirmation of the issue would be nice. Bug report exists.

Moving a little away from the purpose of this thread, my apologies..
Indeed. I see:
1. No robot animations (briefings)
2. No music (I have the soundrack in mp3 files; when I set the music option to "jukebox" they simply say "cannot open file xxxx.mp3".

In fact, it was issue 2 which prompted me to recompile SDL_sound, which in turn caused the latest report.

I also contacted Alan and he answered me. Thanks for all the help!
 
1 members found this post helpful.
Old 06-12-2018, 08:00 AM   #1237
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 384

Rep: Reputation: 123Reputation: 123
Quote:
Originally Posted by ponce View Post
add this line between the configure options in SDL_sound.SlackBuild
Code:
  --enable-physfs=no \
Thank you ponce! Now it builds OK.
 
Old 06-12-2018, 11:35 PM   #1238
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 900

Rep: Reputation: 194Reputation: 194
Quote:
Originally Posted by sombragris View Post
Indeed. I see:
1. No robot animations (briefings)
2. No music (I have the soundrack in mp3 files; when I set the music option to "jukebox" they simply say "cannot open file xxxx.mp3".
I have put a slightly different dxx-rebirth script online that builds both d1x-rebirth and d2x-rebirth from git rather than the current release version, link here.... In this build the robot animations during the briefings are fixed but I am not sure about the jukebox effect as I could not even see out how this works, but perhaps this will also solve your music issues. (Even if perhaps you are simply happy enough with the downloaded 'AddOn' music packs.)

Remember: different package name so remove any copies of d1x-rebirth and d2x-rebirth before running this script.

Last edited by andrew.46; 06-12-2018 at 11:36 PM.
 
Old 06-13-2018, 08:26 AM   #1239
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,042

Rep: Reputation: 149Reputation: 149
Anybody been successful in building rtmpdump yet? It fails with similar "ctx" errors (SSL). I'll keep playing with the SlackBuild to see if I can get it to compile.
 
Old 06-13-2018, 08:28 AM   #1240
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,042

Rep: Reputation: 149Reputation: 149
Quote:
Originally Posted by stormtracknole View Post
Anybody been successful in building rtmpdump yet? It fails with similar "ctx" errors (SSL). I'll keep playing with the SlackBuild to see if I can get it to compile.
Added the following string to the make statement:
Code:
SYS=posix CRYPTO=GNUTLS SHARED=yes LIB_GNUTLS="-lgnutls -lgcrypt -ldl -lz"
That seems to have made it happy!
 
Old 06-13-2018, 08:58 AM   #1241
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,328

Original Poster
Rep: Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265
rtmpdump builds fine here :/
 
Old 06-13-2018, 09:34 AM   #1242
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,042

Rep: Reputation: 149Reputation: 149
Quote:
Originally Posted by ponce View Post
rtmpdump builds fine here :/
Hmm...weird. Let me look again more closely to see what I'm doing wrong. I obviously have overlooked something.
 
Old 06-13-2018, 09:50 AM   #1243
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,328

Original Poster
Rep: Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265Reputation: 2265
maybe you haven't updated your repository? last month I committed this

http://cgit.ponce.cc/slackbuilds/commit/?h=rtmpdump
 
Old 06-13-2018, 03:08 PM   #1244
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 384

Rep: Reputation: 123Reputation: 123
Quote:
Originally Posted by andrew.46 View Post
I have put a slightly different dxx-rebirth script online that builds both d1x-rebirth and d2x-rebirth from git rather than the current release version, link here.... In this build the robot animations during the briefings are fixed but I am not sure about the jukebox effect as I could not even see out how this works, but perhaps this will also solve your music issues. (Even if perhaps you are simply happy enough with the downloaded 'AddOn' music packs.)

Remember: different package name so remove any copies of d1x-rebirth and d2x-rebirth before running this script.
Your SlackBuild worked wonders. I downloaded the addon music, and built your script, and lo and behold, all those issues were solved. Thank you!

dxx-rebirth still cannot play mp3 music but at least I can have music now!

EDIT: I would like to add that I inspected your SlackBuild because I wanted to tweak some parameters. It is very well written and documented. Thanks!

Last edited by sombragris; 06-13-2018 at 03:12 PM.
 
Old 06-13-2018, 04:39 PM   #1245
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 900

Rep: Reputation: 194Reputation: 194
Quote:
Originally Posted by sombragris View Post
Your SlackBuild worked wonders. I downloaded the addon music, and built your script, and lo and behold, all those issues were solved. Thank you!
This is great news! There is a great script on SBo for the release version but I may continue with this script for the development version. That way I will not tread on any toes and may even enhance the SBo script when development turns to release .

Quote:
dxx-rebirth still cannot play mp3 music but at least I can have music now!
I know we have strained the purpose of this thread somewhat but I am a little curious as to how you were playing mp3 music before? In DOS days I simply used the midi sounds that came with the game, I believe that timidity + a sound font may still allow this and then there are the add-on music files. I have not experimented further...

Quote:
EDIT: I would like to add that I inspected your SlackBuild because I wanted to tweak some parameters. It is very well written and documented. Thanks!
That is a cleaned up version of one of my scripts for 'home use'. In its original state it was near indecipherable . I have a longer term project to clean up all of the 'home' scripts...
 
1 members found this post helpful.
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration