LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-09-2006, 08:55 PM   #1
kenyon
LQ Newbie
 
Registered: Jul 2006
Posts: 14

Rep: Reputation: 0
Mouse frozen. Is it an xorg.conf problem?


After a new install of Slackware 10.2 KDE looks great, but mouse doesn't move.

I've read numerous posts and tried xorgconfig and X -configure,
and several manual edits of xorg.conf, including changing protocol
to IMPS/2 and PS/2, but no mouse movement. Nada.

Any suggestions.

PS - I'm new to slackware.

Thanks.

My mouse is a usb Microsoft "Basic Optical Mouse" USB/PS2 Compatible, pretty generic.

############################################################
# xorg.conf
...
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
EndSection
...
Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection
############################################################
 
Old 07-09-2006, 09:34 PM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 32
You could always burn a minimal LiveCD like Damn Small or the like, then boot that and look to see what it autoconfigures your X with in regards to mouse settings. I don't see at first glance what the issue is unless the USB aspect is causing a glitch, then again you may be able to just google your mouse type and see if others have encountered similar problems.
 
Old 07-09-2006, 10:05 PM   #3
ryanoa
Member
 
Registered: Jan 2006
Location: Santa Cruz, CA
Distribution: Slack 10.2 and 11.0
Posts: 102

Rep: Reputation: 15
mice

Since it is a usb mouse.......
try changing the device option to "/dev/input/mice". Save and restart x. That got mine working.
 
Old 07-09-2006, 11:42 PM   #4
krussell
Member
 
Registered: Jul 2003
Location: dhaka
Distribution: Slackware 11 (fixed), MEPIS
Posts: 241

Rep: Reputation: 30
hello
my usb wheel mouse workds fine with the following option:

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS2"
Option "Device" "/dev/mouse"
Option "Emulate3Buttons"
Option "ZAxisMapping" "4 5"
EndSection
 
Old 07-10-2006, 12:02 AM   #5
evilDagmar
Member
 
Registered: Mar 2005
Location: Right behind you.
Distribution: NBG, then randomed.
Posts: 480

Rep: Reputation: 31
If your mouse is plugged into a USB port (and the USB subsystem actually loaded up) then you have to use /dev/input/mice as the device node (like the previous poster said). If it's plugged into the PS/2 port (the round thing next to the keyboard connector) then you use /dev/psaux. If /dev/mouse exists, it's likely to be a symlink which may or may not be pointing to the correct one of these.

If you actually have the "Basic Optical Mouse" model, it's (as far as I know, and after checking MS's site) just a plain-jane Intellimouse, so IMPS/2 should work as a protocol. Do not use the "Emulate3buttons" option as your mouse wheel is the third button when you press down on it. All you should need to make X aware of your mousewheel is the 'Option "ZAxisMapping" "4 5"' argument added as above.
 
Old 07-10-2006, 11:06 AM   #6
kenyon
LQ Newbie
 
Registered: Jul 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Hi All,
Thanks for you input, but still no luck. Any other ideas???

(I tried all your recommendations, as described below)
1) (Xian), tried I LiveCD (Knoppix V5) and used sections found in /etc/X11/xorg.conf but no luck.
2) (ryanoa), tried changing the device option to "/dev/input/mice", save and restart x, but no luck.
3) (krussell), tried
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS2"
Option "Device" "/dev/mouse"
Option "Emulate3Buttons"
Option "ZAxisMapping" "4 5"
EndSection
4) (EvilDagmar), also tried IMPS/2 and not the "Emulate3buttons" option as your mouse wheel is the third button when you press down on it. All you should need to make X aware of your mousewheel is the 'Option "ZAxisMapping" "4 5"' argument added as above.

-kenyon
 
Old 07-10-2006, 11:39 AM   #7
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,300

Rep: Reputation: 90
As it's a usb mouse it could possibly be a problem with hotplug not recognizing it properly.

This is a shot in the dark, but try uplugging it and plugging it back in and see if hotplug recognizes it then.
 
Old 07-10-2006, 12:26 PM   #8
kenyon
LQ Newbie
 
Registered: Jul 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Hi masonm,

Thanks again, I tried but still no movement.

Perhaps hotplug is not enabled, how to check for that?

-kenyon
 
Old 07-10-2006, 12:59 PM   #9
AzrielMacKay
Member
 
Registered: Jul 2001
Location: Moody, AL
Distribution: Debian and Kubuntu
Posts: 249

Rep: Reputation: 30
You could from a console do cat /dev/input/mice and cat on the other devices you think it might be, and move the mouse around and click some buttons to see if you kernel is seeing it (if it does you'll see jibberish everytime you move it). That would let you know where to start, if its just an x config problem or if its the kernel not seeing it (like you dont have usb support in you kernel etc.)
 
Old 07-10-2006, 01:16 PM   #10
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,300

Rep: Reputation: 90
#9 is a good suggestion. Check dmesg to see if usb support was started during boot.
 
Old 07-10-2006, 01:18 PM   #11
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,300

Rep: Reputation: 90
Quote:
Originally Posted by kenyon
Hi masonm,

Thanks again, I tried but still no movement.

Perhaps hotplug is not enabled, how to check for that?

-kenyon
You should see a message about hotplug starting during boot. Also, do other usb devices work when you hotplug them?
 
Old 07-12-2006, 11:35 AM   #12
kenyon
LQ Newbie
 
Registered: Jul 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Hi All,

Yep, I tried to plug in another usb device (apple shuffle) and it was not able determine much. Also tried to cat /dev/input/mice,

However, I was able to start up a terminal window from KDE without
the mouse and look around.

Here's the output from an egrep of dmesg and some info from /proc
============================================
bash-3.00# egrep -i 'usb|hot' /var/log/dmesg
usbcore: registered new driver usbfs
usbcore: registered new driver hub
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
usbmon: debugfs is not available
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.01:USB HID core driver
PCI0 HUB COM1 COM2 USB1 USB2 USB3 USB4 EUSB PBTN
============================================
bash-3.00# cat /proc/devices # should the mouse show up here???
Character devices:
1 mem
2 pty
3 ttyp
4 /dev/vc/0
4 /tty
4 /ttyS
5 /dev/tty
5 /dev/console
5 /dev/ptmx
7 vcs
10 misc
13 input
29 fb
128 ptm
136 pts
180 usb
253 megadev
254 aac
...

Is this helpful info? Anyways, I'm pretty lost on the usb mouse
issue and don't know where to go from here.

Any ideas?

Thanks,

-Kenyon
 
Old 07-12-2006, 11:49 AM   #13
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Did you by any chance installed test26.s kernel and didn't install it's modules from CD 2?
 
Old 07-12-2006, 12:43 PM   #14
kenyon
LQ Newbie
 
Registered: Jul 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Hi gbonvehi, et al.

Hmm. I did install test26.s. Honestly, at this point I don't know about additional modules, but below the output from lsmod and it is blank.

bash-3.00# lsmod
Module Size Used by
bash-3.00#

How to proceed?

Thanks,

-Kenyon (I'm new to slackware)
 
Old 07-12-2006, 01:37 PM   #15
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Rep: Reputation: 30
Hi. I have a USB mouse too, this are my configs and outputs
Code:
# Option "ChordMiddle"
    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "Protocol" "IMPS/2"
# Option for mouse wheel to work
    Option         "ZAxisMapping" "4 5"
# The mouse device.  The device is normally set to /dev/mouse,
    Option         "Device" "/dev/mouse"
From Xorg config file.

Code:
root@nykey:~# lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 003: ID 04a5:7008 Acer Peripherals Inc. (now BenQ Corp.)
Bus 004 Device 002: ID 09da:0006 A4 Tech Co., Ltd Optical Mouse WOP-35 / Trust 450L Optical Mouse
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
root@nykey:~#
The output of lsusb command.

Code:
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
Part of lspci output.

Code:
root@nykey:~# dmesg | grep usb
usbcore: registered new driver usbfs
usbcore: registered new driver hub
usb usb1: configuration #1 chosen from 1 choice
usb usb2: configuration #1 chosen from 1 choice
usb usb3: configuration #1 chosen from 1 choice
usb usb4: configuration #1 chosen from 1 choice
usb usb5: configuration #1 chosen from 1 choice
usb 4-1: new low speed USB device using uhci_hcd and address 2
usb 4-1: configuration #1 chosen from 1 choice
usb 4-2: new low speed USB device using uhci_hcd and address 3
usb 4-2: configuration #1 chosen from 1 choice
usbcore: registered new driver hiddev
input: USB HID v1.10 Mouse [A4Tech USB Optical Mouse] on usb-0000:00:1d.2-1
input: USB HID v1.10 Keyboard [NOVATEK USB MULTIMEDIA KEYBOARD] on usb-0000:00:1d.2-2
input: USB HID v1.10 Device [NOVATEK USB MULTIMEDIA KEYBOARD] on usb-0000:00:1d.2-2
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
Output from dmesg | grep usb.


You can check the output of these commands and compare them as much as you can. Do a lspci, check there if your USB ports appear and everything is right. After try with a lsusb and see what you get. Then check if you have the modules for test26 installed, you can find them in the "testing" directory, on Slackware CD 1 or CD 2 can't remember right now, just look for it it's on the top of the CD. Install the modules, do a reboot and see if your mouse is working. After you make sure modules are installed and mouse still isn't working, run "mouseconfig" and make sure you choose
Code:
usb         USB connected mouse
option and optionally start GPM at boot. You can use the config I have for my mouse in xorg.conf if you wish, if everything is installed alright they should work as charm, and actually you don't need to have /dev/input/mice , /dev/mouse works if you choose the usb option from "mouseconfig" as I told you. Good luck, and hope this helps solving your problem, or at least a little hand . cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can someone post their xorg.conf mouse settings for mx310 please Old_Fogie Linux - Hardware 3 05-03-2006 11:34 AM
How to set mouse sensitivity in xorg.conf, not window manager lasindi Slackware 8 03-19-2006 05:16 PM
Mouse wheel doesn't scroll in X - what setting in xorg.conf? tdking19 Slackware 3 02-23-2005 10:50 AM
Mouse with Scroll button (FreeBSD 5.3) xorg.conf x86br *BSD 6 10-20-2004 06:33 PM
Boot hangs at starting X11 session after changing mouse settings in xorg.conf drlouis Slackware 9 09-10-2004 12:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration