LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-28-2004, 05:45 AM   #1
mokojin
Member
 
Registered: Feb 2004
Location: Portugal
Distribution: OpenSUSE 10.2
Posts: 78

Rep: Reputation: 15
mount permmissions and auto mount


hei all

2 questions! how can I auto-mount my hard drive windows partitions for when I boot up my linux partiticion?

And how can I give permmissions to the user <mokojin> for reaf access to those partiticions.

thanks in advance.
 
Old 02-28-2004, 07:46 AM   #2
MichaelHall
Member
 
Registered: Feb 2004
Location: Alice Springs
Distribution: Slackware
Posts: 31

Rep: Reputation: 15
bom dia

You could add your windows partition to /etc/fstab, do 'man fstab' or look at the file itself for details. Make sure you use a windows filesystem type (vfat or ntfs probably).

Permissions? It is so long since I've mounted a Windows partition that I can't remember how they're handled. Maybe try 'chown' and 'chmod' to set the permissions you want. I don't think Windows knows or cares about file permissions.

Mick

Last edited by MichaelHall; 02-28-2004 at 07:47 AM.
 
Old 02-28-2004, 10:34 AM   #3
Zig
LQ Newbie
 
Registered: Jun 2003
Posts: 26

Rep: Reputation: 15
you must add:

/de/<dev> /mnt/win vfat defaults, umask=000 1 0

to your fstab file (in /etc)

you must put in <dev> your windows partition and if is not vfat you should put the filesystem that applies.

Like win does not have files permissions (fat32) you can give permissions to a user for that files (i think) so "umask=000" let all the users have acces to the data.
 
Old 02-28-2004, 10:47 AM   #4
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
Code:
/dev/hda6  /Stuff   vfat   defaults,owner,users,exec,rw
this is my windows partition, and if you use "ro" instead
of "rw", your users only have "read" access.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
auto mount true_atlantis Fedora 2 11-03-2005 12:50 PM
Auto mount. non root mount canyon289 Linux - Hardware 1 02-21-2005 10:05 PM
no auto mount jabberwock486 Linux - Hardware 1 07-01-2004 09:59 PM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 12:26 PM
SCRIPT: check if auto-mount mount-points are still mounted markus1982 Linux - Software 0 05-25-2003 05:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration