LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-05-2003, 08:18 AM   #1
Ed-Slack
Member
 
Registered: Dec 2002
Location: the Netherlands
Distribution: Slackware/Gentoo with Fluxbox
Posts: 46

Rep: Reputation: 15
Mount cdrom & cdrw


Hello again, this time for mounting cdrom drive. I get the answer "mount: /dev/cdrom is not a valid block device.


My fstab file contains (as cdrom entries):

...
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0

The command dmesg|gred CD replies:
hda: CD-ROM 32X/AKU, ATAPI CD/DVD-ROM drive
hdb: CD-RW CRX100E, ATAPI CD/DVD-ROM drive
hda: ATAPI 32X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdb: ATAPI 24X CD-ROM CD-R/RW drive, 1024kB Cache, DMA


How can I get these to mount? I read a thread which said make a symlink for the devices: ln -s /dev/hdc /dev/cdrom which I don't understand where to place.

kind regards
 
Old 01-05-2003, 10:47 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
your cdrom is /dev/hda

your cdrw is /dev/hdb
you would type these commands in a shell prompt as root

ln -s /dev/hda /dev/cdrom
ln -s /dev/hdb /dev/cdrw

this is if you do not have scsi emulation enabled on them

check /etc/fstab for hda=ide-scsi or hdb=ide-scsi
 
Old 01-05-2003, 11:09 AM   #3
Ed-Slack
Member
 
Registered: Dec 2002
Location: the Netherlands
Distribution: Slackware/Gentoo with Fluxbox
Posts: 46

Original Poster
Rep: Reputation: 15
Okay I entered the command ln -s /dev/hda /dev/cdrom
It then says ln '/dev/cdrom': file exists

After that I still can't mount my cdrom. As for the other line, those aren't in my fstab file.
 
Old 01-05-2003, 11:22 AM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
use this

ln -sf /dev/hda /dev/cdrom

or remove the /dev/cdrom first
 
Old 01-05-2003, 11:38 AM   #5
Ed-Slack
Member
 
Registered: Dec 2002
Location: the Netherlands
Distribution: Slackware/Gentoo with Fluxbox
Posts: 46

Original Poster
Rep: Reputation: 15
Okay I tried this now too.
It still won't work. It now says (after the mount command):

mount: wrong fs type, bad option, bad superblock on dev/hda, or too many mounted file systems.

My exact fstab file is:


/dev/hdf2 swap swap defaults 0 0
/dev/hdf1 / ext2 defaults 1 1
/dev/hdf5 /usr ext2 defaults 1 2
/dev/hdf6 /home ext2 defaults 1 2
/dev/hdf7 /virtual ext2 defaults 1 2
/dev/hde1 /harddrives/windows vfat defaults 1 0
/dev/hde5 /harddrives/misc vfat defaults 1 0
/dev/hdg1 /harddrives/dos vfat defaults 1 0
/dev/hdg5 /harddrives/docs vfat defaults 1 0
/dev/hdg6 /harddrives/films vfat defaults 1 0
/dev/hdg7 /harddrives/music vfat defaults 1 0
/dev/hdh1 /harddrives/w-soft vfat defaults 1 0
/dev/hdh5 /harddrives/images vfat defaults 1 0
/dev/hdh6 /harddrives/l-soft vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0


I also tried by changing /dev/cdrom to /dev/hda
 
Old 01-05-2003, 12:04 PM   #6
kolargol
Member
 
Registered: Jan 2003
Posts: 46

Rep: Reputation: 1
Maybe you are trying to mount a music cd.
If so don't, just insert the cd in the drive and start a cd playing program.
 
Old 01-05-2003, 07:30 PM   #7
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
good point.

Also you can completely bypass fstab by using the mount command

mount /dev/hda /mnt/cdrom


also try it as root.
 
Old 01-05-2003, 11:44 PM   #8
Ed-Slack
Member
 
Registered: Dec 2002
Location: the Netherlands
Distribution: Slackware/Gentoo with Fluxbox
Posts: 46

Original Poster
Rep: Reputation: 15
Ohhhh. I didn't know that. I was trying to mount a music cd. My fault should have siad so. I'll try this evening if it works. Don't have it at work, haha. But thanks for the tip.

Silly me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't mount CDROM/CDRW/DVDROM/FLOPPY kriidler Slackware 45 07-14-2005 05:09 PM
Setup of cdrom and cdrw - can't mount cd's? matsgl Mandriva 2 02-06-2005 08:26 PM
Changed CDROM to CDRW, Debian can't mount it bcalder01 Linux - Laptop and Netbook 9 09-12-2004 03:33 PM
re: how do I mount my cdrom-which is a cdrw ergo_sum Linux - Hardware 10 11-01-2003 04:37 AM
CDROM, CDRW Mount Harryc Linux - Newbie 5 01-01-2003 05:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration