LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-13-2005, 12:10 AM   #1
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Rep: Reputation: 15
Can't mount CDROM/CDRW/DVDROM/FLOPPY


Hi All,

In a nutshell Do what I want, I can't read any removable media on my PC

More info
Firstly, I thought to myself 'K, before you go posting a new thread asking for help, check if you can't find the answers first!'
well, I did that, and now I'm worse off. (I'm not saying that the answers I got from the forum is bad!)

If it is of any help, here's my fstab file:
Code:
/dev/hda6        swap             swap        defaults         0   0
/dev/hda1        /                ext3        defaults         1   1
/dev/hda5        /home            ext3        defaults         1   2
#/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
#/dev/cdrom       /mnt/cdrom       iso9660     noauto,users,ro  0   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,users     0   0
/dev/dvd         /mnt/dvd         iso9660     noauto,users,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
And here's my PC details:
Code:
1 x HD 40gB partitioned as follows:
           ~1gB       <-- SWAP
         ~20gB ext3 <-- /home
	 ~19gB ext3 <-- /
1 x CDRW
1 x DVDROM
1 x FLOPPY       <-- 3.25 inch stiffy drive
Thanks
K

Last edited by kriidler; 07-13-2005 at 12:13 AM.
 
Old 07-13-2005, 12:18 AM   #2
Smokey
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 313

Rep: Reputation: 30
Are you trying to mount a music cd?
 
Old 07-13-2005, 12:41 AM   #3
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Smokey
Are you trying to mount a music cd?
Hi Smokey.
It doesn't realy matter. I cant read music or data CDs, baught or burned. I can't read movie or data DVDs. Or any floppies I know the physical drives are detected during boot-up as /dev/hdc, /dev/hdd and /dev/fd0.
k
 
Old 07-13-2005, 12:44 AM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Try: mount -t auto /dev/hdd /mnt

If your cd-rom is hdd of course. Take a look at /mnt directory to see if it was mounted. You can try the -t iso9660 option instead of auto.
Music CDs can't be mounted because they don't have a filesystem.

If it was mounted then check the file /dev/cdrom to see if it's pointing to the right device with: ls -l /dev/cdrom
If it's not do: ln -s -f /dev/cdrom /dev/hdd
 
Old 07-13-2005, 12:57 AM   #5
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by gbonvehi
Try: mount -t auto /dev/hdd /mnt

If your cd-rom is hdd of course. Take a look at /mnt directory to see if it was mounted. You can try the -t iso9660 option instead of auto.
Music CDs can't be mounted because they don't have a filesystem.

If it was mounted then check the file /dev/cdrom to see if it's pointing to the right device with: ls -l /dev/cdrom
If it's not do: ln -s -f /dev/cdrom /dev/hdd
Hi,
From bash, using mount -t auto /dev/hdd /mnt
"mount: block device /dev/hdd is write-protected, mounting read-only"
This is what I get when I try to read the cd in konqueror:
"file:/mnt/cdrom doesn't seem to exist anymore"

Using mount -t iso9660 /dev/hdd /mnt
I got :
Code:
mount: block device /dev/hdd is write-protected, mounting read-only
mount: /dev/hdd already mounted or /mnt busy
mount: according to mtab, /dev/hdd is already mounted on /mnt
I'll try the others. goto go now.
 
Old 07-13-2005, 02:09 AM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
It was mounted! It just that it was mounted in /mnt not /mnt/cdrom.
That's why you got the second error, because the /mnt already had the cd mounted on it.
Issue the first command but point it to /mnt/cdrom instead and will work

Code:
mount -t auto /dev/hdd /mnt/cdrom

Last edited by gbonvehi; 07-13-2005 at 02:16 AM.
 
Old 07-13-2005, 01:42 PM   #7
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by gbonvehi
It was mounted! It just that it was mounted in /mnt not /mnt/cdrom.
That's why you got the second error, because the /mnt already had the cd mounted on it.
Issue the first command but point it to /mnt/cdrom instead and will work

Code:
mount -t auto /dev/hdd /mnt/cdrom
Hi again gbonvehi.
I just tried the above and got
Code:
# mount -t auto /dev/hdd /mnt/cdrom
mount: Too many levels of symbolic links
#

note: I tried all the other things you suggested, while we were offline.
"ls -l /dev/cdrom" and "ln -s -f /dev/cdrom /dev/hdd"
I guess that's why I'm getting this error now. Got any ideas on how to undo these?

k
 
Old 07-13-2005, 02:03 PM   #8
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 128Reputation: 128
Please post the output of:
Code:
ls -l /dev/cdrom /dev/hd? /dev/dvd
Also, you might want to change the "users" option in fstab to just "user", which enables user-mounting.
 
Old 07-13-2005, 02:20 PM   #9
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
The symlink command should've been backwards, I'm very sorry that was my fault.
/dev/hdd is now a symlink to /dev/cdrom which is a symlink to /dev/something, that's why you're getting that error.

To fix this, first remove the hdd link with: rm /dev/hdd
Then recreate it with: /dev/MAKEDEV hdd
Then create the correct symlink, this time: ln -sf /dev/hdd /dev/cdrom

Hopefully all should be working by now

Last edited by gbonvehi; 07-13-2005 at 02:24 PM.
 
Old 07-13-2005, 03:10 PM   #10
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Hi Matir,
Quote:
Originally posted by Matir
Please post the output of:
Code:
ls -l /dev/cdrom /dev/hd? /dev/dvd
as requested:
Code:
# ls -l /dev/cdrom /dev/hd? /dev/dvd
lrwxrwxrwx  1 root root      8 2005-07-11 19:26 /dev/cdrom -> /dev/hdc
lrwxrwxrwx  1 root root      8 2005-07-13 08:45 /dev/dvd -> /dev/hdc
brw-rw----  1 root disk  3,  0 2002-06-09 21:27 /dev/hda
brw-rw----  1 root disk  3, 64 2002-06-09 21:27 /dev/hdb
lrwxrwxrwx  1 root root      8 2005-07-13 08:38 /dev/hdc -> /dev/dvd
lrwxrwxrwx  1 root root     10 2005-07-13 08:38 /dev/hdd -> /dev/cdrom
brw-rw----  1 root disk 33,  0 2002-06-09 21:27 /dev/hde
brw-rw----  1 root disk 33, 64 2002-06-09 21:27 /dev/hdf
brw-rw----  1 root disk 34,  0 2002-06-09 21:27 /dev/hdg
brw-rw----  1 root disk 34, 64 2002-06-09 21:28 /dev/hdh
brw-rw----  1 root disk 56,  0 2002-06-09 21:28 /dev/hdi
brw-rw----  1 root disk 56, 64 2002-06-09 21:28 /dev/hdj
brw-rw----  1 root disk 57,  0 2002-06-09 21:28 /dev/hdk
brw-rw----  1 root disk 57, 64 2002-06-09 21:28 /dev/hdl
brw-rw----  1 root disk 88,  0 2003-09-02 22:02 /dev/hdm
brw-rw----  1 root disk 88, 64 2003-09-02 22:02 /dev/hdn
brw-rw----  1 root disk 89,  0 2002-06-09 21:28 /dev/hdo
brw-rw----  1 root disk 89, 64 2002-06-09 21:28 /dev/hdp
brw-rw----  1 root disk 90,  0 2002-06-09 21:28 /dev/hdq
brw-rw----  1 root disk 90, 64 2002-06-09 21:28 /dev/hdr
brw-rw----  1 root disk 91,  0 2002-06-09 21:28 /dev/hds
brw-rw----  1 root disk 91, 64 2002-06-09 21:28 /dev/hdt
#
[quote]
Also, you might want to change the "users" option in fstab to just "user", which enables user-mounting.
[/qoute] Is this "user" is it a group id? because if it is, there's no such group on my pc.
 
Old 07-13-2005, 03:16 PM   #11
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
gbonvehi, in doing what you suggest mean I've got to reboot? Also, will it interfere with the stuff for Matir?
 
Old 07-13-2005, 03:40 PM   #12
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
hi, just did
Code:
rm /dev/hdd
/dev/MAKEDEV hdd
ln -sf /dev/hdd /dev/cdrom
rebooted, and I'm still getting the too many levels error on the cdrom and a no medium found on the dvd!
 
Old 07-13-2005, 03:55 PM   #13
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 128Reputation: 128
Code:
rm /dev/hdc /dev/hdd /dev/dvd /dev/cdrom
/dev/MAKEDEV /dev/hdc
/dev/MAKEDEV /dev/hdd
ln -s /dev/hdc /dev/cdrom
ln -s /dev/hdd /dev/dvd
This assumes your CDROM is your secondary master and your dvd is your secondary slave.
 
Old 07-13-2005, 04:10 PM   #14
kriidler
Member
 
Registered: May 2005
Location: Potchefstroom SA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Matir
This assumes your CDROM is your secondary master and your dvd is your secondary slave.
Hi Matir, how will I confirm this? During boot, I've seen that the dvd is /hdc and the cd is /hdd. is this what you mean? Also, does it matter that the actual cd drive is a cd writr as well?

Thanks
k
 
Old 07-13-2005, 04:15 PM   #15
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 128Reputation: 128
If you saw that during boot, then just switch around the links being created.
Code:
rm /dev/hdc /dev/hdd /dev/dvd /dev/cdrom
/dev/MAKEDEV /dev/hdc
/dev/MAKEDEV /dev/hdd
ln -s /dev/hdc /dev/dvd
ln -s /dev/hdd /dev/cdrom
It does not matter that the cdrom is actually a writer, this is just to give your system some more recognizable names for the devices.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dvdrom & Cdrom Mount Issues AxXium Slackware 18 05-10-2005 08:44 AM
cdrom/dvdrom mount problem salahuddin_66 Slackware 3 05-23-2004 11:17 AM
ATAPI floppy/dvdrom/cdrw automounting, slackware 9.1 Ben2210 Slackware 13 03-02-2004 01:55 AM
re: how do I mount my cdrom-which is a cdrw ergo_sum Linux - Hardware 10 11-01-2003 05:37 AM
CDROM, CDRW Mount Harryc Linux - Newbie 5 01-01-2003 06:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration