LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Mount cdrom & cdrw (https://www.linuxquestions.org/questions/slackware-14/mount-cdrom-and-cdrw-40363/)

Ed-Slack 01-05-2003 08:18 AM

Mount cdrom & cdrw
 
Hello again, this time for mounting cdrom drive. I get the answer "mount: /dev/cdrom is not a valid block device.


My fstab file contains (as cdrom entries):

...
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0

The command dmesg|gred CD replies:
hda: CD-ROM 32X/AKU, ATAPI CD/DVD-ROM drive
hdb: CD-RW CRX100E, ATAPI CD/DVD-ROM drive
hda: ATAPI 32X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdb: ATAPI 24X CD-ROM CD-R/RW drive, 1024kB Cache, DMA


How can I get these to mount? I read a thread which said make a symlink for the devices: ln -s /dev/hdc /dev/cdrom which I don't understand where to place.

kind regards

DavidPhillips 01-05-2003 10:47 AM

your cdrom is /dev/hda

your cdrw is /dev/hdb
you would type these commands in a shell prompt as root

ln -s /dev/hda /dev/cdrom
ln -s /dev/hdb /dev/cdrw

this is if you do not have scsi emulation enabled on them

check /etc/fstab for hda=ide-scsi or hdb=ide-scsi

Ed-Slack 01-05-2003 11:09 AM

Okay I entered the command ln -s /dev/hda /dev/cdrom
It then says ln '/dev/cdrom': file exists

After that I still can't mount my cdrom. As for the other line, those aren't in my fstab file.

DavidPhillips 01-05-2003 11:22 AM

use this

ln -sf /dev/hda /dev/cdrom

or remove the /dev/cdrom first

Ed-Slack 01-05-2003 11:38 AM

Okay I tried this now too.
It still won't work. It now says (after the mount command):

mount: wrong fs type, bad option, bad superblock on dev/hda, or too many mounted file systems.

My exact fstab file is:


/dev/hdf2 swap swap defaults 0 0
/dev/hdf1 / ext2 defaults 1 1
/dev/hdf5 /usr ext2 defaults 1 2
/dev/hdf6 /home ext2 defaults 1 2
/dev/hdf7 /virtual ext2 defaults 1 2
/dev/hde1 /harddrives/windows vfat defaults 1 0
/dev/hde5 /harddrives/misc vfat defaults 1 0
/dev/hdg1 /harddrives/dos vfat defaults 1 0
/dev/hdg5 /harddrives/docs vfat defaults 1 0
/dev/hdg6 /harddrives/films vfat defaults 1 0
/dev/hdg7 /harddrives/music vfat defaults 1 0
/dev/hdh1 /harddrives/w-soft vfat defaults 1 0
/dev/hdh5 /harddrives/images vfat defaults 1 0
/dev/hdh6 /harddrives/l-soft vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0


I also tried by changing /dev/cdrom to /dev/hda

kolargol 01-05-2003 12:04 PM

Maybe you are trying to mount a music cd.
If so don't, just insert the cd in the drive and start a cd playing program.

DavidPhillips 01-05-2003 07:30 PM

good point.

Also you can completely bypass fstab by using the mount command

mount /dev/hda /mnt/cdrom


also try it as root.

Ed-Slack 01-05-2003 11:44 PM

Ohhhh. I didn't know that. I was trying to mount a music cd. My fault should have siad so. I'll try this evening if it works. Don't have it at work, haha. But thanks for the tip.

Silly me


All times are GMT -5. The time now is 09:00 PM.