LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-09-2014, 12:47 AM   #1
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
LILO does not display second OS.


I am asking this question here, because Slackware users are familiar with LILO. I am currently dual-booting Debian and Slackware, with LILO on the Debian partition. I re-installed Debian, including LILO. Previously, this configuration booted both systems.
Code:
image = /boot/vmlinuz
  root = /dev/sda3
  label = "Slackware"
  read-only
With the new installation, however, it did not work. In order to get
Code:
lilo
to recognize Slackware I had to change it to
Code:
image=vmlinuz
root=/dev/sda3
label="Slackware"
read-only
The lilo command results in Slackware being "added," but when booting, an option of systems to boot is not presented. It only displays "Linux" (Debian).
Code:
# Boot up Linux by default.
#
default=Linux
Thinking this might make Debian the default, and only, OS, I commented the line out with a "#", but to no avail.
Code:
# You have the choice between: text, bmp, and menu
I have tried install=menu and install=text, but neither presents a menu of installed systems, as was the case previously. LILO knows Slackware is there (on sda3), but does not include it at boot time. What makes it difficult to figure out what I am missing is that the previous well-working set-up and the current mess are both with Debian Wheezy and LILO. If it helps, here is my entire lilo.conf.
Code:
#boot=/dev/sda
boot = /dev/disk/by-id/ata-ST1000LM024_HN-M101MBB_S2U5J9FD225463

# Specifies the device that should be mounted as root. (`/')
#
#root=/dev/sda1
root = "UUID=60ef56bd-82f4-4ab3-b241-08391b626ae4"

# This option may be needed for some software RAID installs.
#
# raid-extra-boot=mbr-only

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller.  Using `compact' is especially recommended when
# booting from a floppy disk.  It is disabled here by default
# because it doesn't always work.
#
compact

# Installs the specified file as the new boot sector
# You have the choice between: text, bmp, and menu
# Look in lilo.conf(5) manpage for details
#
install=menu

# Specifies the location of the map file
#
map=/boot/map

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration.  If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
#
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
#
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well.  Please RTFM `install-mbr(8)'.
#
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.
#
delay=20

# You can put a customized boot message up if you like.  If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress.  `single-key' goes with the `alias' lines in the
# `image' configurations below.  eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
#
# message=/boot/bootmess.txt
#    prompt
#    delay=100
#    timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
#
# vga=ask
# vga=9
#


# Kernel command line options that apply to all installed images go
# here.  See: The `boot-prompt-HOWTO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
#
# append=""
 
# If you used a serial console to install Debian, this option should be
# enabled by default.
# serial=

#
# Boot up Linux by default.
#
default=Linux

image=/vmlinuz
    label=Linux
    read-only
#    restricted
#    alias=1

    initrd=/initrd.img

image=/vmlinuz.old
    label=LinuxOLD
    read-only
    optional
#    restricted
#    alias=2

    initrd=/initrd.img.old


# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
#

image=/vmlinuz
    root=/dev/sda3
    label="Slackware"
    read-only
 
Old 06-09-2014, 01:04 AM   #2
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: FreeBSD 11.0-Current Slackware64-Current
Posts: 5,107
Blog Entries: 15

Rep: Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509Reputation: 1509
Make sure the Debian partition(s) is mounted and listed in fstab before running liloconfig.
 
Old 06-09-2014, 01:47 AM   #3
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Original Poster
Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
Debian (sda1) is in fstab, which is probably why I can boot it. The slackware partition (sda3) is not, but I am sure it was not in Debian's fstab before the re-installation.
 
Old 06-09-2014, 02:02 AM   #4
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=14, FreeBSD_10{.0|.1|.2}
Posts: 2,891

Rep: Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256
First, it sounds to me as if you have not run lilo after editing the lilo.conf file.

Next, your lilo.conf (as shown above) will try to start Slackware with the Debian kernel (if I have read it correctly).

Remeber that the kernels for ALL listed linuxes must be mounted and visible to lilo at the time when you run lilo. so, for example, if Slackware is on sda3 and Debian is on sda1, and you are writing to MBR (sda), while running Debian then...

Code:
mkdir /mnt/swtmp
mount /dev/sda3 /mnt/swtmp/
... and your Debian lilo.conf must be something like this (with your own paths of course):

Code:
boot = /dev/sda
...
#Debian
image=/boot/vmlinuz
root = /dev/sda1
    label=Debian
    read-only

...
image=/mnt/sw/boot/vmlinuz
root = /dev/sda3
    label=Slackware
    read-only
Then run lilo and reboot.

Again, just remember that the kernel (and initrd if any) must be mounted and reachable at the locations given in lilo.conf when you run lilo - not necessarily their boot time locations.

Last edited by astrogeek; 06-09-2014 at 02:05 AM.
 
Old 06-09-2014, 02:13 AM   #5
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Original Poster
Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
Quote:
First, it sounds to me as if you have not run lilo after editing the lilo.conf file.
It has definitely been run. Several times. And it did report "Added Slackware," which is exactly what happened when I had both systems working fine.
Code:
mkdir /mnt/swtmp
What I used previously, and it worked, was
Code:
mkdir /mnt/sda3
mount /dev/sda3 /mnt/sda3
lilo
umount /dev/dsa3
I shall try your suggestions later today and let you know if it works.
 
Old 06-09-2014, 02:20 AM   #6
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=14, FreeBSD_10{.0|.1|.2}
Posts: 2,891

Rep: Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256Reputation: 1256
Quote:
Originally Posted by Randicus Draco Albus View Post
It has definitely been run. Several times. And it did report "Added Slackware," which is exactly what happened when I had both systems working fine.
Code:
mkdir /mnt/swtmp
What I used previously, and it worked, was
Code:
mkdir /mnt/sda3
mount /dev/sda3 /mnt/sda3
lilo
umount /dev/dsa3
I shall try your suggestions later today and let you know if it works.
In that case, it probably means that lilo is not installing to the partition that is actually booting, or where you think it is, hence Slackware is reported when lilo is run, but does not appear in the list at boot time.

I have confused myself this way before too!

So double check your UUIDs and partition names and make sure they are where you think they are. And if you have multiple disks in the system be sure which one is being booted by the BIOS and that the order is not different than the runtime order.

And to say it one more time, be sure that the paths in lilo are all mounted and correspond to the correct installations at the time lilo is run. fstabs will probably be correct unless the drive order is changing.

Good luck!
 
Old 06-09-2014, 03:24 AM   #7
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Original Poster
Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
Running lilo with Slackware listed as /boot returns a "No such file or directory" message. So apparently you are correct about a problem with where LILO is, which is strange as Hell, since I did not choose its location. The Debian installer did.

I shall post more information after I look around some more.
 
Old 06-09-2014, 03:46 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Try installing Slackware's lilo in Slackware's root, then putting this in Debian's lilo.conf:
Code:
other = /dev/sda3
  label = Slackware
 
Old 06-09-2014, 04:27 AM   #9
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Original Poster
Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
I might try that, but the most likely result will be screwing it up and either having the MBR on Slackware's partition or not being able to boot either system. Unfortunately, I am quite capable of making such a blunder.
 
Old 06-09-2014, 04:34 AM   #10
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
I used that method when I had a Slack + Debian dual-boot. Slack on first, lilo in the MBR, swap, then Debian with its GRUB in /dev/sda3. Worked flawlessly.
 
Old 06-09-2014, 04:38 AM   #11
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Original Poster
Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
But Debian is my main system and I did not install a boot-loader with Slackware. I occasionally dual-boot to test other systems. I like to have one boot-loader, so obviously I put it on the main system and add the other system to it.
 
Old 06-09-2014, 04:51 AM   #12
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
I used to try other distros, dual-booting with Slackware as my main system, but I always installed the other distros' boot-loaders in their root. From what I've read, it seemed easier than the single boot-loader option.
 
Old 06-09-2014, 05:27 AM   #13
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Original Poster
Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
A single boot-loader has been easier for me, until now.
 
Old 06-09-2014, 05:31 AM   #14
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
I'm sure you'll find a solution...maybe.
 
Old 06-09-2014, 05:40 AM   #15
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Distribution: OpenBSD
Posts: 1,519
Blog Entries: 6

Original Poster
Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
I just fired up gparted and according to it LILO is in the right place. sda1 is the boot partition, so LILO can only be there. There are only two bootable partitions: sda1 (Debian) and sda3 (Slackware).
Quote:
I'm sure you'll find a solution
Sledge hammer or foot? Decisions, decisions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO ERROR #1 - Lilo boot loader not installing in VectorLinux 7.0 Light edition. Vexe VectorLinux 4 02-09-2013 09:41 AM
[SOLVED] Edit lilo.conf, run /sbin/lilo, but lilo won't take changes lukameen Slackware 2 02-10-2012 12:10 PM
Lilo cannot display video mode DemoniX Slackware 3 08-06-2005 01:05 PM
Lilo doesnt support higher display res munchkins Slackware 4 05-08-2005 08:37 AM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 05:00 PM


All times are GMT -5. The time now is 12:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration