LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-23-2009, 01:14 PM   #1
CrowTRobot
LQ Newbie
 
Registered: Jun 2009
Distribution: Slackware 13
Posts: 12

Rep: Reputation: 0
Laptop overheats only when running Slackware.


Hello,

I recently installed Slackware 12.2 on my Toshiba Satellite P205D (AMD Athlon 64 X2 - using 32 bit operating systems), and I'm pretty excited to start using it. However, while running Slackware, my computer suddenly powers off, apparently from overheating. I can run it for a while in the console, but when I start X, particularly when using KDE, it overheats after a short time.

I also run Windows XP SP3 on the same computer without any cooling issues. Once, when my computer turned off, I restarted straight into Windows so I could check my core temps. They were around 180 deg F., which is very high. After using XP for a while, they went down to almost 140 deg F., my usual temp for this time of year.

Previous to Slackware 12.2 (kernel 2.6.27.7), I used:

OpenSUSE 11.0 (kernel 2.6.25) no overheating at all.

Debian Lenny (kernel 2.6.26) no overheating, but sometimes locked up when interacting with window managers, like dragging windows.

So it seems like the main difference between Slackware and my others is its kernel being newer. I have the source for 2.30, which I was going to compile but couldn't because of overheating in X. I could try installing it from the console though. I'm hoping the new kernel might fix the problem, especially if I configure it with all the modules. If not, I could downgrade to 2.26, which works. Another possibility is that I simply don't have the right software installed or running which works with cooling.

Any help or suggestions would be greatly appreciated!
 
Old 06-23-2009, 01:31 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,655
Blog Entries: 36

Rep: Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844
Hi,

Welcome to LQ and Slackware!

You don't need 'X' to compile a new kernel. You can take a look at 'Building a Linux Kernel from source'.

Which kernel are you using now?

This link and others are available from 'Slackware-Links'. More than just SlackwareŽ links!
 
Old 06-23-2009, 01:45 PM   #3
CrowTRobot
LQ Newbie
 
Registered: Jun 2009
Distribution: Slackware 13
Posts: 12

Original Poster
Rep: Reputation: 0
I know I don't need to be running an X server to compile the kernel, I just meant I wanted to do it in KDE with 'make xconfig' so it would be easier (less keyboard use). Thanks for the link, it looks like a great guide.

Right now I'm using the kernel included on the install media: 2.6.27.7 hugesmp.s

One thing is I was too lazy to read about the difference between huge.s and hugesmp.s when installing. Could my using hugesmp.s as opposed to huge.s have something to do with my problem?

Also, thanks for the quick response!

EDIT:
After some reading, I found that I chose the right kernel, having two processor cores. However is this the right choice for ANY computer with 2 cores?

Last edited by CrowTRobot; 06-23-2009 at 01:56 PM. Reason: Elaboration
 
Old 06-23-2009, 02:13 PM   #4
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
the principal differences between hugesmp and huge is that the hugesmp kernel has got acpi enabled, this should be one of the features that the hugesmp kernel has got, but make sure that there are minor features, the thing doesn't finish there, any way you choose the right kernel to start(when you'll solve your problem you'll probably switch to a generic kernel that is smaller and faster, it loads less features and modules) ...Any way I compiled my 2.6.30 kernel using "make menuconfig", with ncurses graphical interface, it's easy to use and you've to move with the four buttons of the keyboard...It looks a little faster than xconfig(I'm faster with the keyboard), well, I compiled it in tty without starting X, once finished I just rebooted.

Code:
One thing is I was too lazy to read about the difference between huge.s and hugesmp.s when installing.
Slackware is well documented, use this documentation that is very complete, easy to understand, even a teenager as me learned "how-to use" linux reading wiki, man pages and documentation in general, they're always useful

Last edited by metrofox; 06-23-2009 at 02:15 PM.
 
Old 06-23-2009, 02:48 PM   #5
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Rep: Reputation: 205Reputation: 205Reputation: 205
To my knowledge there is a kernel module to support Toshiba laptops. It is accompanied by some utilities that allow for temperature control etc. Maybe you just have to ensure that this module (I think it has "toshiba" in its name) is loaded.

The difference between Slackwre and other distros is probably NOT the kernel, here, but the fact, that other distros automagically load this module, while in Slackware you have to configure this manually.

Also, ACPI or APM modules may help (or get in your way, if you choose the wrong one for your hardware).

I am pretty sure, that compiling a new kernel will not solve the overheating problem you describe (but it may improve other things, though).

gargamel
 
Old 06-23-2009, 02:55 PM   #6
CrowTRobot
LQ Newbie
 
Registered: Jun 2009
Distribution: Slackware 13
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks gargamel, I'll check for the module and if apm / acpi are running. I think when I was using Debian apm was running and acpi was not, but I'll experiment with those later. It's a fresh install so I have nothing to lose.

I'm probably going to upgrade the kernel eventually, but if I can have my system working right I'll put it off for a while.
 
Old 06-23-2009, 03:03 PM   #7
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Rep: Reputation: 205Reputation: 205Reputation: 205
BTW, KDE comes with some power management functions, that only can be used when all necessary modules are loaded. So, first check for the module, then configure power management in KDE.

I own a Toshiba laptop, too, but I a don't have it with me, right now, so I cannot look at the configuration. But as far as I remember the steps mentioned is just what I did, and everything runs just fine.

Good luck, and, BTW, it would be nice if you could report back, what finally solves your problem.

gargamel
 
Old 06-23-2009, 03:07 PM   #8
CrowTRobot
LQ Newbie
 
Registered: Jun 2009
Distribution: Slackware 13
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks again, I'd take a look at my laptop now but I'm installing something in Windows so I'll share my findings later.
 
Old 06-23-2009, 03:19 PM   #9
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
The two important ACPI modules are 'processor' and 'thermal', and maybe 'fan' might be useful. Make sure they show up in 'lsmod', if not, 'modprobe' them.
 
Old 06-23-2009, 03:22 PM   #10
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Rep: Reputation: 205Reputation: 205Reputation: 205
Correct!
Not sure about any equivalent modules to be used with APM, though.

gargamel
 
Old 06-23-2009, 03:25 PM   #11
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, OpenSuSE
Posts: 1,769

Rep: Reputation: 205Reputation: 205Reputation: 205
BTW, this thread might be of interest to you:

Powermanagement

gargamel
 
Old 06-23-2009, 05:11 PM   #12
Ilgar
Senior Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware64 14.2, Slackwarearm-current
Posts: 1,035

Rep: Reputation: 149Reputation: 149
CrowtRobot did you check (using KSysguard, or "top" in the terminal) whether there's a process stuck with 100% CPU usage? I wouldn't expect a newer kernel to behave so badly. Even if ACPI etc. fail, there should be no reason for CPU to heat up like that unless there's some software using it heavily.
 
Old 06-23-2009, 05:30 PM   #13
CrowTRobot
LQ Newbie
 
Registered: Jun 2009
Distribution: Slackware 13
Posts: 12

Original Poster
Rep: Reputation: 0
I was finally able to reboot into Slack so I did a few checks...

Ilgar: According to top, my CPU usage was under 2%, half of which was top running.

H TeXMeX H: The processor and thermal modules were loaded according to lsmod. I loaded fan with modprobe and now I'm waiting to see how long my computer will stay on.

gargamel: I think the module you're referring to is called toshiba_acpi. I tried to modprobe it in and got the error:

(.../kernel/drivers/acpi/toshiba_acpi.ko): No such device

...Or something very close to this.

As far as I know, this means the module wasn't (correctly) compiled.
 
Old 06-23-2009, 05:36 PM   #14
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,655
Blog Entries: 36

Rep: Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844Reputation: 2844
Hi,

Quote:
excerpt from 'CHANGES_AND_HINTS.TXT';

As stated earlier, it is recommended that you use one of the generic kernels
rather than the huge kernels; the huge kernels are primarily intended as
"installer" and "emergency" kernels in case you forget to make an initrd.
For most systems, you should use the generic SMP kernel if it will run,
even if your system is not SMP-capable. Some newer hardware needs the
local APIC enabled in the SMP kernel, and theoretically there should not be
a performance penalty with using the SMP-capable kernel on a uniprocessor
machine, as the SMP kernel tests for this and makes necessary adjustments.
Furthermore, the kernel sources shipped with Slackware are configured for
SMP usage, so you won't have to modify those to build external modules
(such as NVidia or ATI proprietary drivers) if you use the SMP kernel.

If you decide to use one of the non-SMP kernels, you will need to follow the
instructions in /extra/linux-2.6.27.7-nosmp-sdk/README.TXT to modify your
kernel sources for non-SMP usage. Note that this only applies if you are
using the Slackware-provided non-SMP kernel - if you build a custom kernel,
the symlinks at /lib/modules/$(uname -r)/{build,source} will point to the
correct kernel source so long as you don't (re)move it.
I would suggest that you read all the documentation that PV has provided but the few following will aid you; Announce 12.2, Slackware-Howto, CHANGES_AND_HINTS.TXT, UPGRADE.TXT. Plus the other text files relevant to your needs.

'SlackwareŽ Basics' is another good reference listed in the 'Slackware Reference' section.

These links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!

Last edited by onebuck; 06-23-2009 at 06:54 PM. Reason: correct links to proper version
 
Old 06-23-2009, 05:58 PM   #15
CrowTRobot
LQ Newbie
 
Registered: Jun 2009
Distribution: Slackware 13
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the information onebuck, I'm spending some time reading through it.

As for the current state of my laptop, it's been 30 minutes since login and it's still running fine. Physically, the bottom of the laptop doesn't feel extremely hot, like when it used to shut down. The fan also sounds like it might be running faster than before. When I acutally try to view the temperature, /proc/acpi/thermal_zone is empty. Is there anywhere else the thermal data could be?

I still get errors when trying to modprobe toshiba and toshiba_acpi, but it appears as though some progress has been made.

Thank you for your input gargamel, H TeXMeX H, Ilgar, onebuck, and metrofox.

EDIT:
After doing some research, I found that the toshiba_acpi driver accesses /dev/toshiba, which does not exist. I'm considering recompiling the kernel with the modules. Any suggestions?

Last edited by CrowTRobot; 06-23-2009 at 06:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is anyone running Slackware on a Dell Laptop? joutlancpa Slackware 7 04-04-2009 10:08 PM
Going to be running Slackware on my laptop what are the things I need to worry about darkhatter Slackware 2 09-20-2006 04:01 PM
laptop overheats, and the fans won't turn on! msbigbadwolf Linux - Laptop and Netbook 6 08-11-2005 02:44 PM
Laptop with Slackware overheats! Yalla-One Slackware 3 05-05-2005 05:30 AM
laptop overheats... riddlebox80 Linux - Hardware 4 01-28-2003 08:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration