LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-12-2019, 02:42 AM   #1
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64
Posts: 230

Rep: Reputation: 16
Ktorrent error


Running Slack64-current, latest Plasma5. I read the bit in another thread where Eric had fixed ktorrent and installed his latest -2 version. When I try to start it an error box (Error KTorrent) appears stating -

Malformed URL %25U

Has anyone else encountered this or have a fix? Thanks
 
Old 05-13-2019, 12:07 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,499

Rep: Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827Reputation: 5827
Works fine here, no error on startup - with the latest Slackware64-current and the latest ktown packages.
 
Old 05-14-2019, 12:52 AM   #3
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64
Posts: 230

Original Poster
Rep: Reputation: 16
Thanks for that Eric. Figured it was something unique to my installation. I rebuilt it from source using your script and that got the error box to disappear. When I try to start it from the command line it just returns to the prompt. No error or complaints at all. When I start Plasma ktorrent starts automatically and appears to run fine. It is only after I shutdown the automatic instance that it refuses to start. I'll keep looking.
 
Old 05-14-2019, 01:46 AM   #4
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64
Posts: 230

Original Poster
Rep: Reputation: 16
Got it sorted. Checked all autostart settings in Plasma System settings and .config/autostart and found nothing related to ktorrent. Then a ps -ef|grep torrent showed a ktorrent process running even though the gui was absent. Killed that and ktorrent starts normally as it should. On thing I found though. When I have the ktorrent gui running if I stop it by clicking on the "x" in the uppermost right corner of the screen the gui shuts down but the process is still running. If I shut ktorrent down with Crtl-Q then that kills the gui and the process. Is that normal behaviour? With all other programs that I routinely use clicking on the "x" kills the whole shootin' match.
 
Old 05-14-2019, 05:36 AM   #5
ehartman
Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 529

Rep: Reputation: 252Reputation: 252Reputation: 252
Quote:
Originally Posted by 3rensho View Post
Is that normal behaviour? With all other programs that I routinely use clicking on the "x" kills the whole shootin' match.
Yes, other torrent applications (like azureus/vuze) have the same behaviour: the "x" only makes it into a app inside the desktop tray, but it keeps on running.
You explicitly have to quit the program through the menu's (and confirm that) to get it to really exit.
 
Old 05-14-2019, 06:33 AM   #6
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64
Posts: 230

Original Poster
Rep: Reputation: 16
Thank you for the clarification. Have virtually no experience with torrent apps. I learn something new every day on this site.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ktorrent error hugok Slackware 5 01-28-2019 11:01 AM
Error while installing kTorrent. . . rajanjina Linux - Software 3 07-29-2008 12:40 PM
ktorrent error - will not download a certain torrent ckent Linux - Software 6 07-08-2007 11:13 PM
Error compiling KTorrent from source: No KDE Headers Installed JamesHall Linux - Software 5 06-01-2006 03:35 AM
ktorrent error in suse 10.0 riba43 SUSE / openSUSE 4 03-16-2006 07:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration