LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-27-2019, 06:14 AM   #1
hugok
LQ Newbie
 
Registered: Feb 2014
Location: Porto, Portugal
Distribution: Slackware 14.2 x86_64
Posts: 16

Rep: Reputation: Disabled
ktorrent error


Hello Slackers,

I get an error after i start ktorrent showing this:

http://geolite.maxmind.com/download/...y/GeoIP.dat.gz

How do i fix this?
 
Old 01-27-2019, 08:00 AM   #2
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 123

Rep: Reputation: 86
See https://www.linuxquestions.org/quest...up-4175646629/
 
Old 01-27-2019, 09:21 AM   #3
hugok
LQ Newbie
 
Registered: Feb 2014
Location: Porto, Portugal
Distribution: Slackware 14.2 x86_64
Posts: 16

Original Poster
Rep: Reputation: Disabled
Thanks for replying, but from what I see there was a discontinuation of the GeoLite Legacy Databases ... and so far there is no solution to this problem or an easy how to, to fix this...
I also do not use ktorrent, I use Alien BOB qbitorrent 3.3.16 package, in fact I am the translator of qbitorrent for Portuguese(Portugal) for some years now. I simply do not like to see error messages every time I start (Slackware64 14.2 KDE) and I also do not like having to uninstall packages that comes with the official release.
 
Old 01-28-2019, 04:38 AM   #4
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 123

Rep: Reputation: 86
I can see your point. However, KDE4 is as I understand it no longer maintained and the ktorrent package in the official slackware distro is more than three years old and will probably never be updated.
An error message when starting seems unavoidable since the program searches for a file that is no longer accessible, but if you don't ever use ktorrent, why start it?
Or maybe the issue could be sorted by rebuilding the package. Found a thread suggesting it could be built with
Quote:
./configure --disaple-geoip
 
Old 01-28-2019, 10:23 AM   #5
FTIO
Member
 
Registered: Mar 2015
Location: Las Vegas, NV
Distribution: Slackware 14.1_32
Posts: 260

Rep: Reputation: 129Reputation: 129
Or, just stop using ktorrent and go with Frostwire. Works perfectly for me (has for years!) and builds extremely easily each update (it's superbly and often maintained, with updates sometimes as many as once a week +/-).

Get the build at slackbuilds and updates at Frostwire's site (when you start Frostwire it will let you know if there is an update).
 
Old 01-28-2019, 11:01 AM   #6
hugok
LQ Newbie
 
Registered: Feb 2014
Location: Porto, Portugal
Distribution: Slackware 14.2 x86_64
Posts: 16

Original Poster
Rep: Reputation: Disabled
I opened ktorrent by accident, I think I only used it a few times ago.
qbittorrent is my program of choice. (But I also used Frostwire a few years ago and enjoyed using it a lot, thanks for tip #FTIO)

It also happens that the message that appeared to me from ktorrent on startup no longer appears...without me doing anything...

I've already started slackware about 5 or 6 times since yesterday and the error message just doesn't appear anymore... Unless I open ktorrent again ...!!! I say.

Anyway, thank you for your answers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while installing kTorrent. . . rajanjina Linux - Software 3 07-29-2008 12:40 PM
ktorrent error - will not download a certain torrent ckent Linux - Software 6 07-08-2007 11:13 PM
Error compiling KTorrent from source: No KDE Headers Installed JamesHall Linux - Software 5 06-01-2006 03:35 AM
ktorrent error in suse 10.0 riba43 SUSE / openSUSE 4 03-16-2006 07:27 AM
ktorrent 1.1rc1 anticuchos Linux - Newbie 3 09-11-2005 02:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration