LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-24-2015, 11:58 AM   #1
GreenFireFly
Member
 
Registered: Jul 2013
Posts: 217

Rep: Reputation: Disabled
Smile Icewm and compton


Hello Everyone,

When i try to have transparency in icewm with compton the terminal goes black when i first log in. However when i go to my .icewm directory and double click my startup file then my terminal has transparency. Anyone have any idea why this is?

I'm running Slackware 14 64bit Nvidia Geforce 430GT with the Proprietary driver 340.65 and the xfce4-terminal with icewmbg as the background manager. This is what my startup script looks like

#!/bin/sh
compton &
killall ROX-Filer nm-applet volumeicon idesk wicd-client
#rox -p=default &
sleep 5
idesk &
volumeicon &
sleep 1
wicd-client -t &

Here is a 4.47mb video of the issue so you can see for yourselves.

https://www.sendspace.com/file/nl7qct

Last edited by GreenFireFly; 02-27-2015 at 03:29 PM. Reason: Solved
 
Old 02-24-2015, 02:11 PM   #2
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Rep: Reputation: Disabled
I think the problem is with xfce4-terminal and compton not icewm, the same thing happens to me in openbox with compton if I set xfce4terminal to full transparency, it ends up being a black box. You can set xfceterminal to be some percent and it will kinda work, it seems like compton interprets 0.0 transperancy as black and 1.00 as white and values <50 as dark shaded transparent of some level and >50 as white shaded transparent of some level. Unfortunately there is no way to get 100% or really anything more than 50% transparent.

The transparency you see when you double click your startup file, is compton get run again, but since it is already running this second one fails and closes which seems to trigger xfce4-terminal to use psuedo-transparency.
 
Old 02-24-2015, 03:26 PM   #3
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Rep: Reputation: Disabled
Update
If you run
compton --backend glx

to use GLX/OpenGL instead of Xrender then xfc4-terminal transparency works fine.

when using the compton glx backend you might need some other tweaks if you run into other problems. for example I needed to add --xrender-sync-fence to solve some window movement issues, though I use the AMD catalyst drivers, so you might nor have this issue.
 
Old 02-24-2015, 04:15 PM   #4
GreenFireFly
Member
 
Registered: Jul 2013
Posts: 217

Original Poster
Rep: Reputation: Disabled
Hello Pataphysician,

Thanks for the replies. I will give it a try.
 
Old 02-25-2015, 05:52 PM   #5
GreenFireFly
Member
 
Registered: Jul 2013
Posts: 217

Original Poster
Rep: Reputation: Disabled
Hello Everyone,

I tried compton --backend glx but the terminal bg turns black when compton is on. I also tried it with roxterm with the same result. However i notice that if i use compton -e .80 -i .80, the background terminal has transparency but what ever window is focused on will not have any transparency. Look at the screen shot below.

http://postimg.org/image/ye4cjtuut/

Last edited by GreenFireFly; 02-25-2015 at 05:55 PM.
 
Old 02-26-2015, 06:29 AM   #6
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Rep: Reputation: Disabled
Well I decided to install Icewm from slackbuild.org to see better, and I couldn't get true transparency to work with compton or xcompmgr with any terminal, urxvt,konsole, xfce4-terminal. So I guess most of the problem is icewm. I did some searching and found this submitted for 1.3.7 icewm

http://sourceforge.net/p/icewm/bugs/906/

So it seems to be a possible general problem.
 
Old 02-26-2015, 10:56 AM   #7
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Rep: Reputation: Disabled
Ok based on what you kind of got working I cam up with a sort of solution, but it is a kludge

the -e .8 option you were using is for setting only window decoration and border transparent, whereas the -i option is for the whole inactive window

If you use
compton -i .80 --active-opacity .8

this works

The reason I say this is a kludge, is that you are actually making all windows transparent.

Really compton should just work with the terminals own transparency settings. In openbox I only have problems with compton in xrender mode with xfce4-terminal and then only at 100% transparency, konsole transparency works fine in either mode, as does urxvt.
 
Old 02-27-2015, 05:00 AM   #8
Nh3xus
Member
 
Registered: Jan 2013
Location: France
Distribution: Slackware 14.1 32 bits
Posts: 211

Rep: Reputation: 56
Actually, you have to blacklist some applications in the file ~/.config/compton.conf for them to be rendered properly with compton on top of it.
 
Old 02-27-2015, 03:28 PM   #9
GreenFireFly
Member
 
Registered: Jul 2013
Posts: 217

Original Poster
Rep: Reputation: Disabled
Hello Everyone,

With compton -i .80 --active-opacity .8 it is work now. Thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Make Slackware Xfce use compton for compositing holden87 Slackware 2 11-29-2014 09:30 PM
[SOLVED] Weird issue with compton moisespedro Slackware 10 04-21-2014 04:47 PM
Any Icewm/Icewm-experimental experts here? linus72 Linux - General 3 01-18-2010 06:45 AM
where is the startup script of icewm when there is no ~/.icewm frenchn00b Linux - General 2 08-14-2008 05:36 PM
iceWM lilohatea Debian 5 07-06-2005 02:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration