LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Icewm and compton (https://www.linuxquestions.org/questions/slackware-14/icewm-and-compton-4175534965/)

GreenFireFly 02-24-2015 11:58 AM

Icewm and compton
 
Hello Everyone,

When i try to have transparency in icewm with compton the terminal goes black when i first log in. However when i go to my .icewm directory and double click my startup file then my terminal has transparency. Anyone have any idea why this is?

I'm running Slackware 14 64bit Nvidia Geforce 430GT with the Proprietary driver 340.65 and the xfce4-terminal with icewmbg as the background manager. This is what my startup script looks like

#!/bin/sh
compton &
killall ROX-Filer nm-applet volumeicon idesk wicd-client
#rox -p=default &
sleep 5
idesk &
volumeicon &
sleep 1
wicd-client -t &

Here is a 4.47mb video of the issue so you can see for yourselves.

https://www.sendspace.com/file/nl7qct

pataphysician 02-24-2015 02:11 PM

I think the problem is with xfce4-terminal and compton not icewm, the same thing happens to me in openbox with compton if I set xfce4terminal to full transparency, it ends up being a black box. You can set xfceterminal to be some percent and it will kinda work, it seems like compton interprets 0.0 transperancy as black and 1.00 as white and values <50 as dark shaded transparent of some level and >50 as white shaded transparent of some level. Unfortunately there is no way to get 100% or really anything more than 50% transparent.

The transparency you see when you double click your startup file, is compton get run again, but since it is already running this second one fails and closes which seems to trigger xfce4-terminal to use psuedo-transparency.

pataphysician 02-24-2015 03:26 PM

Update
If you run
compton --backend glx

to use GLX/OpenGL instead of Xrender then xfc4-terminal transparency works fine.

when using the compton glx backend you might need some other tweaks if you run into other problems. for example I needed to add --xrender-sync-fence to solve some window movement issues, though I use the AMD catalyst drivers, so you might nor have this issue.

GreenFireFly 02-24-2015 04:15 PM

Hello Pataphysician,

Thanks for the replies. I will give it a try.

GreenFireFly 02-25-2015 05:52 PM

Hello Everyone,

I tried compton --backend glx but the terminal bg turns black when compton is on. I also tried it with roxterm with the same result. However i notice that if i use compton -e .80 -i .80, the background terminal has transparency but what ever window is focused on will not have any transparency. Look at the screen shot below.

http://postimg.org/image/ye4cjtuut/

pataphysician 02-26-2015 06:29 AM

Well I decided to install Icewm from slackbuild.org to see better, and I couldn't get true transparency to work with compton or xcompmgr with any terminal, urxvt,konsole, xfce4-terminal. So I guess most of the problem is icewm. I did some searching and found this submitted for 1.3.7 icewm

http://sourceforge.net/p/icewm/bugs/906/

So it seems to be a possible general problem.

pataphysician 02-26-2015 10:56 AM

Ok based on what you kind of got working I cam up with a sort of solution, but it is a kludge

the -e .8 option you were using is for setting only window decoration and border transparent, whereas the -i option is for the whole inactive window

If you use
compton -i .80 --active-opacity .8

this works

The reason I say this is a kludge, is that you are actually making all windows transparent.

Really compton should just work with the terminals own transparency settings. In openbox I only have problems with compton in xrender mode with xfce4-terminal and then only at 100% transparency, konsole transparency works fine in either mode, as does urxvt.

Nh3xus 02-27-2015 05:00 AM

Actually, you have to blacklist some applications in the file ~/.config/compton.conf for them to be rendered properly with compton on top of it.

GreenFireFly 02-27-2015 03:28 PM

Hello Everyone,

With compton -i .80 --active-opacity .8 it is work now. Thanks a lot.


All times are GMT -5. The time now is 04:31 PM.