LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-29-2014, 02:33 PM   #1
holden87
Member
 
Registered: Jul 2012
Location: Slovenia
Distribution: Debian 9 GNOME
Posts: 55

Rep: Reputation: 9
Make Slackware Xfce use compton for compositing


Hi guys.

So, i've installed compton form the slackbuilds, and set the application autostart as

Code:
compton -b
...

naturally, i created the compton.conf file, but it doesn't seem to boot compton when booting. it's still 'compositless'. What could i be doing wrong?

Kind regards...

-up-to-date Slackware 14.1 w Xfce
 
Old 11-29-2014, 03:18 PM   #2
moisespedro
Senior Member
 
Registered: Nov 2013
Location: Brazil
Distribution: Slackware
Posts: 1,223

Rep: Reputation: 195Reputation: 195
Follow this. I used to do that when I was using XFCE.
 
Old 11-29-2014, 09:30 PM   #3
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,154

Rep: Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982Reputation: 3982
Do you get any errors when you start Compton from an X terminal?

Also: I don't know what settings you're using, and I also don't know if Compton's defaults visibly change anything.

Here's the compton.conf I'm using:

Code:
backend = "glx";
paint-on-overlay = true;
glx-no-stencil = true;
glx-no-rebind-pixmap = true;
vsync = "opengl-swc";

menu-opacity = 0.8;
frame-opacity = 0.8;

shadow = true

# Add own_window_class Conky to conkyrc
shadow-exclude = "class_g = 'Conky'";

unredir-if-possible = true;

Last edited by dugan; 11-29-2014 at 09:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Weird issue with compton moisespedro Slackware 10 04-21-2014 04:47 PM
ati pci-e card, xorg.conf, Slackware and compositing esteeven Linux - General 8 07-09-2010 02:29 PM
Slackware 13 and NVidia Compositing Maestro485 Slackware 7 09-22-2009 11:11 AM
Slackware 64 -current / KDE 4.2.4 / lost compositing. botnet Slackware 22 07-21-2009 12:54 PM
Some apps kill xorg, with XFCE compositing 'on' Neil- Slackware 5 05-14-2008 03:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration