LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-26-2004, 01:16 AM   #46
Darktyco
Member
 
Registered: Aug 2003
Location: michigan
Distribution: slackware
Posts: 59

Rep: Reputation: 15

I follow the directions correctly and get the module built (althought it gives me a few warnings about initializing an incompatible pointer type), but when I try to run ./make_install (or modprobe fglrxt) it tells me "invalid module format". This seems odd because I have other modules loaded (alsa, forcedeth, agpgart, etc) without any problems.

I'm running slack 9.1 and am just off a fresh upgrade from 2.4.22 to 2.6.3. What could be going wrong here?
 
Old 02-26-2004, 02:50 AM   #47
Erol
Member
 
Registered: Jan 2004
Location: Vienna/Austria
Distribution: Slackware 10.0 (kernel 2.6.7)
Posts: 46

Original Poster
Rep: Reputation: 15
I guess you didn't upgrade module-init-tools?

And ofcourse rm -rf *.o and rm -rf *.ko in /lib/modules/fglrx and /lib/modules/fglrx/build_mod is needed. Since probably you have some leftovers there from your last kernel.

"Invalide module format" is the message when you try to load a driver compiled for 2.4.x kernel into 2.6.x. I had this problem myself with my soundcard driver...

If you are using swaret, just type swaret --install module-init-tools, to be safe. Try to freshly unpack the fglrx driver, so that you don't have any leftovers in those directories, and patch with the appropriate patches.

Good luck,

Erol
 
Old 02-26-2004, 09:36 AM   #48
Darktyco
Member
 
Registered: Aug 2003
Location: michigan
Distribution: slackware
Posts: 59

Rep: Reputation: 15
Sorry, I figured out the problem. After trying to load it there was a message in my syslog showing that the module was looking for something in my kernel that I needed to enbale. Enabling it loaded, now I just need to fix one more error...
 
Old 02-29-2004, 09:22 AM   #49
smkDeb
LQ Newbie
 
Registered: Feb 2004
Location: Italy
Posts: 4

Rep: Reputation: 0
nforce2 + 2.6.3 + 4.3 + radeon9500pro

Hi to all and a Big Respect for all the work here .... i found a lot of answer ....

A BIG BIG RESPECT to EROL and his post .... but i still have problem

i'am a newbie in all (debian linux etc etc )

i have compiled kernel 2.6.3 as in the first post

- agpgart must be as a module
- dri support must be disabled

i can set ""NVIDIA-AGP must be enabled"" cause agpgart is Module . so i set it M or both built-in

i download the fglrx 3.7.0 insted of 3.2.8

dpkg -i --force-overwrite fglrx-.........

i applied the 2 patch so /lib/modules/fglrx/build_mod/fire.........

and i ./make.sh | cd .. | ./make_install.sh

configured fglrxconfig and installed DRI (from sourceforge. --- cause to my 9500 i installed the R200 DRI package, right ? )

now .....

i have some problem glxgears get 200fps
i can't modprobe nvidia_agp (FATAL Moduile nvidia_agp not found) (or FATAL Module nvidia_agp already in the kernel, if i compiled the kernel with it built in)
when i glxinfo , it return NO DRI and
when i fglxinfo , it return

OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.3 Mesa 4.0.4)

--------
hoping to resolve this problem ||| A BIG RESPET TO ALL AGAIN ||||
--------
 
Old 02-29-2004, 09:38 AM   #50
Erol
Member
 
Registered: Jan 2004
Location: Vienna/Austria
Distribution: Slackware 10.0 (kernel 2.6.7)
Posts: 46

Original Poster
Rep: Reputation: 15
Re: nforce2 + 2.6.3 + 4.3 + radeon9500pro

In your kernel config Character devices must look like this:

(M) /dev/agpgart (AGP Support)
(M) Nvidia nForce/nForce2 chipset support

This is a must, they must be compiled as modules.

I recomend that you use 3.2.8 drivers, since I've read that 3.7.0 have few unsolved problems and are slower than 3.2.8.

You need to download radeon package, click here for today's snapshot. R200 is not what you need.

Make sure that in your /etc/X11/XF86Config-4 file is

Option "UseInternalAGPGART" "no"

this set to no.

I think that you just need to fix these few details, and that it will be ok, if not post your status here...

good luck,

Erol
 
Old 02-29-2004, 09:51 AM   #51
smkDeb
LQ Newbie
 
Registered: Feb 2004
Location: Italy
Posts: 4

Rep: Reputation: 0
Talking thank u

a question than i try your solution

in kernel

Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) Must be enabled/disabled/modular ?

big up !
 
Old 02-29-2004, 10:09 AM   #52
Erol
Member
 
Registered: Jan 2004
Location: Vienna/Austria
Distribution: Slackware 10.0 (kernel 2.6.7)
Posts: 46

Original Poster
Rep: Reputation: 15
It's clearly stated in my first post:

- dri support must be disabled

Disable it
 
Old 02-29-2004, 10:36 AM   #53
smkDeb
LQ Newbie
 
Registered: Feb 2004
Location: Italy
Posts: 4

Rep: Reputation: 0
Unhappy


So:

Kernel Rebuild with : agp && nvidia Modular ||| dri disable

Install fglrx 3.2.8

Applied 2 patch to firegl.......
/lib/modules/fglrx/build_mod/ ./make.sh
/lib/modules/fglrx/ ./make_install.sh

fglrxconfig

Option "UseInternalAGPGART" "no"

Install DRI radeon-20040225-linux.i386.tar.bz2

now:
i can't modprobe nvidia_agp === FATAL: Module nvidia_agp not found.

lsmod === fglrx 201732 0

glxinfo = no DRI and

OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.3 Mesa 4.0.4)

glxgears === 330 FPS (medium)

fglrxinfo ===

OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.3 Mesa 4.0.4)

fgl_glxgears ==== Error: couldn't get fbconfig

------------------
ooooooooooooops i did it again {free the weed} |||
------------------
 
Old 02-29-2004, 11:52 AM   #54
Erol
Member
 
Registered: Jan 2004
Location: Vienna/Austria
Distribution: Slackware 10.0 (kernel 2.6.7)
Posts: 46

Original Poster
Rep: Reputation: 15
Check if you have the module nvidia_agp

modprobe -l

if not, maybe it wouldn't be a bad idea to reboot so that your modules get registered.

btw. how did the DRI compiling go ? no problems ?

Erol
 
Old 02-29-2004, 11:57 AM   #55
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 897

Rep: Reputation: 30
Also I belive that the module is not nvidia_agp but nvidia-agp

Kick me if I am wrong

Adam
 
Old 02-29-2004, 12:02 PM   #56
Erol
Member
 
Registered: Jan 2004
Location: Vienna/Austria
Distribution: Slackware 10.0 (kernel 2.6.7)
Posts: 46

Original Poster
Rep: Reputation: 15
no kicking, but it's the same thing.

Try both

/sbin/modprobe nvidia-agp
/sbin/modprobe nvidia_agp

bash-2.05b# lsmod | grep nvidia_agp
nvidia_agp 7644 1
agpgart 32104 2 nvidia_agp

When you modprobe nvidia-agp, it will load itself in the modules table with _ instead of -.
Also you can do modprobe nvidia_agp, and still it will be in the lsmod list with _.
 
Old 02-29-2004, 12:07 PM   #57
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 897

Rep: Reputation: 30
Ok learn somthing new everyday! he he Now to get Arch linux going... I know I don´t really know enough to do it but thats the reason I am trying!

Adam
 
Old 02-29-2004, 12:09 PM   #58
smkDeb
LQ Newbie
 
Registered: Feb 2004
Location: Italy
Posts: 4

Rep: Reputation: 0
Talking

i don't kick anyone ......

u're right ... correct name in nvidia-agp ....

now i remake the installation step by step ....
and all is done CORRECTLY ))

glxinfo: DRI ----------- > YES

fglrxinfo: display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon 9700 Athlon (3DNow!)
OpenGL version string: 1.3 (X4.3.0-3.2.8)

glxgears: make up to 5700 FPS in normal window it start

---it's normal that if i enlarge the window FPS come down ?
---why some time glxgears make up to 5000 FPS and
some time maximum 2700 FPS
---is a problem that can be fix or it's so ?

!!! A BIG BIG BIG THANK U TO EROL !!!
!!! A BIG BIG BIG THANK U TO ALL !!!
!!! A BIG BIG BIG THANK U TO !!!

I'm really excited and happy ..... i don't know how to say thank u ...
(and a really oooooooops for my english ... )


big up big up big up !!!!
 
Old 02-29-2004, 12:22 PM   #59
Erol
Member
 
Registered: Jan 2004
Location: Vienna/Austria
Distribution: Slackware 10.0 (kernel 2.6.7)
Posts: 46

Original Poster
Rep: Reputation: 15
I'm realy happy for you and that it finaly works now

Yes it's normal for your glxgears results to differ. Since they depend on the size of the window glxgears run in, and of the CPU usage. If your CPU is 0% used and your window is at the default size, you will get better results.

More your CPU is in use and the bigger your glxgear window is the FPS will decrease.

But you don't have to worry about that, since it's normal.

BTW I have Radeon 9000 Pro and max my glxgears give me is about 2400 FPS So think of yourself as a lucky man.



All the best,

Erol
 
Old 03-01-2004, 05:05 PM   #60
jimdaworm
Member
 
Registered: Aug 2003
Location: Spain
Distribution: Ubuntu
Posts: 897

Rep: Reputation: 30
Hey Erol I have a Radeon 9100 and I only get about 2050?? I thought it was quite a lot better than the 9000 pro!

Another thing you might be intersted in I am starting out in Arch linux... it looks COOL also looks like this major minor naming system is going to gotten rid of ... have a look here (Arch uses Devfs)

http://www.atnf.csiro.au/people/rgoo...ocs/devfs.html

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
zsnes && logitech dual action gamepad && dpad woes John5788 Linux - Games 5 10-29-2008 09:56 PM
(FreeBSD && Fedora Core 4 && Slackware 10.0) Filesystem Support taylor_venable *BSD 1 07-14-2005 02:24 PM
Japanese canna won't work : Warning: かな漢字変&am OrganicOrange84 Debian 3 06-30-2005 02:28 PM
Phục hồi dữ liệu bị mất???, cứ pollsite General 1 06-27-2005 12:39 PM
fglrx, nforce2 mobo, kernel 2.6.2-rc3 thrice Slackware 1 12-22-2004 11:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration