LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-03-2019, 06:19 PM   #16
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584

There is a --install-modules option and a --modules= option that preloads modules
What I did at the grub prompt was lsmod and compared the output of my ubuntu grub compared to slackware grub

Last edited by colorpurple21859; 11-03-2019 at 06:23 PM.
 
Old 11-04-2019, 08:37 AM   #17
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,337

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
https://www.linux.org/threads/unders...modules.11142/

under jpeg, just need to figure out how to apply it.
 
Old 11-04-2019, 09:01 AM   #18
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,337

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by Jan K. View Post
Blank as ever so can only ask, if this is inspiring? https://www.dedoimedo.com/computers/...mozTocId930378
haha in that tut, they show what my system no have
Code:
userx@slack64efi.net:/etc/grub.d
$ ls
00_header  10_linux  20_linux_xen  30_os-prober  40_custom  41_custom  README
the 05_debian_theme file.

going to find a theme then using that example in there page for a template then hack away a little and see what I can come up with.

got to toss it in that dir to see if grub-update will even pick it up first. Got to go hunt down a copy paste so I don't got to write it all out because them are images...


that part was simple enough

https://github.com/huslage/qfi-box-c...5_debian_theme

-------- BUMP --------

Code:
userx@slack64efi:/etc/grub.d$ update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/Andreea-Munteanu-001.jpg
/etc/grub.d/05_debian_theme: line 21: /usr/lib/grub/grub-mkconfig_lib: No such file or directory

Last edited by BW-userx; 11-04-2019 at 09:14 AM.
 
Old 11-04-2019, 10:16 AM   #19
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,337

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
so far, but still not working.
goes in /etc/grub.d/05_slackware_theme and that still gets picked up running update-grub or grub-mkconfig -o /boot/grub/grub.cfg (same thing) .. but no image showing.
Code:
#!/usr/bin/env bash 

source /usr/share/grub/grub-mkconfig_lib

set_blue_theme()
{
cat << EOF
set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue
EOF
}
#check for usable backgrounds
use_bg=false
# I do not think this ever gets figured out
#so I commented it out and it then shows output
#in terminal when update-grub is ran
#providing one has an image in the dir the for loop
#is looking in
#if [ "$GRUB_TERMINAL" = "gfxterm" ] ; then
{
	for i in {/boot/grub/*,/usr/share/grub/*,/usr/share/grub/images/*}{png,tga,jpg,jpeg} ; do
	{
		echo "$i"
                #there is a BUG in that call
		#if is_path_readable_by_grub $i ; then
		if [ -f $i ] ; then
		{
			bg=$i
			case ${bg} in
			*.png)	reader=png ;;
			*.tag)	reader=tga ;;
			*.jpg|*.jpeg)	reader=jpeg ;;
			esac
		}	
			if test -e /boot/grub/x86_64-efi/${reader}.mod ; then
			{
				echo "Found Slackware Background:: `basename ${bg}`" >&2
				use_bg=true
				break
			}
			fi
		fi
	}
	done
}
#fi
https://ubuntuforums.org/archive/ind...t-1347582.html
how to actually load the grub mods??? editing the grub.cfg gets overwritten so I'm not bothering trying to figure it out in that script.
Code:
userx@slack64efi.net:~
$ ls /boot/grub/x86_64-efi/png.mod
/boot/grub/x86_64-efi/png.mod

userx@slack64efi.net:~
$ ls /boot/grub/x86_64-efi/tga.mod
/boot/grub/x86_64-efi/tga.mod

userx@slack64efi.net:~
$ ls /boot/grub/x86_64-efi/jpeg.mod
/boot/grub/x86_64-efi/jpeg.mod
still looking deeper into the theme part too.

This might work if I install Debian but that's never going to happen...

GRUB 2 Custom Splash Screen on RHEL 7 UEFI and Legacy ISO Image


going to be a hack job for that link...

Last edited by BW-userx; 11-04-2019 at 10:50 AM.
 
Old 11-04-2019, 11:23 AM   #20
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Have you ran videoinfo at the grub prompt to see what gfxmode sizes will work and grub video module that needs to be loaded ?
 
Old 11-04-2019, 11:51 AM   #21
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,337

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by colorpurple21859 View Post
Have you ran videoinfo at the grub prompt to see what gfxmode sizes will work and grub video module that needs to be loaded ?
how do I even get one of them? grub prompt without screwing up grub to give me one?
 
Old 11-04-2019, 12:41 PM   #22
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
at the grub menu when you first boot, press c for a grub prompt
Code:
grub> videoinfo
Code:
grub> lsmod
will give a list of grub modules that are loaded.

Last edited by colorpurple21859; 11-04-2019 at 12:43 PM.
 
Old 11-06-2019, 01:43 PM   #23
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Been playing around with this both in vm and on bare metal using the slackware-grub2-theme from slackbuilds.
At the very minimum to get this to work, add this to /etc/default/grub
Code:
GRUB_THEME="/boot/grub/themes/slackware/theme.txt"
then
Code:
grub-mkconfig -o /boot/grub/grub.cfg
grub-install --modules=efi_gop
It may be a different grub video module for your system, there is also an efi_uga and a few other grub video modules.
at the grub menu when you first boot, press C then
Code:
grub>videoinfo
should give you an idea of which module to preload, but this may not always work.

Sometimes would also need
Code:
GRUB_GFXMODE=1024X768
or something similar also in /etc/default/grub.
 
Old 11-06-2019, 03:02 PM   #24
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,337

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
I had 1080p set now I'll try this . just cuz, and videoinfo gave me just a line about the colors for the text and nothing else
Code:
GRUB_GFXMODE=1024x768x32
#GRUB_GFXMODE=auto
#GRUB_GFXMODE=1920x1080x32
GRUB_GFXPAYLOAD_LINUX=keep
 
Old 11-06-2019, 04:12 PM   #25
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Quote:
videoinfo gave me just a line about the colors for the text and nothing else
I had that happen on one of the vm's I have setup, when I get a chance, I'll see if there is way to coax more info from videoinfo.
 
1 members found this post helpful.
Old 11-06-2019, 06:24 PM   #26
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Maybe this will work to give you an idea of what video module needs to be preloaded by grub.
Code:
grub>insmod all_video
grub>videoinfo
 
1 members found this post helpful.
Old 11-06-2019, 08:50 PM   #27
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Code:
grub-install --modules=all_video
also works on my systems, I think it preloads all grub video modules.

Last edited by colorpurple21859; 11-06-2019 at 08:52 PM.
 
Old 11-07-2019, 07:50 AM   #28
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,337

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by colorpurple21859 View Post
Code:
grub-install --modules=all_video
also works on my systems, I think it preloads all grub video modules.
I think we've been spinning our wheels, mostly you. I just tried to boot a usb stick which didn't take off the boot, so I used the Esc key to give me my (BIOS) boot options, then I seen my Slackware 14+ selection and used that instead of the grub options, and well, guess what.
come on Guess!!!

I seen the theme screen. Therefore, I bet that its been working this entire time, but, it was due to the means being used that it was not showing is all.

Though I cannot say for sure, I did try your suggestion
Code:
install-grub --modules=all_video /dev/sdb
update-grub
which did not show any change on my "normal" boot to grub. but anyways yeah it is how my system is set up to boot slacks grub64.efi ..I'll have to look into that part now. thanks for all of your due diligence.
 
Old 11-07-2019, 09:40 AM   #29
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,557

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
One of the vms I was testing with, has the efi partition on /dev/sdb, and It has the same issue you describe, where I have to go to vm bios and select the Slackware 14+ to get the grub theme to show. Even when I would make Slackware 14+ as default bootloader with efibootmgr same thing would happen.
I just thought it was just a quirk with the vm. Guess not, either grub and/or the efi firmware has issues when the efi partition isn't the first drive.

Last edited by colorpurple21859; 11-07-2019 at 09:43 AM.
 
Old 11-07-2019, 11:23 AM   #30
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,337

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by colorpurple21859 View Post
One of the vms I was testing with, has the efi partition on /dev/sdb, and It has the same issue you describe, where I have to go to vm bios and select the Slackware 14+ to get the grub theme to show. Even when I would make Slackware 14+ as default bootloader with efibootmgr same thing would happen.
I just thought it was just a quirk with the vm. Guess not, either grub and/or the efi firmware has issues when the efi partition isn't the first drive.
yeah, looks that way. I am now in the process of moving my efi partition onto my sda drive, after rsync gets done.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Ooooy. EFI boot mmx64.efi.efi not found bulgin Linux - Newbie 12 12-20-2018 12:03 PM
resize efi question [/boot/efi] with boot flag gparted mtdew3q Fedora 4 03-19-2017 11:02 PM
[SOLVED] Can't find /boot/efi/EFI/Slackware/vmlinuz kernel configuration ironQiu Slackware 4 02-09-2015 07:21 AM
boot efi disk with without a non-efi bios pc... masavini Programming 1 11-12-2013 09:48 PM
Infinite Grub Loop: GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB... beeblequix MEPIS 2 11-02-2013 11:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration