LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-30-2019, 04:24 PM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
efi boot screen background grub


this might be a mute question, but how to set up a grub background using grub efi in slack?

the in the default/grub is not working.
it says it pics it up but it never shows.

Code:
$ update-grub
Generating grub configuration file ...
Found background: /boot/efi/EFI/slackware-14.2+/Andreea-Munteanu-001.jpg
Found linux image: /boot/vmlinuz-huge-4.19.81
Found initrd image: /boot/initrd.gz
Found linux image: /boot/vmlinuz-huge
Found initrd image: /boot/initrd.gz
Found linux image: /boot/vmlinuz-generic-4.19.81
Found initrd image: /boot/initrd.gz
Found linux image: /boot/vmlinuz-generic
Found initrd image: /boot/initrd.gz
Found Windows Boot Manager on /dev/sdb1@/EFI/Microsoft/Boot/bootmgfw.efi
Found unknown Linux distribution on /dev/sdb7
done
 
Old 10-30-2019, 07:35 PM   #2
Tonus
Member
 
Registered: Jan 2007
Location: Paris, France
Distribution: Slackware-current
Posts: 521
Blog Entries: 3

Rep: Reputation: 139Reputation: 139
efi boot screen background grub

You have to worry about it size and other specs, otherwise it won't be shown...

Edit : " 256-color non-indexed RGB JPEG"
Edit 2 : Set GRUB_GFXMODE and resize the bg accordingly

Last edited by Tonus; 10-30-2019 at 07:45 PM.
 
Old 10-30-2019, 08:27 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
NOPEz .. I even tried a image off my phone. nopeZ .. still working on it.

does not even use the only grub2 theme on slackbuilds.
slackware-grub2-theme (1.0)

Last edited by BW-userx; 10-30-2019 at 08:37 PM.
 
Old 10-30-2019, 09:45 PM   #4
0XBF
Member
 
Registered: Nov 2018
Location: Winnipeg
Distribution: Slackware
Posts: 92

Rep: Reputation: Disabled
"info grub" talks about using theme files to set this kind of stuff up but maybe you can get it working just through /etc/default/grub

I just played around with this to test things out. It seems I have a /boot/grub/themes/breeze/ directory and theme.txt file in that folder already set up from a breeze-grub pkg from alienBOB. I'm guessing that showed up from my ktown install. Anyways, I edited the theme file to include the lines:
Code:
desktop-image: "slackware-boot.png"
desktop-image-scale-method: "stretch"
and I put that image file in the same directory.

Then in my /etc/default/grub I added the following lines:
Code:
GRUB_THEME=/boot/grub/themes/breeze/theme.txt
GRUB_GFXMODE=1920x1080x32
Also needed to update-grub to get the new info (I just did a grub-mkconfig -o /boot/grub/grub.cfg, it does the same thing).

On the first reboot nothing worked. There was a quick error message before grub loaded that I had to use a slow-mo video on my phone to capture. It complained about missing /boot/grub/fonts/dejavusansmono.pf2 and "no suitable video mode". After finding and copying dejavusansmono.pf2 to /boot/grub/fonts the themed grub started working.

Also I tried with a .jpg first and grub complained about some invalid argument. Switching it to a .png file made it work properly. I'll add a photo to prove it .

Also note that I'm using legacy boot here so some of these things may need to be adjusted for your efi setup. Hopefully this gives you some ideas to try. Grub seems kind of picky about these settings so good luck!
Attached Thumbnails
Click image for larger version

Name:	IMG_20191030_202607.jpg
Views:	55
Size:	255.3 KB
ID:	31727  

Last edited by 0XBF; 10-30-2019 at 09:49 PM. Reason: pf2, not df2
 
Old 10-30-2019, 10:09 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by 0XBF View Post
"info grub" talks about using theme files to set this kind of stuff up but maybe you can get it working just through /etc/default/grub

I just played around with this to test things out. It seems I have a /boot/grub/themes/breeze/ directory and theme.txt file in that folder already set up from a breeze-grub pkg from alienBOB. I'm guessing that showed up from my ktown install. Anyways, I edited the theme file to include the lines:
Code:
desktop-image: "slackware-boot.png"
desktop-image-scale-method: "stretch"
and I put that image file in the same directory.

Then in my /etc/default/grub I added the following lines:
Code:
GRUB_THEME=/boot/grub/themes/breeze/theme.txt
GRUB_GFXMODE=1920x1080x32
Also needed to update-grub to get the new info (I just did a grub-mkconfig -o /boot/grub/grub.cfg, it does the same thing).

On the first reboot nothing worked. There was a quick error message before grub loaded that I had to use a slow-mo video on my phone to capture. It complained about missing /boot/grub/fonts/dejavusansmono.pf2 and "no suitable video mode". After finding and copying dejavusansmono.pf2 to /boot/grub/fonts the themed grub started working.

Also I tried with a .jpg first and grub complained about some invalid argument. Switching it to a .png file made it work properly. I'll add a photo to prove it .

Also note that I'm using legacy boot here so some of these things may need to be adjusted for your efi setup. Hopefully this gives you some ideas to try. Grub seems kind of picky about these settings so good luck!
that's what I was thinking use a theme then put the image in it that I want and use it that way. and yeah efi looks like someone needs to fix that.. lu lu lu as if that's it a priority.
my update-grub is just a wrapper.
Code:
userx@slack64efi.net:~
$ cat /usr/local/bin/update-grub

sudo grub-mkconfig -o /boot/grub/grub.cfg
seen that background didn't get comment out on install, so I am ging to reboot to see if that theme works now.
Code:
userx@slack64efi.net:~
$ cat /etc/default/grub
# If you change this file, run grub-mkconfig -o /boot/grub/grub.cfg
# afterwards to update /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=$( sed 's/Slackware /Slackware-/' /etc/slackware-version )
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
#GRUB_GFXMODE=1024x768x32
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep

GRUB_BACKGROUND="/usr/share/grub/Andreea-Munteanu-001.jpg"
#GRUB_BACKGROUND="/boot/efi/EFI/slackware-14.2+/Andreea-Munteanu-001.jpg"
#GRUB_BACKGROUND="/usr/share/grub/IMG_20191029_212113.jpg"

# Font used on the graphical terminal:
#GRUB_FONT=/usr/share/grub/dejavusansmono.pf2

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"
#GRUB_THEME=/boot/grub/themes/Atomic/theme.txt
 
Old 10-30-2019, 10:10 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
dupe, and that didn't work, and it's getting late.. pick it up later.
 
Old 10-30-2019, 10:19 PM   #7
0XBF
Member
 
Registered: Nov 2018
Location: Winnipeg
Distribution: Slackware
Posts: 92

Rep: Reputation: Disabled
Well since you're trying without the theme I gave it a shot and it worked from /etc/default/grub for me.
Code:
# If you change this file, run grub-mkconfig -o /boot/grub/grub.cfg
# afterwards to update /boot/grub/grub.cfg.

GRUB_DEFAULT="1>6"
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=$( sed 's/Slackware /Slackware-/' /etc/slackware-version )
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
#GRUB_SAVEDEFAULT=true
#GRUB_THEME=/boot/grub/themes/breeze/theme.txt
GRUB_BACKGROUND="/boot/grub/themes/breeze/slackware-boot.png"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
#GRUB_GFXMODE=1024x768x32
GRUB_GFXMODE=1920x1080x32
# Font used on the graphical terminal:
#GRUB_FONT=/usr/share/grub/dejavusansmono.pf2

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"
Since I'm not using the theme on this run I'm not sure about the image size but the image is 1920x1080, if that matters. The scale option in the theme file was supposed to avoid any problems with size. I also have a png, so maybe try converting your image to such. The only other thing I see different is I'm using the /boot/grub/... path.
 
Old 11-01-2019, 09:55 AM   #8
SpacePlod
Member
 
Registered: Jan 2014
Distribution: Slackware
Posts: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
this might be a mute question, but how to set up a grub background using grub efi in slack?

the in the default/grub is not working.
it says it pics it up but it never shows.
<snip>
This issue rang a bell for me - I had the exact same problem a few months ago in this thread: https://www.linuxquestions.org/quest...fi-4175648731/ . The problem I specified in that thread seems to be the same exact thing you're seeing here if I'm reading it right.

Never did get it resolved (too many other more important issues). The odd thing is that you (BW-userx) responded in that thread a few times and seemed to have it working fine at that time.
 
Old 11-01-2019, 11:09 AM   #9
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by SpacePlod View Post
This issue rang a bell for me - I had the exact same problem a few months ago in this thread: https://www.linuxquestions.org/quest...fi-4175648731/ . The problem I specified in that thread seems to be the same exact thing you're seeing here if I'm reading it right.

Never did get it resolved (too many other more important issues). The odd thing is that you (BW-userx) responded in that thread a few times and seemed to have it working fine at that time.
yep, in post #2
I don't know much about elilo or grub efi but still it looks like you're mixing boot loaders .
 
Old 11-01-2019, 11:12 AM   #10
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by 0XBF View Post
Well since you're trying without the theme I gave it a shot and it worked from /etc/default/grub for me.
Code:
# If you change this file, run grub-mkconfig -o /boot/grub/grub.cfg
# afterwards to update /boot/grub/grub.cfg.

GRUB_DEFAULT="1>6"
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=$( sed 's/Slackware /Slackware-/' /etc/slackware-version )
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
#GRUB_SAVEDEFAULT=true
#GRUB_THEME=/boot/grub/themes/breeze/theme.txt
GRUB_BACKGROUND="/boot/grub/themes/breeze/slackware-boot.png"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
#GRUB_GFXMODE=1024x768x32
GRUB_GFXMODE=1920x1080x32
# Font used on the graphical terminal:
#GRUB_FONT=/usr/share/grub/dejavusansmono.pf2

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"
Since I'm not using the theme on this run I'm not sure about the image size but the image is 1920x1080, if that matters. The scale option in the theme file was supposed to avoid any problems with size. I also have a png, so maybe try converting your image to such. The only other thing I see different is I'm using the /boot/grub/... path.
It looks like the biggest change is that specifying the size and not using auto, placement of the image, I don't really think matters as long as it can get to it, and /usr/share/grub which was already there. for the font(s).

as soon as I can I'll reboot and see if this works. I am compiling software at the moment.
thanks.
 
Old 11-03-2019, 09:11 AM   #11
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,556

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
There is an option 'grub-install --themes=THEMES', maybe that is what is needed to get themes to work with efi grub loader.
 
Old 11-03-2019, 12:48 PM   #12
Jan K.
Member
 
Registered: Apr 2019
Location: Esbjerg
Distribution: slackware...
Posts: 94

Rep: Reputation: 42
Blank as ever so can only ask, if this is inspiring? https://www.dedoimedo.com/computers/...mozTocId930378
 
1 members found this post helpful.
Old 11-03-2019, 03:53 PM   #13
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Thanks, Jan K. , I'll give that a closer look when I get a free minute
 
Old 11-03-2019, 05:23 PM   #14
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,556

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
I was playing with using grub themes on my system had same issue with slackware grub themes not working in efi mode.
For me the fix was
Code:
grub-install --modules=efi_gop
efi_gop is the grub video module my system uses.

Last edited by colorpurple21859; 11-03-2019 at 05:26 PM.
 
Old 11-03-2019, 06:15 PM   #15
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: FreeBSD/Slackware-14.2+/ArcoLinux
Posts: 9,335

Original Poster
Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by colorpurple21859 View Post
I was playing with using grub themes on my system had same issue with slackware grub themes not working in efi mode.
For me the fix was
Code:
grub-install --modules=efi_gop
efi_gop is the grub video module my system uses.
did that already, I think. I know I did a grub-install install something.
I think this is what I got
Code:
$ ls /boot/grub/x86_64-efi
acpi.mod              gcry_whirlpool.mod        password.mod
adler32.mod           geli.mod                  password_pbkdf2.mod
affs.mod              gettext.mod               pata.mod
afs.mod               gfxmenu.mod               pbkdf2.mod
ahci.mod              gfxterm.mod               pbkdf2_test.mod
....... more stuff ......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Ooooy. EFI boot mmx64.efi.efi not found bulgin Linux - Newbie 12 12-20-2018 12:03 PM
resize efi question [/boot/efi] with boot flag gparted mtdew3q Fedora 4 03-19-2017 11:02 PM
[SOLVED] Can't find /boot/efi/EFI/Slackware/vmlinuz kernel configuration ironQiu Slackware 4 02-09-2015 07:21 AM
boot efi disk with without a non-efi bios pc... masavini Programming 1 11-12-2013 09:48 PM
Infinite Grub Loop: GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB... beeblequix MEPIS 2 11-02-2013 11:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration