LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 05-22-2004, 01:15 PM   #1
oxbeat
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
Inspiron 1150 Mandrake 10.0 Official


I have an Inspiron 1150 and cannot get X working, I
just get an error message when I try to start it up.
I'm using the latest kernel, but should I be using
2.4.26 instead? I've also updated my BIOS to A02 and
tried applying 855patch and 855wrapper but still no
luck. Please help!

My email is: oxbeat AT yahoo DOT com
 
Old 05-28-2004, 10:50 PM   #2
Alekti
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
I too have recently acquired an Inspiron 1150. Trying to get Slackware running acceptably on it. Not much luck yet, seems there is very little support for it.

I was able to get X working. I did have to change a configuration file though.

/etc/X11/XF86Config

you need to find the place where it says

Section "Screen"

# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32

Change this to

# DefaultDepth 8
DefaultDepth 16
# DefaultDepth 24
# DefaultDepth 32

Assuming you are using the (lame) vesa driver like I am, then X should start up in a horrible 640x480 res.

I can't get the Intel video drivers to work properly (allowing me better video).

When I install the drivers and tell the device to use "i830" X complains "Received Signal 11" and fails to start. When I tell the device to use "i810" the screen turns green and I can't do anything at all except push the power button. Probably since that's the wrong driver.

I can't install kernel 2.6.6 (probably user error). I'm using 2.4.2 or something (whatever comes with Slackware).

I had to tell the cs-pcmcia to not check certain IO ports because it will freeze the machine on bootup if it does.
And I get spammed with "insmod: init_module: No device found" on bootup as well.

I can't get the networking to work properly (allowing internet access). The drivers don't work, when I try to load them after compile to just make sure the compilation worked, "insmod: init_module: No device found."

I have found absolutely no help with this model, I've been using Inspiron 1100 information to help me with some things, since I figure that model is probably the most similar to the 1150. It is very frustrating.

I'll probably try installing Fedora Core 2 pretty soon if I can't get Slackware working. . .

Last edited by Alekti; 05-28-2004 at 10:59 PM.
 
Old 05-30-2004, 09:45 PM   #3
dzn
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
I got Slackware to work , I had to get the bios upgrade from Dell. After upgrade to ver A02, I made it! The default depth ,16 bit @ 640x480 (yea, I know, yuck)


SO I added to that XF86Config file:


Virtual 1024 768


...below my sync ranges for 16-bit, giving me a larger screen, but ya have to drag around to view it all...
but it was trouble to begin with, I couldnt gain access the disk with cfdisk command, and had to take it in to the service shop to be properly partitioned, preserving the already installed M$ windows



yea I got sound and everything working, -- except the onboard NIC ........


Whats really cool I found this Linux Live cd, called SLAX I can run it, although it automatically mounts all the current partitions


Last edited by dzn; 05-30-2004 at 09:54 PM.
 
Old 06-12-2004, 11:19 AM   #4
jsilve1
LQ Newbie
 
Registered: Jun 2004
Location: Baltimore, Maryland
Distribution: Red Hat/Fedora Core
Posts: 10

Rep: Reputation: 0
I have installed both Fedora Core 1 and Fedora Core 2 without *any* problems onb my refurbished Dell Inspiron 1150.

Now, if only I could get my 3Com wireless card to work...

But FC1 and FC2 worked flawlessly for me!
 
Old 06-14-2004, 12:11 AM   #5
Alekti
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
Upgraded to bios A03, and Fedora Core 2 works!

I'm afraid to try slackware now though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10.1 official and dell inspiron 5160 guelzimtr Linux - Laptop and Netbook 1 09-23-2005 03:22 AM
Installation Problems, RH 6.2 on Dell Inspiron 1150 rdiemand Linux - Laptop and Netbook 1 07-22-2005 04:07 PM
Framebuffer with intelfb (Dell Inspiron 1150) Anders1 Linux - Laptop and Netbook 6 03-17-2005 02:30 PM
headphone sound, FC3, inspiron 1150 jeremiahbell Linux - Laptop and Netbook 2 01-15-2005 03:22 PM
FC 1 on a Dell Inspiron 1150 *problems* igo_mexico Fedora 5 09-07-2004 08:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration