LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-16-2006, 03:00 PM   #31
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30

I'm pretty confident the redirect to port 80 is right.
 
Old 10-16-2006, 03:33 PM   #32
kvedaa
Member
 
Registered: Mar 2004
Location: Virginia
Distribution: PacketProtector
Posts: 331

Rep: Reputation: 30
Any news reguarding the DSL Router configuration?
 
Old 10-16-2006, 03:46 PM   #33
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
I went through the procedure again.
It's not a clear way to set port 80.
It's called 'Application Level Gateway'.
Your enter '192.168.0.6' then select 'Web Server'.
The rule shows port 80, so I guess it's right.
Is it possible to attach the screen here?
 
Old 10-16-2006, 03:59 PM   #34
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Could NAT be the problem? NAT is set to 'on'.

NAT

Warning: Please do not disable NAT unless instructed to do so by your ISP. Turning off NAT will open your DSL Gateway to outside intrusion, creating a security risk.

NOTE: If you turn NAT off, you MUST specify a static route for your local subnet. However, if you have configured an Unnumbered IP address then you will not need to disable NAT and/or enter any Static Route.



Static Routing is set as follows.

Static Routes can be entered in the spaces below. "Subnet IP" is the IP address of the subnet being defined. "Subnet Mask" is the subnet mask of the subnet being defined. "Gateway IP" is the IP address of the DSL Gateway and can be empty for the local subnet.

Subnet IP Subnet Mask Gateway IP
192.168.0.2 255.255.255.0 192.168.0.1


Static Routing Table

I changed Subnet IP to 192.168.0.6 but it did not help.
Would it help to turn NAT off then set static to 192.168.0.6?
 
Old 10-16-2006, 06:22 PM   #35
kvedaa
Member
 
Registered: Mar 2004
Location: Virginia
Distribution: PacketProtector
Posts: 331

Rep: Reputation: 30
In this case I think that you want to keep NAT inplace.

I think that the idea that the ISP may well be blocking your access to port 80. With this in mind I would try this with another port. For starters change the the port reference in the http.conf file from port 80 to some other number (such as 8080). Then restart the apache service. Now from inside the LAN you should be able to access the web site by going to:

http://192.168.0.6:8080

(if you opt to use a port other than 8080 substitute as necessary on the address above)

Once we have verified that this works than take a look at this instruction from no-ip

http://www.no-ip.com/support/guides/...k_port_80.html

[the TinyURL link if the above]

http://tinyurl.com/fdmuq

If I understand their instruction you should be able to mask non-standard port numbers.

Now you will have to set up port forwarding on the newly selected port on your DSL router sending port 8080 (or your selected port) to your web server (192.168.0.6). Now you should be able to access your page manually by typing:

http:\\[ip_address_from_IPchicken]:8080

If this works then you should be able to go ahead and try the no-ip hostname. (assuming that you followed the instructions on the link above)

Let me know how it works out.

Happy Hunting!
 
Old 10-16-2006, 07:24 PM   #36
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Shut down 'httpd'
When starting it again I got the error;
Starting httpd: httpd: Could not reliably determine the server's full qualified domain name, using 127.0.0.1 for ServerName.

Do you know what this mean and what it might affect?
Also, what do I do about it?
I'll see what I can find out.
 
Old 10-16-2006, 07:33 PM   #37
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Also, no-ip says 8833 can also be used.
I used that as a redirect and it did not work.
 
Old 10-16-2006, 07:34 PM   #38
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
I found no reference to 'port 80' in /etc/httpd/conf/httpd.conf
 
Old 10-16-2006, 08:04 PM   #39
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
I finally got /etc/httpd/conf/httpd.conf set so httpd started without errors.
I've had enough for one day.
I'll try again tomorrow.
I hope you guys will continue to try and help.

Thanks a ton for your efforts.
Don
 
Old 10-17-2006, 07:33 AM   #40
kvedaa
Member
 
Registered: Mar 2004
Location: Virginia
Distribution: PacketProtector
Posts: 331

Rep: Reputation: 30
This is from one of your comments yesterday

Quote:
I found the following in /etc/httpd/httpd.conf which I understand is what runs Apache. What should the 'Listen 0.0.0.0:80'be? Or, should it be as is?

#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
#
#Listen 12.34.56.78:80
Listen 0.0.0.0:80
If we look on the last line (since there is no '#' mark the line is not commented out. This is the httpd.conf (I think I made a typo in refering to this file yeterday), you will notice that the ip adress of 0.0.0.0 is followed by :80

This is what I was refering to by changing this value to the value of the port that you wish the web server to listen for.

Once the value is changed and the service has been restarted you should be able to test by trying to access the page on the new port from your LAN.

I hope that this helps.
 
Old 10-17-2006, 02:11 PM   #41
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Okay, here we go.
Changed 0.0.0.0:80 to 8080 and 8833.
8833 is an alternate suggested by no-ip.
Did not work.

At the no-ip site there is a page to test whether ports are blocked or not.
http://www.canyouseeme.org/
According to this, port 80 is not blocked. The rest are however.

I checked to see if 'noip-duc' was working by
[root@server don]# noip2
One noip2 process is already active,
and the multiple instance flag (-M) is not set.
[root@server don]#
and as you can see, it is.
 
Old 10-17-2006, 02:14 PM   #42
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Check that:
A check of port 80 at
canyouseeme.org
shows port 80 is not working now.

What exactly should I put for an ip address at the no-ip site?
 
Old 10-17-2006, 02:14 PM   #43
kvedaa
Member
 
Registered: Mar 2004
Location: Virginia
Distribution: PacketProtector
Posts: 331

Rep: Reputation: 30
OK, one step at a time.

After you have changed the port number did we have success on reaching this page from a web browser on another system on your LAN at the given port?
 
Old 10-17-2006, 02:23 PM   #44
kvedaa
Member
 
Registered: Mar 2004
Location: Virginia
Distribution: PacketProtector
Posts: 331

Rep: Reputation: 30
At the moment I would not worry about no-ip, first we need to make sure that your Apache instance is actaully responsing to the desired alternate port. So you mentioned to possible alternated 8080 and 8833. Pick one, any one, it should not matter.

For the sake of argument let say 8833.

Change the httpd.conf to replace the original 80 with 8833.

Restart the service.

From another workstation, bring up a web broswer and look for:

http://192.168.0.6:8833

This should return you default site (whatever that is at the moment). Can you confirm that this is indeed working as we would expect it to?
 
Old 10-17-2006, 02:49 PM   #45
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Check that- again.
Forget that.
I had not changed the listen back to 80.
It was still set at 8833.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get my external IP address from behind a NAT? Moses420ca Linux - Networking 23 01-25-2013 05:35 AM
Cannot see my webserver using the external IP address shazam75 Linux - Networking 12 09-30-2005 08:32 PM
How do I get external IP address of router... The_JinJ Linux - Networking 2 02-05-2005 07:43 AM
SSH to an external IP address BluePyre Linux - Software 2 07-14-2004 06:10 PM
external ip address dica Linux - Networking 8 10-05-2003 09:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration