LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 07-19-2004, 04:55 AM   #16
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42

Thanks XJNick !

Quote:
Originally posted by XJNick
What does ifconfig return? If the network card is up, you should see an entry for both eth0 and lo.
Here is the output when typing ifconfig:
Code:
[root@localhost thort]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:02:44:16:55:AC
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:248 (248.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0x9400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:162 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11742 (11.4 Kb)  TX bytes:11742 (11.4 Kb)
I assume this indicates my network is up.






Questions:

Is it necessary to have a device connected to the network card to get the network interface up?

Would the eth0 start at Mandrake start-up if nothing is connected to my Ethernet card?

Is it always necessary to make settings in Mandrake Control Center (or if you're skillful the Terminal) to make Internet work?

I'm asking because I didn't make any additional settings in MCC when I installed Mandrake 9.2? All where managed automatically. Internet worked at once.

Now I have installed 10.0 and Internet doesn't work. Mandrake 9.2 installation program did make eth0 start at Mandrake start-up. Mandrake 10.0 installation program have failed doing this. Now I get an red error at start-up.





How do I make my eth0 start at Mandrake start-up?






I can't see why I should type in any username or password for Internet when it wasn't necessary in Mandrake 9.2?

I use an external adsl modem connected to the ethernet card. The modem is then connected to the telephone line. The modem is always on and always on-line with the telephone station. So, as I understand, Internet is always online to the ethernet card.

Long ago, when I established my adsl connection the modem had to call my Internet provider. This was done using a special ip-adress wich my provider gave me. Using a browser, this ip-adress took me to a site where I was told to type in user-name and password. When this was done Internet worked. All this I did using Windows XP. Nowhere in XP there is any boxes where my user-name and password is stored. As I understand, in some way, the user-name and password is stored in the modem. And the modem is always online with Internet and make Internet on-line at my ethernet card. So, now when I have established a dual boot system with Windows Xp and Mandrake it should be possible to get access to Internet in Mandrake. Internet is right now working OK when starting XP.





Please help me to sort all this out?

And please be patience with me if I am tedious.
 
Old 07-19-2004, 05:37 AM   #17
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Now I know !!!

I've read the manual from my Internet provider.

My user-name and password is stored in my adsl modem.

So, no user-name and password is needed to get my adsl work in Mandrake.

Please, help me set up the right network protocol and make my eth0 start at Mandrake start-up.
 
Old 07-19-2004, 10:20 AM   #18
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi,

Quote:
Originally posted by thort

Here is the output when typing ifconfig:
Code:
[root@localhost thort]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:02:44:16:55:AC
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:248 (248.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0x9400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:162 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11742 (11.4 Kb)  TX bytes:11742 (11.4 Kb)
I assume this indicates my network is up.
Yes. The network is up, but there is no IP (aka "inet") address being assigned to eth0. At the terminal try typing ifdown eth0 then type ifup eth0 to restart the network interface. During the start-up it should flash "Determining IP address for eth0..." or something to that effect.

Quote:
Originally posted by thort
Is it necessary to have a device connected to the network card to get the network interface up?
Yes, I believe so.

Quote:
Originally posted by thort
Would the eth0 start at Mandrake start-up if nothing is connected to my Ethernet card?
It would probably attempt to start-up then return the [failed] message. You should have the network card plugged into the modem during boot.

Quote:
Originally posted by thort
Is it always necessary to make settings in Mandrake Control Center (or if you're skillful the Terminal) to make Internet work?
Absolutely not. My computers connect to a home network which is connected to the internet through a router and ADSL modem. Because of the router handling all the dialing, nothing had to be done to get them on the internet. After I had installed Mandrake, internet worked and continues to work. The only reason I say you might need to set stuff in MCC is if you need to tell Linux to dial your ADSL modem to the internet, if you don't have a router to do it for you.

Quote:
Originally posted by thort
I can't see why I should type in any username or password for Internet when it wasn't necessary in Mandrake 9.2?

I use an external adsl modem connected to the ethernet card. The modem is then connected to the telephone line. The modem is always on and always on-line with the telephone station. So, as I understand, Internet is always online to the ethernet card.
No, that is not the case. If you have a standard ADSL modem connected straight to the computer, you'll have to use software to dial it (such as the built-in dialing software in XP or Mandrake). However, if you have a modem with a router built-in, then the router becomes the dialing software and it would store the username/password and handle all dialing functions.

So, from your description, it sounds like you have a router. otherwise, you'd HAVE to enter a username/password into the MCC internet connections wizard so it would dial into the internet for you.

Now, if you have a router, you should be able to simply connect the router to the computer, bring up interface eth0, open a browser and be on the internet. If this is not the case, it'd likely be a setting is set wrong in the router software, or the physical connection between the modem/router/computer is not correct.

Maybe you could take a picture of your modem/router or describe it really well so we can figure out if it is a router or not?

-Nick

Last edited by XJNick; 07-19-2004 at 10:22 AM.
 
Old 07-19-2004, 12:42 PM   #19
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi XJNick !

Thanks for your reply!

Quote:
Originally posted by XJNick
Yes. The network is up, but there is no IP (aka "inet") address being assigned to eth0. At the terminal try typing ifdown eth0 then type ifup eth0 to restart the network interface. During the start-up it should flash "Determining IP address for eth0..." or something to that effect.
ifup eth0 gives this output:
Code:
[root@localhost thort]# ifdown eth0
[root@localhost thort]# ifup eth0
Determining IP information for eth0... failed; no link present.  Check cable?
Check cable it says. That's not the problem since Internet works okey when running Windows XP.

Quote:
Originally posted by XJNick
However, if you have a modem with a router built-in, then the router becomes the dialing software and it would store the username/password and handle all dialing functions.
My adsl modem has a built-in router. Here is the site for my modem. The brand is "Zyxel Prestige 645 MP".




So, now we have come a little closer to the solution.

The problem now is: How do we make this adsl modem with bult-in router connect to the Internet?
 
Old 07-19-2004, 01:34 PM   #20
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Quote:
Originally posted by thort
The problem now is: How do we make this adsl modem with bult-in router connect to the Internet? [/B]
That's just it... if it has a router built-in and all the settings are correct in the router, you shouldn't need to do anythng to get it to connect to the internet... it should all be automatic.

And apparently it is working for you, as you can access the internet through Win XP. What we need to figure out is what is set differently between XP and Mandrake that's making XP work with the network connection and Mandrake not work.

When you call ifup eth0 , no IP address is specified, so Linux will try to bring up the network interface and get an IP address assigned to it from the DHCP server, if you have one. Most routers have built-in DHCP servers. The question is, are you using the DHCP server or not? if you aren't, then you'll need to manually specify an IP address when bringing up eth0.

Look at your network settings in Windows XP (start > settings > network connections) . See if it is set to automatically assign IP address or if an IP address has been specified in the network connection properties. If there is an IP address specified, try bringing up eth0 in Mandrake with that same IP address by doing the following (after bringing down the network if it is already running): ifconfig eth0 up xxx.xxx.xxx.xxx (insert IP address in place of xxx.xxx.xxx.xxx).

I'll continue to think about what else could be causing it to work fine in XP but not in mandrake...
-Nick
 
Old 07-19-2004, 05:39 PM   #21
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Thanks for helping me!

Quote:
Originally posted by XJNick
Look at your network settings in Windows XP (start > settings > network connections) . See if it is set to automatically assign IP address or if an IP address has been specified in the network connection properties.
This information I found in Windows XP regarding my network connection:

Windows XP network setting - 1

Sorry, but my XP is in Swedish. Adresstyp means "kind of adress". Tilldelad av DHCP means "Allocated by DHCP"

Clicking the information button in this window brings up this information:

Windows XP network setting - 2

My current dynamic ip-adress seems to be 192.168.2.2

Another adress often mentioned is 192.168.2.1

Quote:
Originally posted by XJNick
If there is an IP address specified, try bringing up eth0 in Mandrake with that same IP address by doing the following (after bringing down the network if it is already running): ifconfig eth0 up xxx.xxx.xxx.xxx (insert IP address in place of xxx.xxx.xxx.xxx).
I tried this. First with 192.168.2.1, getting this result:
Code:
[root@localhost thort]# ifconfig eth0 up 192.168.2.1
[root@localhost thort]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:02:44:16:55:AC
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::202:44ff:fe16:55ac/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:47 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2972 (2.9 Kb)  TX bytes:9828 (9.5 Kb)
          Interrupt:10 Base address:0x9400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:719 errors:0 dropped:0 overruns:0 frame:0
          TX packets:719 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:53040 (51.7 Kb)  TX bytes:53040 (51.7 Kb)
I also tried the same with the other adress 192.168.2.2

Afterward I tried to connect to Internet, but without success. I logged out from KDE and in again but in vain.





So, will this new information lead us forward?

What will be the next step to make Mandrake connect to Internet?
 
Old 07-19-2004, 09:08 PM   #22
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi,

Well, to be honest I'm starting to run out of ideas here...

From your output of ifconfig, though, it looks as though data is being sent to/from the network interface. Maybe the problem is that the routing settings aren't correct in Linux, that is, you have the network connected properly but data isn't being directed through it?

Try becoming root then typing route in the terminal. When I type route, I see the following:

Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.7.0     *                  255.255.255.0   U     0      0        0     eth0
default           192.168.7.7       0.0.0.0         UG    0      0        0     eth0
Do you have a similar routing table? Just for your info, 192.168.7.7 is the local IP address of my router. So I'd imagine you should be seeing your DSL modem/router's IP address under "gateway" where I see my router's address.

P.S. Your screen shots are nice.
-Nick

Last edited by XJNick; 07-19-2004 at 09:09 PM.
 
Old 07-20-2004, 03:14 AM   #23
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi !

Quote:
Originally posted by XJNick
Try becoming root then typing route in the terminal. When I type route
Typing route gives this result for me:
Code:
[root@localhost thort]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
[root@localhost thort]# ifconfig eth0 up 192.168.2.1
[root@localhost thort]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
First, typing route just gives headings. After typing ifconfig eth0 up 192.168.2.1 I see nothing under the heading "Gateway". But my knowledge is limited so I can't understand the information.



A sum up of the problem:
  • There is a red error concerning the eth0 network start during Mandrake start-up.
  • I have a functioning Internet connection when running Windows XP in my dual boot system. In XP my adsl modem with built-in router works ok.
  • I get a functioning Internet connection when doing a clean install of Mandrake 9.2. This without doing any complementary configuration after installation.
  • When doing an upgrade to 10.0, or a clean install of 10.0, I have no functioning Internet.

Is there some kind of troubleshooting guide about processes starting during Mandrake start-up? I mean, all these green OK passing by on the screen. Is there some guide dealing with those. If so, what will it say about troubleshooting the network eth0 start-ip?



What am I to do next? All proposals are welcome!

Last edited by thort; 07-20-2004 at 03:22 AM.
 
Old 07-20-2004, 05:43 AM   #24
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
i don't remember if this has been brought up before, but you don't have any firewall running during setup for internet do you? i think the MDK firewall, Shorewall, is enabled by default. in terminal, as root, try typing....... service shorewall stop. if it was running, it will tell you it's shutting down & then shut it down. and, you mentioned earlier about your router has all your IP info saved so there's no need to enter the pertinent info in MCC->DrakConnect. i am not familiar with this router/adsl modem, so excuse my ignorance, but i've never heard of such a thing. and, even if that is the case, i still think you need to enter the correct user/login parameters in DrakConnect to make a connection.

Quote:
I have run the wizard again and typed in provider name "tele2adsl". Then ran "adsl-start" in the Terminal. But no connection.
AFAIK, that is not enough for a correct provider name. you need the .com, .net, .whatever domain after tele2adsl. again, i could be wrong, but i've never heard of doing it any other way.

otis
 
Old 07-20-2004, 07:06 AM   #25
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi !

Welcome back otis !

Quote:
Originally posted by otish1000c
i don't remember if this has been brought up before, but you don't have any firewall running during setup for internet do you? i think the MDK firewall, Shorewall, is enabled by default. in terminal, as root, try typing....... service shorewall stop.
Good point! It's good to be sure about this. Here is the result of typing service shorewall stop
Code:
[root@localhost thort]# service shorewall stop
Cannot find shorewall service
Usage: service -[Rfshv] SERVICE ARGUMENTS
        -f|--full-restart:      Do a fullrestart of the service.
        -R|--full-restart-all:  Do a fullrestart of all services currently running.
        -s|--status-all:        Print a status of all services.
        -d|--debug:             Launch with debug.
        -h|--help:              This help.
        -v|--version:           Print version.

version 1.14
So, we see no firewall is running.
Quote:
Originally posted by otish1000c
and, you mentioned earlier about your router has all your IP info saved so there's no need to enter the pertinent info in MCC->DrakConnect. i am not familiar with this router/adsl modem, so excuse my ignorance, but i've never heard of such a thing. and, even if that is the case, i still think you need to enter the correct user/login parameters in DrakConnect to make a connection.
Here is the link to the site about my modem.

And here is a link to the Knowledge Base on the same site. It's talking about log in.
Quote:
Originally posted by otish1000c
AFAIK, that is not enough for a correct provider name. you need the .com, .net, .whatever domain after tele2adsl.
Yes, I'm aware tele2adsl is not correct. It must be a dot and a domain name. But I don't have any information about the correct provider name. And the discussion in the recent posts in our thread is pointing to it's not necessary to make any settings in Mandrake Control Center. And, by the way, the adsl configuration guide we where talking about in the firsts posts acquire not only to fill in provider name but also username and password. As I understand, no complete working configuration can be achieved using this guide if not all but the optional fields are filled in.



What I want to know now, is if it's possible to get the eth0 network starting at Mandrake start-up when all boxes are left unfilled in the Mandrake Control Center network manager.



Once again, thanks for your concern about my problem!
 
Old 07-20-2004, 10:14 AM   #26
psych27
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
Hi,

I'm just posting to say that I've had the exact same problem as you(thort) up until recently.
After I installed Mandrake 10 i figured that everything was set to go; the physical connection was set, and the software settings seemed to be correct, however I couldn't get online. So, after numerous failed attempts to tweak around with the "network & internet" configs in control center, I decided to let Mandrake be for a couple of days, and used phlak and windows instead. (both worked online)
This morning I figured I'd give Mandrake another shot, and, without altering any configurations, it worked. eth0 was recognized from start, I was automatically issued an IP, and everything... well, worked. I don't think I did anything but putting my ethernet card in an alternate PCI socket before booting, so unless that did the trick, I'm clueless. (Perhaps you should try changing the placement of your ethernet card yourself, just in case?)
Anyway, since it seems as we've had just about the same problems, I guess it wouldn't hurt running our settings side by side for comparision?
Unfortuneatly I'm quite green with Linux, so I don't really know what settings that'd be important to list, (anyone care to name them?) but here are a couple of screenshots: Manage Connections and Internet Access (masked the full IP out of paranoia ^,^; ).
As you can see, I also use Tele2; and as you, from what I understand, use the swedish version, I'd guess your domain would be something like adsl.tele2.se. (not certain)

Well, if anyone are interested in giving us any specific settings to check, I'd be more than willing to list mine.
Also, is it a possibility that this is an ISP-specific problem?

Note that I too use the kind of modem as you, though a different brand and model.
 
Old 07-20-2004, 10:35 AM   #27
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Thanks psych27 !


Very interesting!

I will look through your post thoroughly later this evening or tomorrow.

So, you also have Tele 2 as provider in Norway. And the same kind of modem, although not the same brand. Is it an adsl modem with built-in router just as mine?

I would be glad if you could help me.

But as I said. I will take a closer look at your post later.


Thor
 
Old 07-20-2004, 11:00 AM   #28
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi,

I think we may have found your problem with the output of route . It seems you don't have any default route specified. It is my understanding that the without the default route, the networking apps (like the browser) won't know how to find the internet connection.

To add a default route, do the following in the terminal (I'm going to assume your router/modem's IP address is 192.168.2.0, and your computer's IP address is 192.168.2.1) :

- Bring up the network interface with your computer's typical IP address : ifconfig eth0 up 192.168.2.1 .
- Add a default route to your router/modem's IP address with: route add default gw 192.168.2.0 .

Now when you type route you should see at least 2 lines which look similar to these:

Code:
192.168.2.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.2.0     0.0.0.0         UG    0      0        0 eth0
Try the internet now. Note that all of this is only set until you reboot the computer. I'm not focusing on the boot-up stuff because it is more important that we can get you a connection manually first, before going and editing the boot scripts.

As a side-note: if it still doesn't work, try bringing up the network interface without an IP address (let DHCP do it) then try again.

-Nick

Last edited by XJNick; 07-20-2004 at 11:02 AM.
 
Old 07-20-2004, 12:17 PM   #29
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
Hello there, thort and others,

I noticed your Windows info in post #21, which kind of don't match that you told the connection wizard in Mandrake to use PPPoE in post #8. Are you sure about the PPPoE? I don't think this is correct; you should tell it to use DHCP (Dynamic Host Configuration Protocol). This also fits in the picture considering that you don't have a route. I think DHCP will set up this automagically, and since it's not used, it won't work.

HTH
 
Old 07-20-2004, 12:30 PM   #30
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi,

But if his DSL modem has a working router built-in, it is the responsibility of the router to dial the modem and connect to the internet -- not the computer's software. Thort, if you are using the router, it should be dialing and connecting on it's own, so there would be no reason to use the mandrake internet connection wizard for dialing. Only setup the connection through mandrake internet connection wizard if you need mandrake to dial the modem and connect it to the internet, i.e. if you do NOT have a router.

This means that settings such as choosing PPPoE or DHCP for the WAN (DSL connection) would be set in the router. And since you can connect through Win XP, I'm assuming all the router settings are correct.

Also, the DHCP settings you see in your win XP settings is DHCP on the LAN (local network between your router and computer(s)). Don't get that confused with connecting to the DSL through DHCP (which would be a WAN setting between the modem and your ISP).

-Nick

Last edited by XJNick; 07-20-2004 at 12:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl configuration paul62 Debian 9 10-20-2005 02:38 PM
dlink 502T Adsl configuration shueib Linux - Newbie 1 10-19-2005 11:29 AM
slackware network configuration adsl shashank Linux - Software 2 05-31-2005 04:36 AM
Adsl configuration trough the terminal Alex_jacobson Linux - Networking 0 07-09-2004 12:50 PM
Adsl Modem Configuration hemanth_020784 Linux - Hardware 0 01-03-2004 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 11:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration