LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 07-16-2004, 01:36 PM   #1
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Rep: Reputation: 42
ADSL configuration


Hi !

When installing Mandrake 9.2 the installation program automatically found my adsl connection and configured it. Internet worked fine.

Now, I have updated to 10.0. But the Mandrake 10.0 installation program didn't configure my adsl connection right. No Internet now.

Mandrake have found and installed my Ethernet card.

Modem brand: Zyxel Prestige 645 MP.

My question is: How do I configure my adsl connection?

I'm new to Linux.

I would be grateful if someone of you experts would help me.
 
Old 07-16-2004, 03:01 PM   #2
Beised
LQ Newbie
 
Registered: Jun 2004
Location: Brasil - Rio de Janeiro
Distribution: SUSE 9.1
Posts: 21

Rep: Reputation: 15
Try, Mandrake Control Center.

Good Luck,

Eduardo
 
Old 07-16-2004, 03:08 PM   #3
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
you can use the DrakConnect wizard in Mandrake Control Center (MCC for short). you can access MCC via kicker(the KDE "K" or star in the left corner of the panel)->system->configure your computer, or you can open a terminal & type mcc (hit enter). if you do the latter method as root, you won't have to supply a password. right, now MCC is open. go to "network & internet"->"make new connection". you'll need to have some info handy.......... service provider name, your name, password, dns server address, make of eth0 card. just follow the wizard, fill in the blanks, accept the final configuration when finished. you'll probably be asked to restart KDE for the settings to take effect. do so. then when back in KDE, open a terminal, su to root, then type adsl-start (hit enter) to start connection. adsl-stop will stop it. if you want your internet connection to start at boot, in MCC go to "system"->services & make sure "network" & "internet" are set to start at boot.

oh............before you configure your connection, if you're running a firewall temporarily disable it. if you're using shorewall, in terminal as root type service shorewall stop (hit enter). service shorewall start will start it when done. if you're using another firewall, then use whatever method you use. if you're not running a firewall, then i'd suggest looking into it as soon as you get the internet set up.

otis
 
Old 07-16-2004, 03:13 PM   #4
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by Beised
Try, Mandrake Control Center.

Good Luck,

Eduardo
Thanks!

I've been at the Control Center. I've gone thru the configuration guide, but I don't know what options to choose. The guide talks about "dhcp" and "pppoe". There are a lot of field to fill in. Hostnames and Gateways.

Can someone help me, please?
 
Old 07-16-2004, 03:25 PM   #5
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
read my post #2. a few things i can help you with. choose pppoe. your dns server address is what your internet provider gives you as a gateway. you can get that from your ISP if you call them. or, if you have a windows machine running somewhere, use that to determine you dns address. for host name, use whatever you call your computer. the default name is, well, default. if you named your computer something else, then use that. to determine your default host name, just open a terminal. at the prompt where it says (user)@(default name here) (user), the "default name here" part will be your default host name. when it asks for your eth0 card, just make sure what it finds matches your card. if you have more than one eth0 card, you prolly should disable the one you aren't using via the BIOS.

otis

Last edited by otish1000c; 07-16-2004 at 03:27 PM.
 
Old 07-16-2004, 05:08 PM   #6
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by otish1000c
read my post #2. a few things i can help you with. choose pppoe. your dns server address is what your internet provider gives you as a gateway. you can get that from your ISP if you call them. or, if you have a windows machine running somewhere, use that to determine you dns address. for host name, use whatever you call your computer. the default name is, well, default. if you named your computer something else, then use that. to determine your default host name, just open a terminal. at the prompt where it says (user)@(default name here) (user), the "default name here" part will be your default host name. when it asks for your eth0 card, just make sure what it finds matches your card. if you have more than one eth0 card, you prolly should disable the one you aren't using via the BIOS.

otis
Thanks otis !

Quote:
choose pppoe
I had a working adsl connection when using Mandrake 9.2. Before upgrading to 10.0 I overlooked the network settings and saw Mandrake 9.2 where using the protocol "dhcp".

This where the settings in Mandrake 9.2. I wrote them down before upgrading. Internet worked whith these:

[COLOR=dark red]Hostname: dhcppc0

Gateway: -

lan

IP Adress: 192.168.2.2

Protocol: dhcp

Driver: fealnx[/COLOR]

So, am I really to choose "pppoe"? When installing 9.2 I never typed in my Name, Password and DNS server adress. This I am asked to do now in the "New connection Guide" when choosing "pppoe".

As I understand, as long as my modem is on, I'm connected to Internet regardless if my computer is on or not. Internet is always present at the entrance of my Ethernet card. Username and password I have once and for all typed in long ago in Windows xp then I installed my adsl modem (I'm running a dual boot system).

Going through the "New Connection Guide" choosing "lan" gives these steps:

Step 1

Step 2

Step 3

Step 4 What am I to fill in here?

Step 5 What about this?

Step 6 What shall I write here?

Step 7

Step 8

Step 9

Please help me! It's annoyng not having Internet working

Last edited by thort; 07-16-2004 at 05:14 PM.
 
Old 07-17-2004, 07:18 AM   #7
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
if i understand correctly, you have a stand alone ADSL connection. you didn't make any mention of running a network. if you are not running a network & do have a stand alone ADSL connection, then by looking at the screenshots you provided, you are choosing the wrong connection type. in the first screen you posted, choose ADSL not LAN. that should take you to another screen where you can choose pppoe as you connection type. then it will search for & find your eth0 card. after that is when you fill in your IP info. to get your DNS info, use Windows. in Win98 you were able to type winipcfg in the "run" box & that would show you a detailed overview of your internet connection settings. not sure what it would be in WinXP, but you should be able to get the info by opening a DOS prompt & typing ipconfig /all while connected to the internet. from then on it's fill in blanks. you have a user name for your isp, you should have a password also. after you fill in the info, you'll get to the final screens asking if you want internet to start at boot & telling you to restart X. so, the key is to choose ADSL in the beginning, not LAN.

otis
 
Old 07-17-2004, 09:38 AM   #8
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Thanks otis !

Quote:
if i understand correctly, you have a stand alone ADSL connection
Yes, an external adsl modem connected to the telephone line.

Quote:
you didn't make any mention of running a network
I'm not connected to any other computer in a network.

Quote:
in the first screen you posted, choose ADSL not LAN
Ok, We will test this. Here is the first screens:

ADSL Step 1

ADSL Step 2

Quote:
that should take you to another screen where you can choose pppoe as you connection type.
ADSL Step 3

Quote:
after that is when you fill in your IP info
ADSL Step 4

Quote:
to get your DNS info, use Windows. in Win98 you were able to type winipcfg in the "run" box & that would show you a detailed overview of your internet connection settings. not sure what it would be in WinXP, but you should be able to get the info by opening a DOS prompt & typing ipconfig /all while connected to the internet.
Typing "ipconfig /all" at the Command Prompt in Windows Xp gives this output:

ipconfig /all

Quote:
from then on it's fill in blanks
ADSL Step 5

ADSL Step 6

After all these steps I did logout, and then logged in again to KDE.

Directly I went to Konqueror and tried to open up a webpage.

It Didn't work.

Now, I rebooted my computer.

The boot process reported eth0 not started. Red error.

Next the boot process said: "Checking internet connections to start at boot". I got a timeout and a red error.



Did I do somethong wrong?

What am I to do now?

Last edited by thort; 07-17-2004 at 09:43 AM.
 
Old 07-17-2004, 10:08 AM   #9
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
okay..........

in step 4, you did not enter your provider name. it would be something like tele2adsl.com (or .net or .org, etc.) also, you may not need to use @tele2adsl in the "account login (user name)" box. i know i don't with mine. i just use my account user name without the @ part. you'd have to try it with & without to find out which one works in your case.

you don't have a screenie where it asks for default hostname. i don't understand your ipconfig output language (sorry.........English only here) but i'm guessing that Varddatornamn.............thor is it, so your default hostname would be thor. if it is different in Mandrake, you can find that out by opening a terminal & looking at the prompt. like, mine looks like this.........

[otis@default otis]$

so mine hostname for Mnadrake is default. (boring i know, but hey.) again, try both (if they are different in Windows & MDK) to see which one works.

in step 5, try not letting it start at boot. to start your connection once you're at your desktop, open a terminal, su to root, then type adsl-start (hit enter). that will start your adsl connection. to stop it, you'd type adsl-stop.

finally, in step 6, instead of just restarting X, try a complete reboot. if you still get an error about not finding your eth0 card on boot, just proceed & try to logon to internet when the boot is complete.

also, check in MCC->system->services & make sure network is checked to start at boot. i know you're not on a network, but that's needed to be running for any internet connection.

if you can't connect with the adsl-start command, try connecting by opening MCC->network & internet & use the "monitor connections" module. open that, then click the "connect" button, then try internet.

if none of the above doesn't hook you up, please post back & we'll use the hardware detection module in MCC to make sure you're card is recognized properly.

otis
 
Old 07-17-2004, 12:13 PM   #10
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi !

I do appreciate you helping me !

I will comment your suggestions one by one.

Quote:
in step 4, you did not enter your provider name
I don't know my provider name. I have information from my internet provider to help me connect to internet using Windows. I have three data: Username, password and an ip-adress which take me to an Internet Explorer site on which I type in username and password. My internet provider don't give any support on Linux.

Quote:
you don't have a screenie where it asks for default hostname
There is no such question in the "New Connections Guide"

Quote:
you can find that out by opening a terminal & looking at the prompt. like, mine looks like this.........

[otis@default otis]$
Mine is [thort@localhost thort]$

Quote:
to start your connection once you're at your desktop, open a terminal, su to root, then type adsl-start
I tried this. No connection where established.

Quote:
finally, in step 6, instead of just restarting X, try a complete reboot. if you still get an error about not finding your eth0 card on boot, just proceed & try to logon to internet when the boot is complete.
Tried it. No Internet access.

Quote:
also, check in MCC->system->services & make sure network is checked to start at boot.
It's checked to start at boot.

Quote:
if you can't connect with the adsl-start command, try connecting by opening MCC->network & internet & use the "monitor connections" module. open that, then click the "connect" button, then try internet.
Tried this also. No connection.

Quote:
if none of the above doesn't hook you up, please post back & we'll use the hardware detection module in MCC to make sure you're card is recognized properly.
Here is the information about my Ethernet card in the Hardware Detection Module:

Ethernet Card





Have I understod right? First we have to make my Ethernet Card start at boot. After that, we can concentrate on configuring the adsl. Shall the eth0 always start at boot regardless if I have created an adsl connection or not? Is it just enough to have an Ethernet card installed in the system to make eth0 start at boot?





Two things to consider:

1) This is a dual boot system. Internet works okey in Windows XP on my computer.

2) If I erase Mandrake 10 and make a clean install of Mandrake 9.2 the 9.2 installation program manage by itself to create a fully functioning Internet access. I know, because I tried this before starting this thread. And I do not type in any username or password. It's seems peculiar, but it's not needed. And eth0 is detected during boot.

So, why can't Mandrake 10 installation program manage to do the same as the 9.2?





Well. How do we go on now? Do you have some more suggestions? I realize you are more competent than me on Linux.
 
Old 07-17-2004, 12:24 PM   #11
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
i'm sorry. i'm busy for the rest of the day. i'll get back with more help later tonight or tomorrow. there's a few other thoughts i have. i'm sure we can get this worked out, so don't reinstall 9.2. that's not a solution, really. maybe somebody else will pick up on this before i get back.

otis
 
Old 07-18-2004, 06:12 AM   #12
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
ok............

Quote:
I don't know my provider name. I have information from my internet provider to help me connect to internet using Windows.
your provider name will be whatever you use after your e-mail address. for instance, i have Verizon as my ISP, my e-mail address is XXXXXXX@verizon.net, so my provider is verizon.net. in your screen shot i can see by your user name that your provider is tele2adsl, so that would be your provider. you just need to add .net, .com, or whatever the proper dot-extension is.

Quote:
OTIS: you don't have a screenie where it asks for default hostname.

THORT: There is no such question in the "New Connections Guide"

THORT: Mine is [thort@localhost thort]$
i could have sworn (from memory) there's a place in one of the wizard screens that asks for hostname. i forget which one, but your hostname would be localhost. if i'm wrong, then ignore that. but i don't think i am.

Quote:
Have I understood right? First we have to make my Ethernet Card start at boot. After that, we can concentrate on configuring the adsl. Shall the eth0 always start at boot regardless if I have created an adsl connection or not? Is it just enough to have an Ethernet card installed in the system to make eth0 start at boot?
yes, you understand correctly. the eth0 card needs to be detected during boot. but, i don't think that's the problem. you haven't mentioned this, but when your system boots do you get any errors during the boot about your eth0 card not being detected? or, do you get any boot errors about network not starting? if not, then i think your problem relates to the lack of proper provider address & hostname in the internet settings.

try running the wizard again. make sure you at least put the provider name in the correct box with the correct syntax. remember, it will be tele2adsl.(something) & look carefully for a box to put a host name.

try those 2 things & post back, please.
 
Old 07-18-2004, 06:27 AM   #13
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Thanks otis !

I will read your post thouroghly. But I'm a bit busy right now. I hope to be back later this evening (my time) whith an answer. I look forward to the time when my Internet works in Mandrake 10.
 
Old 07-18-2004, 01:54 PM   #14
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi again !

Quote:
yes, you understand correctly. the eth0 card needs to be detected during boot. but, i don't think that's the problem. you haven't mentioned this, but when your system boots do you get any errors during the boot about your eth0 card not being detected? or, do you get any boot errors about network not starting? if not, then i think your problem relates to the lack of proper provider address & hostname in the Internet settings.
I do get an error during boot. There are a lot of green OK passing by on the screen. One red error occur about Mandrake can't start eth0. So it has been all the time since I installed Mandrake 10.

So, Is this our next step? To make eth0 start at boot. If so, how do we achieve this?

Quote:
try running the wizard again. make sure you at least put the provider name in the correct box with the correct syntax. remember, it will be tele2adsl.(something)
I have run the wizard again and typed in provider name "tele2adsl". Then ran "adsl-start" in the Terminal. But no connection.

Quote:
& look carefully for a box to put a host name.
Following the options we have chosen in the "New Connections Guide" there is no box for hostname. Following other options in the giude brings to windows asking for hostname, but the options we have chosen don't lead to any hostname box. You can see all the windows showing our choice in the guide if you look above in my post number 8. Click on the "ADSL step"-links.





So, as I understand, first we have to make eth0 start at boot.
 
Old 07-18-2004, 11:59 PM   #15
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi,

If eth0 is failing at start-up, you'll not be able to get the internet working as the network interface is down, and you need it running to connect to your DSL modem.

After the computer boots, try typing the following in the terminal:

su - - To become the root user (you'll then be prompted for the root password)
ifconfig - - Shows the currently running network interfaces. usually eth0 and lo

What does ifconfig return? If the network card is up, you should see an entry for both eth0 and lo. If eth0 is NOT shown, try typing:

ifup eth0 - - Bring up the network interface eth0
ifconfig - - Now you should see a listing for eth0 with an IP address indicating the network interface is up.

That'll bring up the network (but not automatically on the next startup). Now try connecting to the internet (after changing connection settings in the MCC if necessary) Hope that helps
-Nick

Last edited by XJNick; 07-19-2004 at 12:06 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl configuration paul62 Debian 9 10-20-2005 02:38 PM
dlink 502T Adsl configuration shueib Linux - Newbie 1 10-19-2005 11:29 AM
slackware network configuration adsl shashank Linux - Software 2 05-31-2005 04:36 AM
Adsl configuration trough the terminal Alex_jacobson Linux - Networking 0 07-09-2004 12:50 PM
Adsl Modem Configuration hemanth_020784 Linux - Hardware 0 01-03-2004 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration