LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 07-20-2004, 02:02 PM   #31
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31

Yes, sure, but if there is a router, the computer needs to have the connection set up to and by it. What XJNick says does not contradict what I'm saying, it actually confirms it. The router has the connection to your ISP, dialing and giving the password and so on. But your computer has to connect to the router, using the correct protocol. Since it works in Windows, the router and the connection to the WAN is obviously ok (so's your NIC), so the glitch is elsewhere. Possibly it is the device driver, but it is simpler to test if the protocol is correct, since Windows seems to speak DHCP with the router, which Mandrake does not seem to do. Mandrake has to use DHCP too, not PPPoE. So fiddle with that in the MCC, I say.
 
Old 07-20-2004, 04:39 PM   #32
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Thank you all for your recent replies!

I will concentrate on answering and commenting XJNick:s reply in post number 28.

I will make my comments slowly and thorough.

Quote:
Originally posted by XJNick
Hi,

I think we may have found your problem with the output of route . It seems you don't have any default route specified. It is my understanding that the without the default route, the networking apps (like the browser) won't know how to find the internet connection.

To add a default route, do the following in the terminal (I'm going to assume your router/modem's IP address is 192.168.2.0, and your computer's IP address is 192.168.2.1) :

- Bring up the network interface with your computer's typical IP address : ifconfig eth0 up 192.168.2.1 .
- Add a default route to your router/modem's IP address with: route add default gw 192.168.2.0 .

Now when you type route you should see at least 2 lines which look similar to these:

Code:
192.168.2.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.2.0     0.0.0.0         UG    0      0        0 eth0
Okey, first, here is the result doing as you suggest. Typing in the Terminal gives this output:
Quote:
[root@localhost thort]# ifconfig eth0 up 192.168.2.1
[root@localhost thort]# route add default gw 192.168.2.0
SIOCADDRT: Network is unreachable
[root@localhost thort]# ifconfig eth0 up 192.168.2.2
[root@localhost thort]# route add default gw 192.168.2.1
[root@localhost thort]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 * 255.255.255.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.2.1 0.0.0.0 UG 0 0 0 eth0
The output of route above is difficult to read. Here is a picture of the same output in the Terminal. Things would be much easier if it was possible to insert pictures into the posts in this forum.

Okey. As you see the first attempt, using the exact parameters you suggested, resulted in SIOCADDRT: Network is unreachable

My second attempt with other ip addresses resulted, as you see, in an answer.

Wy did I try with these different ip addresses?

Looking at my network settings in Windows XP tells us that my current computer computer ip address is 192.168.2.2. This address vary over time. I have no permanent ip address. My Internet provider often gives me another ip address after a couple of weeks.

The same XP network settings also tells sus that the "Standard Gateway", "DHCP Server" and "DNS Server" is 192.168.2.1. This, as I understand, my router/modems ip address. This is, as I understand, stable and don't change over time.

You suggested 192.168.2.0, but that resulted in the answer SIOCADDRT: Network is unreachable
Quote:
Originally posted by XJNick
Try the internet now. Note that all of this is only set until you reboot the computer.
After I done the above seen typing in the Terminal I tried connect to Internet in the browser. No response.

I rebooted the hole computer into Mandrake, and tried connect. Still no response in the browser.

Then I did the same typing as above once more in the Terminal, but this time afterward I only logged out of KDE and in again. Still no Internet in the browser.
Quote:
Originally posted by XJNick
As a side-note: if it still doesn't work, try bringing up the network interface without an IP address (let DHCP do it) then try again.
I'm sorry, but I don't understand how to bring up the network interface without an IP address (let DHCP do it)





What is the conclusion of all this?

Have we had some success with the network? Is the output we got after I typed route in the Terminal to some extent a step in the right direction?





Sigh! This was difficult. But I'm confident I will make it. The help you guys have given me has been of great help. Bit by bit things gets clearer.

Last edited by thort; 07-20-2004 at 04:59 PM.
 
Old 07-20-2004, 05:01 PM   #33
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
OK, thort, have you tried using the settings that Mandrake 9.2 set up for you that actually worked? If the "LAN connection" doesn't work, try the "ADSL connection". With DHCP.
 
Old 07-20-2004, 05:09 PM   #34
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by Bebo
OK, thort, have you tried using the settings that Mandrake 9.2 set up for you that actually worked? If the "LAN connection" doesn't work, try the "ADSL connection". With DHCP.
Thanks Bebo !

I appreciate the eagerness to help all you experts have.

Now it's late here in Sweden. I will go to bed. I will deal with my problem again tomorrow.

Good night.
 
Old 07-20-2004, 05:30 PM   #35
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi,

in response to the following:

Quote:
Originally posted by thort
typing in the Terminal gives this output:

Code:
[root@localhost thort]# ifconfig eth0 up 192.168.2.1
[root@localhost thort]# route add default gw 192.168.2.0
SIOCADDRT: Network is unreachable
Okey. As you see the first attempt, using the exact parameters you suggested, resulted in SIOCADDRT: Network is unreachable
It seems the network is saying unreachable because we missed a step here. probably my fault

Let's try it with a DHCP assigned IP address since I'm sure you're using the DHCP server in the router: Do the following in the terminal:

ifup eth0
route add -net 192.168.2.0 netmask 255.255.255.0 dev eth0
route add default gw 192.168.2.0

NOTE: The IP address in the second line is your network's lowest IP address which is in 192.168.2.0 since eveything in your network uses a 192.168.2.XXX address. The IP address in the third line is your router/modem IP address (change it if I wrote the wrong address in!!!)

I can't see any reason why those commands wouldn't work for you unless the network card drivers in Linux are screwing up. I've verified that these route commands work by deleting ALL the routes on my computer (which makes my internet stop working) then adding the above mentioned routes, and I get the internet going again instantly.

The other point I was trying to get across before is that these commands are TEMPORARY. Meaning that restarting the computer (and I believe logging out as well) clears them. So don't restart the computer while trying this unless you retype ALL the commands after every boot-up and login. Plus, restarting really won't solve anything (I know being a Windows user your used to restarting )

If I was you I'd consider reinstalling mandrake 10.0 if you still can't get it to work - - sometimes things can get messed up during install and reinstalling is quicker than trying to track down and fix all the problem(s).

-Nick
 
Old 07-20-2004, 05:37 PM   #36
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Quote:
Originally posted by thort
I appreciate the eagerness to help all you experts have.
I don't think of my self as an expert... and I'm certainly not one. I'm just a satisfied Linux user who's still learning new stuff everyday.

-Nick

Last edited by XJNick; 07-20-2004 at 05:39 PM.
 
Old 07-20-2004, 05:40 PM   #37
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
...or why not actually use the MCC to set it up? As far as I've understood this has never been done (properly) in trying to solve this problem. That way the set up will be run at each system boot. Far less work than reinstalling.

OK, Cheers.
 
Old 07-21-2004, 04:09 AM   #38
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi agan XJNick !

And hi Bebo !

Quote:
Originally posted by XJNick
Let's try it with a DHCP assigned IP address since I'm sure you're using the DHCP server in the router: Do the following in the terminal:

ifup eth0
route add -net 192.168.2.0 netmask 255.255.255.0 dev eth0
route add default gw 192.168.2.0
Here is the result of trying this:
Code:
[root@localhost thort]# ifup eth0
Determining IP information for eth0... failed; no link present.  Check cable?
[root@localhost thort]# route add -net 192.168.2.0 netmask 255.255.255.0 dev eth0
SIOCADDRT: No such device
[root@localhost thort]# route add default gw 192.168.2.1
SIOCADDRT: Network is unreachable
No pleasant result.
Quote:
Originally posted by XJNick
The IP address in the third line is your router/modem IP address (change it if I wrote the wrong address in!!!)
This I did.

Okey. No success so far. Yet no Internet.
Quote:
Originally posted by XJNick
I can't see any reason why those commands wouldn't work for you unless the network card drivers in Linux are screwing up.
Maybe this it is so.
Quote:
Originally posted by XJNick
If I was you I'd consider reinstalling mandrake 10.0 if you still can't get it to work - - sometimes things can get messed up during install and reinstalling is quicker than trying to track down and fix all the problem(s).
Yes, it could be a solution. But then I will reinstall 9.2 first. In 9.2 I had a functioning Internet connection. It was configured automatically by the 9.2 installation program. After that I would back up all the network settings, and then upgrade to 10.0. Then I can use the backup to get Internet work in 10.0.
Quote:
Originally posted by Bebo
...or why not actually use the MCC to set it up? As far as I've understood this has never been done (properly) in trying to solve this problem. That way the set up will be run at each system boot. Far less work than reinstalling.
You are right. I have not know how to set things up in Mandrake Control Center. So, before reinstall I will take a tour in MCC and try to make some settings and give it a try.

Last edited by thort; 07-21-2004 at 04:10 AM.
 
Old 07-21-2004, 05:44 AM   #39
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
Yes, good, 'cause I think you were on the right track in your post 8.
 
Old 07-21-2004, 03:17 PM   #40
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Hi everyone !

A working Internet at last!

This I'm writing from within Mandrake 9.2.

I have just installed Mandrake 9.2. The installation program found and installed my network for Internet automatically.

Now I have written down all network settings. Even taken screenshots of the settings in Mandrake Control Center.

Now the most interesting part will come. An upgrade to Mandrake 10.0. Will I succeed this time? Will the installation program configure my network properly to give me Internet access? Last time I tried and upgraded from 9.2 to 10.0 it didn't. This time I have all settings written down so hopefully I can go to Mandrake Control Center and configure the network manually.
 
Old 07-21-2004, 03:26 PM   #41
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
Pardon me, but I believe that was very unnecessary. But since you've checked the settings again: are they the same as you wrote in post 6?
 
Old 07-21-2004, 05:02 PM   #42
XJNick
Member
 
Registered: Dec 2003
Location: Texas
Distribution: Mandriva, SuSE
Posts: 79

Rep: Reputation: 15
Hi,

I'd be interested to see the outputs of ifconfig and route .

-Nick
 
Old 07-21-2004, 05:36 PM   #43
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by Bebo
Pardon me, but I believe that was very unnecessary. But since you've checked the settings again: are they the same as you wrote in post 6?
Here is my settings in Mandrake 9.2 whith a working Internet:

Hostname: dhcppc0

Type: lan

Gateway: -

Zeroconf hostname: -

DNS server: 127.0.0.1

IP address: 192.168.2.2

Netmask 255.255.255.252

Boot protocol: dhcp


And here is screen shoots of the settings in Dracconect:

Dracconnect - Network settings

Hitting the different buttons in this window open up this information:

Dracconnect - Configure Hostname

Dracconnect - Configure Internet Access

Dracconnect - Configure Local Area Network





Now I have already upgraded to 10.0. As expected Internet isn't working. A red error on eth0 at start-up.

Here is the settings in Mandrake Control Center. The compare between the settings in 9.2 and 10.0 is a bit tricky because the interface has been changed. Anyway, here is the settings in 10.0 just after the upgrade:

Mandrake Control Center - Manage Connections

We values to the right in the screen shoot we recognize from the 9.2 settings. But we also see "Ip address" and "Netmask" is missing in the boxes.




So I made a test. I inserted the known "Ip address" and the "Netmask" into the boxes to see if it could help. But no success. No working Internet when trying to browse.




So, here we are!

What is to do now?

We have the working parameters from 9.2. How do we play with them in Mandrake Control Center to make Internet work in 10.0?

One thing we see from the 9.2 settings is we are talking about a "lan connection".
 
Old 07-21-2004, 06:01 PM   #44
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 19
Posts: 208

Original Poster
Rep: Reputation: 42
Quote:
Originally posted by XJNick
Hi,

I'd be interested to see the outputs of ifconfig and route .

-Nick
Hi again Nick !

It's special to get computer help in a discussion forum. There is always a time delay between the different posts. It is inevitable. When talking eye to eye it's easier to make up a plan for the help. What has happened now is I have rushed ahead and already updated to 10.0. So unfortunately it is not possible to look into ifconfig and route in 9.2

If it's to any help, here is the current ifconfig and route in 10.0:
Code:
[root@localhost thort]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:02:44:16:55:AC
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0x9400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3514 (3.4 Kb)  TX bytes:3514 (3.4 Kb)

[root@localhost thort]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
Now it is late here in Sweden. I will go to bed. I'l be back answering again tomorrow evening or on Friday, Swedish time.

Good night!
 
Old 07-22-2004, 02:23 AM   #45
Dommy
Member
 
Registered: Jul 2004
Location: Canberra
Distribution: Mint 7
Posts: 204

Rep: Reputation: 30
Part of your problem is that you have no ip address attached to your eth0
try setting your boot protocol to static and your netmask to 255.255.255.0 also you may need to add the ip address of your gateway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl configuration paul62 Debian 9 10-20-2005 02:38 PM
dlink 502T Adsl configuration shueib Linux - Newbie 1 10-19-2005 11:29 AM
slackware network configuration adsl shashank Linux - Software 2 05-31-2005 04:36 AM
Adsl configuration trough the terminal Alex_jacobson Linux - Networking 0 07-09-2004 12:50 PM
Adsl Modem Configuration hemanth_020784 Linux - Hardware 0 01-03-2004 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration