Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 01-02-2008, 11:39 PM   #1
LQ Newbie
Registered: Dec 2007
Posts: 9

Rep: Reputation: 0
Issue connecting to a linksys router.

I'm trying to connect my Linux/Windows pc to a wireless net being served by a Linksys WRT54G router. The administrator is not using encryption, but he is using MAC address filtering to grant permission only to PCs in his list. When I am in windows mode, I connect just fine. When I am in Linux mode, with my wifi device's MAC address entered properly onto his permission list, I cannot connect. In both cases the KDE desktop wireless assistant sees his network with plenty of strength. I am also able to completly associate with the AP I just cannot get out to the internet with it. The filtering blocks me.

I have checked MULTIPLE times that the Hwaddr is properly entered, and the MAC is proper... I am at a complete loss as to what to do.

Any tips on how to fix this MAC filtering issue? Is it possible for wireless assistant to grab the wrong MAC address on my side?
Many thanks.
Old 01-03-2008, 12:26 AM   #2
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
Can you connect the wireless router at all?

If you are able to connect to the router, but not able to access the internet, perhaps it's not getting correct IP information, i.e. default gateway and/or DNS IP addresses.

Try configuring with static IP and manually enter the default gateway and DNS address, and see if that makes a difference.
Old 01-03-2008, 04:47 AM   #3
Registered: Dec 2007
Location: UK
Distribution: Mageia, MX, Manjaro, OpenSuSE, PCLinuxOS
Posts: 214

Rep: Reputation: 35
Hello Liam123

To narrow down where the problem is occurring I would try the following.

Ping the ip address of the router.

Ping a site on the internet by ip address, try ping

Ping the same site by name: ping

In your web browser address bar type:

The results of those should give you a pretty clear idea of just where the failure is happening.
Old 01-03-2008, 09:59 PM   #4
LQ Newbie
Registered: Dec 2007
Posts: 9

Original Poster
Rep: Reputation: 0
New problem

Thanks guys very much for your help, new problem however. You see, I was very VERY stupid in assuming the router was actually in fact a router... it's actually just an access point, that is unfortunately governed by VERY expensive Fortinet routers that have UBER dhcp servers.. now what i think was going on is that these Fortinet routers were set to somehow disallow anything requesting an ip that was not based on the windows protocol... Now as I said, I forced my ip using the ifconfig wlan0 command and forced my netmask. Problem is not 30 secs after doing so (and a good ./network restart), the wlan0 script I had been using magically began to work.... issue is I now have an (in linux not windows) an ip of whilst in windows i have an ip of ...

To anybody who understands dhcp it would appear as though I have been put on a network split, network. Now I am concerned that this network is highly monitored by the fine folks at Fortinet.. Anybody got a clue as to how tell if this is the case?? without the obvious way of deliberately attracting attention to myself....

Any help is GREATLY appreciated. Thanks again to you both who helped me.

Old 01-03-2008, 11:23 PM   #5
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
I wonder it their DHCP server tracks both MAC addresses and HOSTNAMEs or the VENDER CLASS ID in the dhcp client's request. On my system the value in /etc/HOSTNAME is sent to the server. You may have an option to do so as well, and different behavior by the client could result in different IP addresses being defined. For example, does your windows client send a vender class ID?
from my /etc/sysconfig/dhcp configuration file:
## Type:        string("dhcpcd dhclient")
## Default:     ""
# specify a vendor class ID ( -i option)
# Specifies the vendor class identifier string.  dhcpcd uses the default vendor
# class identifier string (system name, system release, and machine type) if it
# is not specified.
Their server may be using this string to determine the OS of the system making a request.

Another possibility is that your client isn't waiting long enough for the process before it fails:
## Type:        integer
## Default:     5
# When the DHCP client is started at boot time, the boot process will stop
# until the interface is successfully configured, but at most for
There are different dhcp clients and associated configuration files. You system may read a single config file such as /etc/sysconfig/dhcp and use this info to construct the actual config file that your particular client looks for. Or you may need to determine which client your system uses and read it's config file and the man page for the config file if it exists. With some tweaking, you may be able to supply what their system expects.
Old 01-04-2008, 09:17 AM   #6
LQ Newbie
Registered: Dec 2007
Posts: 9

Original Poster
Rep: Reputation: 0

Thank you so much. I will test all that right now.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Home network: connecting to a Linksys router for DHCP IP address - no ping gunther Linux - Networking 28 05-20-2005 11:14 PM
Connecting to my linksys router gbogle Linux - Newbie 3 05-02-2005 10:47 PM
lingering issue with linux behind linksys router pfunk Linux - Networking 27 03-21-2005 08:39 PM
Connecting to Net with Surecom Network card and Linksys Router? EpicLinux Linux - Newbie 0 10-28-2003 03:04 PM
Connecting to I-net through Linksys router in Linux elgleon Linux - Networking 1 09-28-2001 10:52 AM > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 03:49 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration