LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-06-2004, 01:29 AM   #1
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
Starting up programs in .xinitrc ?


Trying to startup xmms when fluxbox starts. I changed the .xinitrc to each of these.

exec wmxmms &

exec xmms &

wmxmms &

xmms &

None of these starts up xmms in fluxbox. I read several threads and they say to use
" exec wmxmms & " but that does not work. What am I missing? thanks
 
Old 07-06-2004, 01:38 AM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
It should work. Maybe when you type startx, it's either reading .xinitrc at /etc/X11/ or /home/.xinitrc. Try editing both and see which one is being used
 
Old 07-06-2004, 05:30 AM   #3
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Where are you putting those commands in .xinitrc? You should put the command 'xmms &' before 'exec fluxbox'. The command 'exec command' tells the computer to execute the command and ignore anything that comes after it in a script.

Enjoy!
--- Cerbere

[edit] BTW the command 'wmxmms &' will launch a small dockable version of xmms in the fluxbox slit. [/edit]

Last edited by Cerbere; 07-06-2004 at 05:33 AM.
 
Old 07-06-2004, 04:25 PM   #4
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Original Poster
Rep: Reputation: 46
I tried both .xinitrc files, the one in home and the one in X11. When I type ./xinitrc in the console it reloads fluxbox and xmms starts up, but what is strange is that when I reboot, xmms does not start like .xinitrc is not getting read on boot.
 
Old 07-06-2004, 04:26 PM   #5
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
you want:
Code:
wmxmms &
xmms &
exec fluxbox
What do you mean you type xinitrc at console? .xinitrc should not be executable. It's not a script, it's a configuration file read by startx.

Last edited by Komakino; 07-06-2004 at 04:27 PM.
 
Old 07-06-2004, 05:05 PM   #6
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Original Poster
Rep: Reputation: 46
I just tried :

wmxmms &
xmms &
exec fluxbox

and that did not work

my .xinitrc also had: exec/X11R6/bin/fluxbox &

I tried it with every combination and still does not start up xmms or any other prog.

The other file was something different I was working on and got confused, lol.
Im jumping back and forth between 2 slack systems trying to configure each of them differently.

Last edited by BajaNick; 07-06-2004 at 05:07 PM.
 
Old 07-06-2004, 05:15 PM   #7
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
I have no idea why that isn't working...unless you're logging in from gdm/kdm/xdm...in which case it may be that you need those lines in your .xsession file instead.

Yep, just realised...if you're logging in graphically then the file used is .xsession - .xinitrc is used only by startx.
 
Old 07-06-2004, 05:24 PM   #8
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Original Poster
Rep: Reputation: 46
Yes I am logging in as runlevel 4, graphical. I will edit the .sessions file and let you know. Thanks
 
Old 07-06-2004, 06:07 PM   #9
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Original Poster
Rep: Reputation: 46
Ok, Im pissed. I cannot find a .xsession file anywhere so I created one in my /home/"USER" directory according to an article I found on the net, but it does nothing. Where is this file? and if I have to make one is it really involved? Thanks
 
Old 07-07-2004, 07:06 AM   #10
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
No, it's not hard...just an empty text file containing the commands you want to run - in your case:
xmms &
wmxmms &

Is all you need I think, saved as .xsession in your home directory.

If that doesn't work then I'm out of ideas.
 
Old 07-07-2004, 08:58 PM   #11
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Original Poster
Rep: Reputation: 46
I created a .xsession file and Its still not working. Ive come to the conclussion that it cant be done the way that it is described on all the threads and the other places ive seen it described. There must be something that is not being mentioned that I dont know about.
 
Old 07-19-2004, 10:40 AM   #12
daisaa
LQ Newbie
 
Registered: Mar 2004
Location: Mankato, MN
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
What login manager do you use? gdm, kdm, or xdm. In that case of gdm, which is the default, you also have to edit the /etc/X11/gdm/Xsession file. At about line 97 you will come to some lines that look like this. You will have to uncomment the if block, and I also changed the code in the if block to what I perfer and think works best.
Code:
# Some people say that an .xsession file should always be given priority, even if a
# different window manager was requested in $SESSION.  If you want that behavior, uncomment
# the lines below.  This is not recommended (nor, in general, is the use of an
# .xsession file as a default... it should be left for the advanced users).
if [ -x $HOME/.xsession ]; then
        . $HOME/.xsession
fi
Then all you have to do is edit the ~/.xsession file, create it if it doesn't exist. Mine looks like this
Code:
/usr/libexec/gnome-settings-daemon &
xmms -p &
bbkeys -i &
xscreensaver -no-splash &
gkrellm -w &
After these apps are executed control will be given back to /etc/X11/gdm/Xsession and it should start the correct session type (in your case fluxbox)

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting programs charnel Linux - General 1 08-02-2005 02:52 PM
Programs not starting Floydian Linux - Newbie 8 12-28-2004 12:04 PM
.xinitrc, fluxbox, startup programs jdier Linux - Newbie 4 08-26-2004 02:41 PM
.xinitrc programs start up twice fasmaie Linux - General 1 09-10-2003 07:21 PM
.xinitrc programs start twice on startup fasmaie Linux - Newbie 0 09-09-2003 03:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration