LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-17-2003, 02:03 AM   #1
lpriyamb
Member
 
Registered: Feb 2003
Posts: 65

Rep: Reputation: 15
Question how to configure sound card?


hello,

I have installed RH 9.0 recently. The sound card is not detected. But while booting for the first time it had detected. How to configure the sound card now?

thanks in advance
 
Old 09-17-2003, 02:45 AM   #2
Joker_cn
LQ Newbie
 
Registered: Sep 2003
Distribution: Slackware
Posts: 8

Rep: Reputation: 0
#sndconfig
 
Old 09-17-2003, 03:13 AM   #3
Evilone
Member
 
Registered: Oct 2002
Location: UK
Distribution: Slack 9.1 (2.6.5)
Posts: 307

Rep: Reputation: 30
OR :

Go to www.alsa-project.org and use a proper decent sound system !!
 
Old 09-17-2003, 04:46 AM   #4
lpriyamb
Member
 
Registered: Feb 2003
Posts: 65

Original Poster
Rep: Reputation: 15
Hi,

I tried sndconfig... it said that a ISAPNP sound card was found and the details are: Model: OPL3-SA3 Snd System:Unknown. Then it displayed the card settings to match the dip swtich settings in the sound card. I/O port, IRQ, DMA 1 and DMA2. I tried various combinations... the sound card test is saying that "unable to play audio"-An error occured opening /dev/audio and then again it goes to the setting which is in loop. how to solve it? please help.
 
Old 09-17-2003, 06:24 AM   #5
lpriyamb
Member
 
Registered: Feb 2003
Posts: 65

Original Poster
Rep: Reputation: 15
anyone there to help me?
 
Old 09-17-2003, 06:48 AM   #6
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
To get your sound card working, log in as root and give the following command:

modprobe opl3sa2

This command places the module for yamaha opl3 sa2 in memory.

Now give the command:

sndconfig

If you dont remember the DMA and IRQ settings, reboot into Windows 98/2000/XP....if you have a dual boot and check out the settings from there. You can locate the settings like this:

Start->Settings->Control Panel->System->Sound, Audio and Game Controllers

Then right click the Yamaha OPL3 SA3 soundboard and check "Properties".

These settings are also displayed at boot time of Windows.

If you dont know the settings, try and use my settings

Use DMA as 1, 0
IRQ as 5
and leave the rest as it is....

And yes, keep the volume of ur speakers high and use a console audio mixer program to set values of bass, treble and other settings to 100%....Check and unmute all the options otherwise u may not hear the test sound.

I hope that will solve your issue.
 
Old 09-17-2003, 07:07 AM   #7
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
Note however that this setting will disappear after you reboot your machine. To keep the settings permanent, you have to get the sound module loaded at the time of system startup.

To do that, create a shell script....name it anything...lets say

load_sound.sh

put this line in it:

modprobe opl3sa2

and save it in the /usr/local/bin directory.

Now open the file

/etc/rc.d/rc.local

This is how it looks like:

#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local

# Your custom script is executed next
/usr/local/bin/load_sound.sh

Now, every time your system boots, the sound module will be loaded automatically.
 
Old 09-18-2003, 12:10 AM   #8
lpriyamb
Member
 
Registered: Feb 2003
Posts: 65

Original Poster
Rep: Reputation: 15
Hello,

Thanks a lot for ur help! The audio is working fine and i tried writing the shell script as u mentioned. when i restarted to check, it's not detecting the device again While booting i saw "Loading sound module ad1848" what should i do?
 
Old 09-18-2003, 12:17 AM   #9
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
well....sorry, i forgot to tell you one more thing...

you need to give executable rights to the script.

do that by issuing the following command:

chmod a+x /usr/local/bin/xxx.sh or

change to the directory /usr/local/bin and give the command

chmod a+x xxx.sh ( where xxx is the name of ur shell script)

i hope that will help u get rid of this problem forever!
 
Old 09-18-2003, 12:20 AM   #10
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
and you need to be logged in as root to assign permissions.

Dont worry about anything else. It will work fine once u make it executable.
 
Old 09-18-2003, 12:33 AM   #11
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Instead of the shell script you could have just added the line "opl3sa2" to your /etc/modules file. Simpler.
 
Old 09-18-2003, 01:31 AM   #12
lpriyamb
Member
 
Registered: Feb 2003
Posts: 65

Original Poster
Rep: Reputation: 15
It's working!! thanks....
 
Old 10-07-2003, 05:19 AM   #13
FrancoisRabe
LQ Newbie
 
Registered: Oct 2003
Location: South Africa
Posts: 7

Rep: Reputation: 0
Unhappy Intel AC'97 and RH 9

I have the same issue...
lsmod =ac97, size:5088, Used by:0, Not taintedunused)
# sndconfig detects Intel 82801EB AC'97 Audio

I press OK and it displays...82801EB AC'97 Audio is not supported.

No sound and no volume control.

Can anybody help please. I am new to Linux
 
Old 10-07-2003, 07:13 AM   #14
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Could you post the relevant part of lspci -v for me. I just want to double-check your chipset.
 
Old 10-17-2003, 03:58 AM   #15
lpriyamb
Member
 
Registered: Feb 2003
Posts: 65

Original Poster
Rep: Reputation: 15
Hi,

In redhat 7.3, the sndconfig is working fine. But the mp3 or .wav files can't be played through xmms... I have 3 packages installed.

xmms-gnome-1.2.7-1
xmms-devel-1.2.7-1
xmms-1.2.7-1

am i missing something?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to configure my sound card and driver........ Ryan L. Brown Linux - Hardware 1 09-10-2005 02:39 PM
How Do I Configure My Sound Card? Nukem Red Hat 13 04-11-2004 12:45 PM
Can't configure my sound card! fahdaziz Linux - Hardware 2 03-18-2004 09:17 PM
cant configure sound card in 2.2.2 gare39 Linux - Hardware 0 02-18-2004 10:50 AM
Configure Sound Card!?? FreakboY Linux - Newbie 1 09-09-2002 12:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration