LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2009, 10:07 PM   #1
brgsousa
Member
 
Registered: Aug 2007
Location: Salvador, Brazil
Distribution: Debian, Ubuntu
Posts: 185

Rep: Reputation: 15
Another aptitude problem...


I am trying to install gnome package in a Debian Lenny.

Installation ends like this:
Code:
Preconfiguring packages ...
(Reading database ... 53823 files and directories currently installed.)
Preparing to replace debianutils 2.8.4 (using .../debianutils_2.30_i386.deb) ...
Unpacking replacement debianutils ...
dpkg: error processing /var/cache/apt/archives/debianutils_2.30_i386.deb (--unpack):
 trying to overwrite `/usr/sbin/add-shell', which is also in package passwd
Errors were encountered while processing:
 /var/cache/apt/archives/debianutils_2.30_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
What can be happening?
 
Old 05-28-2009, 07:43 AM   #2
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,249
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
That package may not have downloaded completely or may be corrupt.. this is the first thing I would try..

rm /var/cache/apt/archives/debianutils_2.30_i386.deb
aptitude update
aptitude safe-upgrade


it will automatically download the package again and retry the installation.


Interesting Debian refers to that package as essential.. how is it not installed already ? Are you upgrading from a different version or something maybe ?
http://packages.debian.org/lenny/debianutils

Last edited by farslayer; 05-28-2009 at 07:44 AM.
 
Old 05-28-2009, 08:42 AM   #3
brgsousa
Member
 
Registered: Aug 2007
Location: Salvador, Brazil
Distribution: Debian, Ubuntu
Posts: 185

Original Poster
Rep: Reputation: 15
It didn't work
Still getting the same error


Code:
# aptitude show debianutils
Package: debianutils
Essential: yes
State: installed
Automatically installed: yes
Version: 2.8.4
Priority: required
Section: utils
Maintainer: Clint Adams <schizo@debian.org>
Uncompressed Size: 233k
PreDepends: libc6 (>= 2.3.2.ds1-4), coreutils (>= 4.5.8-1)
Conflicts: manpages-fr (<= 0.9.3-1)
Replaces: miscutils, cron (<= 3.0pl1-31), tetex-bin (< 1.0.6-1.1), manpages-fr (<= 0.9.3-1)
Description: Miscellaneous utilities specific to Debian
 This package provides a number of small utilities which are used primarily by the installation scripts of Debian packages, although you may use them
 directly.

 The specific utilities included are: installkernel mkboot mktemp run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which.
Code:
# aptitude show gnome
Package: gnome
New: yes
State: not installed
Version: 1:2.22.2~5
Priority: optional
Section: gnome
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uncompressed Size: 20.5k
Depends: gnome-desktop-environment (= 1:2.22.2~5), gdm-themes, gnome-themes-extras, gnome-games (>= 1:2.22.2), libpam-gnome-keyring (>= 2.22.2),
         gstreamer0.10-plugins-ugly (>= 0.10.8), gstreamer0.10-ffmpeg (>= 0.10.4), rhythmbox (>= 0.11.5), synaptic (>= 0.62), system-config-printer (>=
         1.0.0), totem-mozilla, swfdec-mozilla, epiphany-extensions, evolution-plugins (>= 2.22.2), evolution-exchange (>= 2.22.2), evolution-webcal (>=
         2.21.92), gnome-spell (>= 1.0.4), serpentine, gnome-app-install, transmission-gtk, bluez-gnome, gnome-vfs-obexftp, arj, p7zip, avahi-daemon
Recommends: gnome-games-extra-data (>= 2.22.0), gnome-office (= 1:2.22.2~5), tomboy (>= 0.10.2), update-notifier, empathy | pidgin, gparted, tsclient,
            network-manager-gnome, hal-cups-utils, gthumb, liferea | blam, menu-xdg, gdebi, hardinfo
Suggests: gnome-dbg, openoffice.org-gnome, openoffice.org-evolution
Conflicts: gnome-cups-manager
Description: The GNOME Desktop Environment, with extra components
 This is the GNOME Desktop environment, an intuitive and attractive desktop, with extra components.

 This package depends on the standard distribution of the GNOME desktop environment, plus a complete range of plugins and other applications integrating with
 GNOME and Debian, providing the best possible environment to date.
Don't know why it is trying to downgrade debianutils
 
Old 05-28-2009, 09:52 AM   #4
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,249
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
How is it that you have debianutils 2.8.4 installed ?


Yours
Code:
# aptitude show debianutils
Package: debianutils
Essential: yes
State: installed
Automatically installed: yes
Version: 2.8.4
Priority: required
Section: utils
Maintainer: Clint Adams <schizo@debian.org>

Mine
Code:
it-lenny:~# aptitude show debianutils
Package: debianutils
Essential: yes
State: installed
Automatically installed: no
Version: 2.30
Priority: required
Section: utils
Maintainer: Clint Adams <schizo@debian.org>
Lenny Stable is 2.30

Squeeze Testing is 3.1.3

where did 2.8.4 come from ?

What does your sources list look like ?

Last edited by farslayer; 05-28-2009 at 09:54 AM.
 
Old 05-29-2009, 09:55 AM   #5
brgsousa
Member
 
Registered: Aug 2007
Location: Salvador, Brazil
Distribution: Debian, Ubuntu
Posts: 185

Original Poster
Rep: Reputation: 15
/etc/apt/sources.list
Code:
deb ftp://ftp.br.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.br.debian.org/debian/ stable main contrib non-free

deb http://security.debian.org/ stable/updates main contrib
deb-src http://security.debian.org/ stable/updates main contrib
even if I try to remove debianutils, aptitude asks me to upgrade it first
Code:
# aptitude remove debianutils
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
  bsdmainutils console-common cron dbus dialog fdutils fetchmail gzip
  iceweasel less mysql-client-5.0 proftpd-basic x11-common
The following packages will be REMOVED:
  debianutils
0 packages upgraded, 0 newly installed, 1 to remove and 285 not upgraded.
Need to get 0B of archives. After unpacking 233kB will be freed.
The following packages have unmet dependencies:
  mysql-client-5.0: Depends: debianutils (>= 1.6) but it is not installable
  fetchmail: Depends: debianutils (>= 1.7) but it is not installable
  dbus: Depends: debianutils (>= 1.22.0) but it is not installable
  iceweasel: Depends: debianutils (>= 1.16) but it is not installable
  cron: Depends: debianutils (>= 1.7) but it is not installable
  bsdmainutils: Depends: debianutils (>= 1.8) but it is not installable
  console-common: Depends: debianutils (>= 1.13) but it is not installable
  proftpd-basic: Depends: debianutils (>= 1.21.0) but it is not installable
  x11-common: Depends: debianutils (>= 1.13) but it is not installable
  dialog: Depends: debianutils (>= 1.6) but it is not installable
  fdutils: Depends: debianutils (>= 1.7) but it is not installable
  gzip: Depends: debianutils (>= 1.6) but it is not installable
  less: Depends: debianutils (>= 1.8) but it is not installable
The following actions will resolve these dependencies:

Upgrade the following packages:
debianutils [2.8.4 (now) -> 2.30 (stable)]

Score is 90064

Accept this solution? [Y/n/q/?]
 
Old 05-29-2009, 11:51 AM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
So did you accept the solution?
cheers,
jdk
 
Old 05-29-2009, 01:43 PM   #7
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,249
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
debianutils 2.8.4 was from sarge, did you go from Sarge directly to lenny as an upgrade , skipping etch ? If so you are NOT supposed to do that.. Upgrades are testing from the previous stable version.. not from two versions back.

Last edited by farslayer; 05-29-2009 at 01:44 PM.
 
Old 05-29-2009, 04:55 PM   #8
brgsousa
Member
 
Registered: Aug 2007
Location: Salvador, Brazil
Distribution: Debian, Ubuntu
Posts: 185

Original Poster
Rep: Reputation: 15
yeah...
i'm afraid i did that.
but earlier today i fixed this problem by changing sources.list to etch. then installed debianutils, then changed back to lenny.

Thanks!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
aptitude-gtk: Gui for aptitude Rasmus Linux - Software 1 12-19-2008 08:53 AM
Problem trying to install aptitude jacatone Linux - Newbie 2 08-15-2007 08:00 AM
some problem with aptitude woodland56 Debian 2 05-19-2006 04:01 AM
aptitude dependency problem Duncan Foley Debian 6 09-16-2005 05:17 PM
Aptitude problem McCloud Debian 5 09-01-2005 11:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration