LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-07-2011, 11:19 PM   #1
unreal128
Member
 
Registered: Jun 2003
Distribution: SuSE, Slackware, Gentoo
Posts: 207

Rep: Reputation: 30
Unable to access repo with SVN+HTTPS.


I am running Ubuntu 10.4 with Apache2, SVN and SSL. Both HTTP and HTTPS are working correctly with my website. Although the SVN setup I have is not working.

This configuration gives me a 403 error.
Code:
<Location /svn>

  DAV svn

  SVNParentPath /srv/svn/repos
  SVNListParentPath On

  Order allow,deny
  Allow from all

</Location>
This configuration prompts the login but it keep reprompting; not accepting my login.
Code:
<Location /svn>

  DAV svn

  SVNParentPath /srv/svn/repos
  SVNListParentPath On

  Order deny,allow
  Deny from all
  Satisfy any

  AuthType Basic
  AuthName "Subversion Repository"
  AuthUserFile /etc/apache2/dav_svn.passwd

  Require valid-user

</Location>
I write out the dav_svn.passwd file using htpasswd.

This issue is driving me up the walls. If there is any additional information, I will be more than happy to provide it.
 
Old 07-08-2011, 04:51 AM   #2
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,378

Rep: Reputation: 135Reputation: 135
Check this link may help you .

http://thegnulinuxguy.wordpress.com/...-https-server/
 
1 members found this post helpful.
Old 07-08-2011, 11:56 AM   #3
unreal128
Member
 
Registered: Jun 2003
Distribution: SuSE, Slackware, Gentoo
Posts: 207

Original Poster
Rep: Reputation: 30
Thanks for the link. I paid particular attention to the subversion configuration for Apache2. When I get rid of the "Order deny,allow" and "Deny from all" it starts to work but unprotected. I noticed he uses htpasswd2 to create the password file. I couldn't find htpasswd2 on Ubuntu 10.4 but thought htpasswd was the command to use for Apache2. Is the problem that I am using htpasswd instead of htpasswd2? This would explain why the logins fail.
 
Old 07-08-2011, 11:17 PM   #4
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,378

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by unreal128 View Post
Thanks for the link. I paid particular attention to the subversion configuration for Apache2. When I get rid of the "Order deny,allow" and "Deny from all" it starts to work but unprotected. I noticed he uses htpasswd2 to create the password file. I couldn't find htpasswd2 on Ubuntu 10.4 but thought htpasswd was the command to use for Apache2. Is the problem that I am using htpasswd instead of htpasswd2? This would explain why the logins fail.
htpasswd2 is used on SLES there but in ubuntu its htpasswd .

In SLES the version comes after the command, like apache2,htpasswd2 etc..
 
1 members found this post helpful.
Old 07-11-2011, 12:29 PM   #5
unreal128
Member
 
Registered: Jun 2003
Distribution: SuSE, Slackware, Gentoo
Posts: 207

Original Poster
Rep: Reputation: 30
That makes sense, thanks for explaining this. Do you know why the login is not being accepted? Even with HTTP+SVN I can't get it working. I reinstalled Ubuntu 10.04 from scratch without SSL this time and only followed this tutorial in order to setup WebDAV. Please help me, I am so frustrated that it keeps requesting the login.

Code:
<Location /svn>

DAV svn

SVNParentPath /srv/svn/repos
SVNListParentPath On

Order deny,allow
Deny from all

AuthType Basic
AuthName "Subversion Repository"
AuthUserFile /etc/apache2/dav_svn.passwd
Require valid-user

</Location>

Last edited by unreal128; 07-12-2011 at 01:17 AM.
 
Old 07-13-2011, 12:33 PM   #6
unreal128
Member
 
Registered: Jun 2003
Distribution: SuSE, Slackware, Gentoo
Posts: 207

Original Poster
Rep: Reputation: 30
I was able to resolve the problem by putting the Limit directive around the Require valid-user directive.

Code:
<Limit GET POST PUT DELETE CONNECT OPTIONS PATCH PROPFIND PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
   Require valid-user
</Limit>
Don't ask me why, it just works now. I used LimitExcept but I wanted to bar everything so I used Limit instead. You could probably use LimitExcept OPTIONS too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
svn, export repo to remote machine RudraB Linux - General 1 08-29-2010 11:40 AM
Copy svn repo from one server to another? matiasar Linux - Software 2 09-10-2008 08:50 AM
Error during SVN Repo Access through EClipse? your_shadow03 Linux - Server 1 08-27-2008 01:20 AM
svn: Mismatched RA version for 'https': found 1.4.6, expected 1.4.2 sean_zhang Linux - Software 1 04-22-2008 06:02 PM
A nice Beryl 0.1.4 SVN repo here craigevil Debian 1 12-22-2006 11:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration