Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Security
User Name
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.


  Search this Thread
Old 01-19-2004, 05:05 PM   #1
LQ Newbie
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
Firewall off but appears to be on still

I have RedHat 8. I have turned the firewall off completely and iptables shows no rules at all.
But suddenly it seems as though I am firewalled, I noticed it a couple of days ago when trying to run gtk-gnutella. According to my isp, I am not firewalled at their end, and i can connect to the gnutella network using limewire in windows (shudder). So it appears as though its a problem with linux.
I can telnet to my machine ok on my local network, so it appears whatever is firewalling me is not causing a problem on my local home network, but i cannot be telnetted to from the Internet. I connect to the internet using kppp, and everything was working fine up until a couple of days ago, and I haven't played with a thing. I have tried everything and I am completely stumped, I want to be able to be connected to and I want to be able to use gnutella again on my linux box. Any ideas anyone has would be greatly appreciated.
Old 01-19-2004, 05:48 PM   #2
Senior Member
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Verify what rules you have in place and go from there:
iptables --list -n
Old 01-19-2004, 06:14 PM   #3
LQ Newbie
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
yeah there's no rules there... policy accept on everything
i got it working again... i think its my isp...
trying to block me or something from connecting to the gnutella network
Old 01-19-2004, 06:23 PM   #4
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
Make sure you have ip_forwarding enabled on the linux box.

cat /proc/sys/net/ipv4/ip_forward;

It should replay with 1 if not then
echo 1 > /proc/sys/net/ipv4/ip_forward;

You can update the /etc/sysctl.conf file with
to make it perminent.
Old 01-19-2004, 08:32 PM   #5
LQ Newbie
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
yep no worries it all seems to be working now... using a port number above 10000 on gnutella seemed to fix it... i dunno why
thanks for all your help its been really helpful and you dudes replied really quick
i remember installing free bsd years ago on a 486... what a nightmare
linux has come a long way and the only time i even bother to load windows is to play games..
it sucks :P
Old 01-22-2004, 01:17 AM   #6
Registered: Jan 2004
Location: Miami FL
Distribution: Mac OS X 10.4.11 Ubuntu 12.04 LTS
Posts: 429

Rep: Reputation: 30
Remember!! it's all about PERMISSIONS never NEVER make big changes logged in as Root! you can BREAK files -permissions there!
Old 01-16-2005, 01:01 PM   #7
Registered: Feb 2004
Location: Columbus, IN USA
Distribution: Mepis 3.4 rc1
Posts: 119

Rep: Reputation: 26

If anyones still on this thread I could use some help.
Last month I decieded to do some year end clean up so I emptied my work dir and deleted my /.Gtk-Gnutella Dir figuring all I'd have to do is run Gtk-Gnutella again and point it to the corect Dirs and that'd do it. It now just sits there showing 0/3 connections. I've even uninstalled the 0.93 rpm and whyped everything I could find that said Gtk-Gnutella befor reinstalling, nothing! I don't know what I screwed up but it worked before. I tried turning off the router firewall, chainging ports, ipforwarding still nothing. I tried apolon but it can't giftd and after a week fighting it I gave up. Ideas welcome.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LQ wiki appears to be down? titanium_geek LQ Suggestions & Feedback 9 06-25-2005 07:16 AM
I cannot install anything because it appears that I have no compiler. bublebboy Linux - Newbie 14 12-07-2004 02:54 AM
wlan0 appears as eth1 and can't get an ip kovermours Linux - Wireless Networking 7 09-13-2004 05:55 PM
HD appears twice? z-vet Mandriva 4 08-11-2004 06:23 PM
XF86Config appears to be correct, but mimsmall Fedora - Installation 1 03-23-2004 01:51 PM > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 09:35 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration