LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-10-2006, 02:29 AM   #1
tweety1
LQ Newbie
 
Registered: May 2006
Posts: 7

Rep: Reputation: 0
The extension 'zlib' couldn't be found.


Dear All,

I'm using PHP 5.1.4,MySQL 5.1.9-beta, and apache 2.2.2.Everything is working fine except propel.I have been trying to install creole since last tuesday.

When i tried to install creole with pear
# pear install http://creole.phpdb.org/pear/creole-current.tgz
downloading creole-current.tgz ...
Starting to download creole-current.tgz (78,080 bytes)
..................done: 78,080 bytes

I have the following errors
The extension 'zlib' couldn't be found.
Please make sure your version of PHP was built with 'zlib' support.


My PHP configuration is

'./configure' '--with-mysql=/usr/local/mysql' '--enable-freetype-4bit-antialias-hack' '--with-gd=/usr/' '--with-jpeg-dir=/usr/local/libjpeg' '--with-png-dir=/usr/local/libpng' '--with-tiff-dir=/usr/local/libtiff' '--enable-libxml' '--enable-dom' '--enable-t1lib' '--with-pcre-regex' '--enable-posix' '--enable-session' '--enable-soap' '--enable-sockets' '--enable-debug' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-inline-optimization' '--enable-libgcc' '--enable-maintainer-mode' '--enable-sysvsem' '--enable-shared-pdflib' '--with-system-regex' '--with-tsrm-pthreads' '--with-x' '--with-xsl=/usr/local/libx' '--with-bz2' '--enable-gd-native-tt' '--with-zlib-dir=/usr/local/lib/zlib/' '--wi '--with-zlib' '--enable-yp' '--with-gettext' '--enable-shmop' '--enable-wddx' '--with-xml' '--with-tsrm-pthreads' '--enable-shared' '--enable-debugger' '--enable-fastcgi' '--with-libexpat-dir=/usr/local/include' '--with-libxml-dir=/usr/local/include/libxml2' '--enable-xslt' '--with-xslt-sablot' '--with-iconv-dir=usr/bin/iconv' '--with-gettext' '--with-gdbm' '--with-apxs2=/usr/local/apache2/bin/apxs' '--enable-mbstring' '--with-kerberos' '--with-xsl' '--prefix=/usr/local/php'

Eagerly waiting for your advice
 
Old 07-12-2006, 03:57 AM   #2
zeitounator
Member
 
Registered: Aug 2003
Location: Montpellier, France, Europe, World, Solar System
Distribution: Debian Sarge, Fedora core 5 (i386 and x86_64)
Posts: 262

Rep: Reputation: 30
In your etc folder, check if you have a php-cli.ini file. If it is there, check that the zlib extension is loaded in there. If this file does not exist, make the same check in php.ini file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
zlib not found when running ./configure quordandis Linux - Software 9 11-28-2010 08:51 AM
zlib m2azer Linux - Newbie 1 09-16-2005 05:07 PM
zlib ?! D3javu Linux - Newbie 1 04-05-2005 06:39 AM
"shape extension stuff could not be found" bluefire Linux - Software 0 05-04-2004 09:16 PM
Apache Extension Tool(apxs) not found!! Sabeer Linux - Software 3 09-08-2003 09:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration