Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 08-15-2003, 08:07 PM   #1
LQ Newbie
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Shaw > Linksys 4 port > RTL-8139 > MDK 9.1 = no internet

can someone help with my lack of internet?

A breif of my LAN is like this:

Linksys 4 port router
RTL-8139 Ethernet Card
Mandrake 9.1

-previously, this machine had Xp on it, so i know the LAN outside my box is operational.

-eth0 (the realtek) is stated as up, yet my status is not connected.

-im trying to establish the same LAN settings that i had on my XP machine.

-Ive been as daring as to input all the settings such as Static Ip, Mask, and Def Gateway...

can someone give me some pointers or a walkthrough?
Old 08-15-2003, 09:43 PM   #2
LQ Newbie
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
when i try to ifconfig this is what i get. .

$ ifconfig eth0
SIOSCIFADDR: Permission denied
SIOSCIFFLAGS: Permission dnied

?? any takers ??
Old 08-15-2003, 10:45 PM   #3
LQ Guru
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Go into Mandrake Control Center. Configure your network card to automatically get an IP address. Your LINKSYS router should be already setup as a DHCP server, a service that hands out unused IP addresses to computers on the LAN network, by default. You can manually enter in the network information for a static (pernament) IP address. For a static IP address, you need:
1) An unused IP address. Usually its 192.168.1.XXX Fill in a number from 2 to 255 for XXX. It has to be in three digit format.
2) DNS numbers from your ISP. If you don't know them, you can look at the logs for your router.
3) The domain name of your ISP. This is not the same as the ISP web address. Some ISP is setup so you can ping www and this will give you the domain name.
4) Gateway address. This is your router's IP address. Its normally is

If you don't know the information for step 2 throught 4 or it doesn't work. You can use any Windows OS from Win98 and up. At the console type ipconfig. This will give you the information that you need.

You have to be as root or su for the below to work
ifconfig eth0
Also your system and router will have a fight with that address.
Old 08-16-2003, 03:34 AM   #4
LQ Newbie
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
i tried all that.. im not sure where the problem was..

I decided to go with redhat 9 + xp.. it was a clean install dual boot works great..

thanks anyway..
Old 08-16-2003, 05:32 AM   #5
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 748

Rep: Reputation: 31
I had the EXACT same problem. Then, I reinstalled (I hate reinstalling, but I was testing different distros for a newbie), and on the second try, it worked fine. Still not sure why or exactly how it got going. It just worked the second time around, even I selected the same options.

(I'd decided that Mandrake 9.1 was friendlier, so I installed it to figure out the problem in case a similar thing happened.) I wish I had an answer, however, because my setup works great in both freebsd and debian as well.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't configure my Realtek RTL 8139 in ubuntu Guest1234 Linux - Networking 10 04-08-2008 12:30 PM
Please help with RTL 8139 on RedHat 9 danywu Linux - Networking 12 12-12-2003 07:08 PM
RTL-8139 on ECS L7SOM mobo Chernobyl Linux - Hardware 6 04-05-2003 01:31 AM
RTL 8139 - Set Link speed cmarkides Linux - Networking 1 02-13-2003 09:50 AM
Problem configuring rtl 8139 buscard Raven_X_Neo Linux - Networking 0 10-30-2002 09:50 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:57 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration