LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Shaw > Linksys 4 port > RTL-8139 > MDK 9.1 = no internet (https://www.linuxquestions.org/questions/linux-newbie-8/shaw-linksys-4-port-rtl-8139-mdk-9-1-%3D-no-internet-82395/)

understatement 08-15-2003 09:07 PM

Shaw > Linksys 4 port > RTL-8139 > MDK 9.1 = no internet
 
can someone help with my lack of internet?

A breif of my LAN is like this:

SHAW
v
Linksys 4 port router
v
RTL-8139 Ethernet Card
v
Mandrake 9.1

-previously, this machine had Xp on it, so i know the LAN outside my box is operational.

-eth0 (the realtek) is stated as up, yet my status is not connected.

-im trying to establish the same LAN settings that i had on my XP machine.

-Ive been as daring as to input all the settings such as Static Ip, Mask, and Def Gateway...

can someone give me some pointers or a walkthrough?

understatement 08-15-2003 10:43 PM

when i try to ifconfig this is what i get. .

$ ifconfig eth0 192.168.1.1
SIOSCIFADDR: Permission denied
SIOSCIFFLAGS: Permission dnied

?? any takers ??

Electro 08-15-2003 11:45 PM

Go into Mandrake Control Center. Configure your network card to automatically get an IP address. Your LINKSYS router should be already setup as a DHCP server, a service that hands out unused IP addresses to computers on the LAN network, by default. You can manually enter in the network information for a static (pernament) IP address. For a static IP address, you need:
1) An unused IP address. Usually its 192.168.1.XXX Fill in a number from 2 to 255 for XXX. It has to be in three digit format.
2) DNS numbers from your ISP. If you don't know them, you can look at the logs for your router.
3) The domain name of your ISP. This is not the same as the ISP web address. Some ISP is setup so you can ping www and this will give you the domain name.
4) Gateway address. This is your router's IP address. Its normally is 192.168.1.1

If you don't know the information for step 2 throught 4 or it doesn't work. You can use any Windows OS from Win98 and up. At the console type ipconfig. This will give you the information that you need.

You have to be as root or su for the below to work
ifconfig eth0 192.168.1.1
Also your system and router will have a fight with that address.

understatement 08-16-2003 04:34 AM

i tried all that.. im not sure where the problem was..

I decided to go with redhat 9 + xp.. it was a clean install dual boot works great..

thanks anyway..

scott_R 08-16-2003 06:32 AM

I had the EXACT same problem. Then, I reinstalled (I hate reinstalling, but I was testing different distros for a newbie), and on the second try, it worked fine. Still not sure why or exactly how it got going. It just worked the second time around, even I selected the same options.

(I'd decided that Mandrake 9.1 was friendlier, so I installed it to figure out the problem in case a similar thing happened.) I wish I had an answer, however, because my setup works great in both freebsd and debian as well.


All times are GMT -5. The time now is 07:01 AM.