LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-05-2005, 06:08 PM   #1
Guest1234
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 33

Rep: Reputation: 15
Can't configure my Realtek RTL 8139 in ubuntu


Hi I recently installed ubuntu 5.04 and the it didn't detect my realtek RTL8139/810x Family Fast Ethernet NIC card, which works fine on Win XP.

So I went to the realtek site and downloaded this driver "Linux driver for kernel 2.4.x (RedHat 7.2/ 7.3/ 8.0/ 9.0)" .
I unzipped the files and when I typed make, I got those error messages:

in file included from /usr/include/asm/smp.h:18,
from /usr/include/linux/smp.h:17,
from /usr/include/linux/sched.h:23,
from /usr/include/linux/module.h:10,
from rtl8139.c:104:
/usr/include/asm/mpspec.h:6:25: mach_mpspec.h: No such file or directory
In file included from /usr/include/asm/smp.h:18,
from /usr/include/linux/smp.h:17,
from /usr/include/linux/sched.h:23,
from /usr/include/linux/module.h:10,
from rtl8139.c:104:
/usr/include/asm/mpspec.h:8: error: `MAX_MP_BUSSES' undeclared here (not in a function)
/usr/include/asm/mpspec.h:9: error: `MAX_MP_BUSSES' undeclared here (not in a function)
/usr/include/asm/mpspec.h:10: error: `MAX_MP_BUSSES' undeclared here (not in a function)
/usr/include/asm/mpspec.h:12: error: `MAX_MP_BUSSES' undeclared here (not in a function)
/usr/include/asm/mpspec.h:19: error: `MAX_APICS' undeclared here (not in a function)
/usr/include/asm/mpspec.h:20: error: `MAX_MP_BUSSES' undeclared here (not in a function)
/usr/include/asm/mpspec.h:20: error: conflicting types for `mp_bus_id_to_type'
/usr/include/asm/mpspec.h:8: error: previous declaration of `mp_bus_id_to_type'
/usr/include/asm/mpspec.h:22: error: `MAX_IRQ_SOURCES' undeclared here (not in a function)
/usr/include/asm/mpspec.h:24: error: `MAX_MP_BUSSES' undeclared here (not in a function)
/usr/include/asm/mpspec.h:24: error: conflicting types for `mp_bus_id_to_pci_bus'
/usr/include/asm/mpspec.h:12: error: previous declaration of `mp_bus_id_to_pci_bus'
/usr/include/asm/mpspec.h:54: error: `MAX_APICS' undeclared here (not in a function)
In file included from /usr/include/asm/smp.h:20,
from /usr/include/linux/smp.h:17,
from /usr/include/linux/sched.h:23,
from /usr/include/linux/module.h:10,
from rtl8139.c:104:
/usr/include/asm/io_apic.h:120: error: `MAX_IRQ_SOURCES' undeclared here (not in a function)
/usr/include/asm/io_apic.h:120: error: conflicting types for `mp_irqs'
/usr/include/asm/mpspec.h:22: error: previous declaration of `mp_irqs'
In file included from /usr/include/linux/smp.h:17,
from /usr/include/linux/sched.h:23,
from /usr/include/linux/module.h:10,
from rtl8139.c:104:
/usr/include/asm/smp.h:73:26: mach_apicdef.h: No such file or directory
In file included from /usr/include/linux/irq.h:20,
from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:11,
from rtl8139.c:116:
/usr/include/asm/irq.h:16:25: irq_vectors.h: No such file or directory
In file included from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:11,
from rtl8139.c:116:
/usr/include/linux/irq.h:70: error: `NR_IRQS' undeclared here (not in a function)
In file included from /usr/include/linux/irq.h:72,
from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:11,
from rtl8139.c:116:
/usr/include/asm/hw_irq.h:28: error: `NR_IRQS' undeclared here (not in a function)
/usr/include/asm/hw_irq.h:31: error: `NR_IRQS' undeclared here (not in a function)
rtl8139.c: In function `rtl8129_open':
rtl8139.c:717: warning: `MOD_INC_USE_COUNT' is deprecated (declared at /usr/include/linux/module.h:482)
rtl8139.c:718: warning: passing arg 2 of `request_irq' from incompatible pointer type
rtl8139.c:719: warning: `MOD_DEC_USE_COUNT' is deprecated (declared at /usr/include/linux/module.h:494)
rtl8139.c:739: warning: `MOD_DEC_USE_COUNT' is deprecated (declared at /usr/include/linux/module.h:494)
rtl8139.c: In function `rtl8129_close':
rtl8139.c:1424: warning: `MOD_DEC_USE_COUNT' is deprecated (declared at /usr/include/linux/module.h:494)
rtl8139.c: In function `set_rx_mode':
rtl8139.c:1551: warning: passing arg 2 of `set_bit' from incompatible pointer type
rtl8139.c: In function `rtl_pwr_event':
rtl8139.c:1573: warning: `MOD_INC_USE_COUNT' is deprecated (declared at /usr/include/linux/module.h:482)
rtl8139.c:1609: warning: `MOD_DEC_USE_COUNT' is deprecated (declared at /usr/include/linux/module.h:494)


I'm a newbie to linux so can anyone tell me what's wrong?
 
Old 05-05-2005, 06:12 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
don't use any additional drivers. the 8139 chipset is just about THE best supported generic NIC chipset under linux. you WILL already have THREE fully functional 8139 drivers installed on your system. Try using "8139too" as your first attempt. just "modprobe 8139too" and go.
 
Old 05-06-2005, 04:18 AM   #3
Guest1234
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 33

Original Poster
Rep: Reputation: 15
I typed "modprobe 8139too" in the terminal(both as root user and as a regular user ), and it didn't do anything. When I checked the network setting it said Ethernet card eth0 is not configured and also said that the modem isn't configured. There isn't any "connect to the internet" or something like that in any of the menus.
Oh I forgot to mention that I have an ADSL connection and my modem is: B-FOCuS Router 270PR
 
Old 05-06-2005, 05:25 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,590

Rep: Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799
Quote:
I typed "modprobe 8139too" in the terminal(both as root user and as a regular user ), and it didn't do anything
That means that the command was succesful (since if there was an error you should have seen it), so the module is loaded into the kernel. Type "lsmod" as root (also modprobe must be run as root) to verify it. If it's not listed, run "dmesg" to see what the problem is.
Then you must use your distro's network configuration tool to configure your eth0 interface.
 
Old 05-06-2005, 07:11 AM   #5
Guest1234
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 33

Original Poster
Rep: Reputation: 15
I type lsmod and I did saw 8139too but in the "used by" it wrote 0.
After that I went to network settings to configure my ethernet card, but I didn't know what to write
in the IP address, netmask and gateway fields so I selected DHCP. then I configured DNS servers.
Then I opened firefox but whenever I tried to write some adress, it couldn't find it.
Am I supposed to create a dialer or something like that myself, or a dialer is automatically created for me after I configure the ethernet card?

And my IP address changes from connection to connection, each time I connect to the internet I get a different IP address so what am I supposed to write in the IP address field in the network settings.
And How do I find my netmask and gateway(I tried looking for those in the realtek card properties in device manager in windows but didn't find anything)
I did find a checkbox marked: "use default gateway on remote network" in the TCP/IP settings in windows.

Oh and another thing, in windows when I right-click and selected properties on "Local area connection" and then selected properties on TCP/IP and then advanced I saw under IP Adresses: DHCP Enabled.
So I guess that's what I need to use in linux, but as I said I tried that and I didn't saw any "connect to the internet" menu item or something like that afterwards.
So how do I configure a dialer if it's not automatically created for me?

After I configure my ethernet card I activated it of course.

Last edited by Guest1234; 05-06-2005 at 07:12 AM.
 
Old 05-06-2005, 07:56 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,590

Rep: Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799Reputation: 1799
So the module for your nic is loaded into the kernel. Since I'm not familiar with adsl setup, I cannot help you further but I found this link that might help you.
Also sarching here in LQ you can find lots of posts about setting up adsl/pppoe
Good luck
 
Old 05-06-2005, 11:38 AM   #7
Guest1234
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 33

Original Poster
Rep: Reputation: 15
I followed the link and installed the RP-PPPoE client and configured all the settings, but it still doesn't work, but thanks for your help anyway.
When I try to connect it just holds there for several seconds and then give me a timeout error message, does anybody here knows what might be the problem?

I tried connecting to the internet in windows and it worked, so it's not a problem with the ISP.

Last edited by Guest1234; 05-06-2005 at 11:39 AM.
 
Old 05-07-2005, 12:34 PM   #8
Guest1234
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 33

Original Poster
Rep: Reputation: 15
Does anybody know what's wrong and why I'm getting the timeout?????
 
Old 05-11-2005, 05:53 PM   #9
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
I've just installed Ubuntu 5.04 and I'm facing the same problem too. I had FC3 and SUSE 9.3 running on the same desktop machine before without problem but I just couldn't make my network card to work with Ubuntu. I've tried almost all the things that been suggested (searched google too) .. including assigning ip address manually .. I realiased during Ubuntu installation, it complaint about couldn't get IP from DHCP and then I use manual assignment which doesn't work either .. spent 2 hours now on this and still I'm no where ..
 
Old 05-11-2005, 07:04 PM   #10
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Alright .. found it .. it is the IRQ conflict .. and APIC is the culprit .. add NOAPIC at the end of your boot line in /boot/grub/menu.lst ... this works on mine .. after spending more than 2 hours trying to get it to work!
 
Old 04-08-2008, 01:30 PM   #11
EricEarl
Member
 
Registered: Jun 2004
Location: Victoria BC Canada
Distribution: Suse 9.2-10.0 RH 6.1 ubuntu 8.10 Mint 6
Posts: 33

Rep: Reputation: 15
8139 on Ubuntu and variants

It appears that this is an old issue that popped up when I started to use a Duron 1000Ghz machine with an rtl8139. The varius OSes I tried were based on Debian (Ubuntu). My last one was Mint Linux 4 and I had the same problem stated here by others with what appears to be an unrecognized nic. But the command lsmod|grep 8139 showed 2 hits: 8139cp and 8139too. This told me I had 2 drivers for 1 card. hmmmmm. After some experimentation and some experience in the past I knew my nic (network interface card) should have been 8139too. So I removed the 8139cp in Mint4 with: sudo rmmod 8139cp. The network then needed to be restarted the terminal way as if rebooting: sudo /etc/init.d/networking force-reload Done! My network is back and running properly after the 2 or 3 steps and it stays that way. It seems the newer installs on older hardware got confused in choosing the proper driver for the rtl8139 so chose both which conflicted with each other. Newer machines now come with the 8169 which doesn't have the duplication confusion.
Thank you, hope this helps.
Love Mint4 as well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed detection of "Realtek Semiconductor Co., Ltd. RTL-8139" network card scuffell Linux - Networking 5 06-15-2004 06:34 AM
Please help with RTL 8139 on RedHat 9 danywu Linux - Networking 12 12-12-2003 08:08 PM
How to install and configure Realtek 8139 Nic card zerokool Linux - Newbie 5 08-14-2003 03:23 AM
RTL-8139 on ECS L7SOM mobo Chernobyl Linux - Hardware 6 04-05-2003 02:31 AM
RTL 8139 - Set Link speed cmarkides Linux - Networking 1 02-13-2003 10:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration