LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 11-30-2003, 04:35 AM   #1
neubeigh
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 7

Rep: Reputation: 0
PC Speaker beeps


I'm running Slackware 9.1

It ran fine for several days. Then I installed the Seti@Home program, running in the background. This will run fine for several hours. Then, I'll hear a periodic single short beep from the PC speaker (I don't have a sound card installed on this machine). I'll hear the beep 2 or three times over a couple hours. Then there will be a continuous beep.
If I send the shutdown command to the system, the beep immediately stops. It stops before Linux has had a chance to complete the shutdown. Based on this behavior, I don't think it's a motherboard or memory issue.

Are there any reasons Linux would send a beep signal to the speaker?
 
Old 12-01-2003, 01:29 AM   #2
neubeigh
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Bump? Anyone? Bueller? Bueller?
 
Old 12-01-2003, 01:45 AM   #3
gradedcheese
Member
 
Registered: Nov 2003
Posts: 59

Rep: Reputation: 15
often when a program wants to make a sound but there is no soundcard there will instead be a beep from the speaker. Try it without Seti@Home and see if the problem goes away. If so then see if there's a way to configure Seti not to try to make any sounds.
 
Old 12-01-2003, 05:15 AM   #4
ReefShark
Member
 
Registered: Oct 2003
Location: the Netherlands
Distribution: Arch Linux, Ubuntu server
Posts: 145

Rep: Reputation: 15
Quote:
Originally posted by gradedcheese
If so then see if there's a way to configure Seti not to try to make any sounds.
As far as I know, there is no way to configure S@H itself not to make any sounds. Simply because the client itself doesn't make any sounds.

neubeigh; I have several clients running on several boxes (none of which have a configured soundcard) but I am 'beepless'. Even if S@H is the cause of the beeps, you might try to find out why it is beeping (errors connecting or something like that?). How do you start S@H in the background btw? There are several ways, perhaps a different approach from the one you are using now may resolve further annoying beeps.
 
Old 12-01-2003, 08:02 AM   #5
neubeigh
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
I have it running according to the instructions at this site:
http://www.lmb.org/temp/linux.htm

Strangely, I haven't had any beeps in the last day (knock on laminate). I hate intermittent problems. You're never really certain that you've fixed them.
 
Old 12-01-2003, 02:49 PM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by neubeigh
I hate intermittent problems. You're never really certain that you've fixed them.
Oh how I feel for you on that note! That's the problem with ANYTHING. Strange thing is though, that's what I've always loved about Linux. My problems have never auto-corrected themselves, giving me adequate time to properly diagnose and repair the problem.
If it re-surfaces, try the following, and post up anything 'unusual':
Drop back to a console:
CTRL ALT F2
Login as root, and type:
top
Kill your seti process and see if the beeping stops.

This is of couse just 1 idea of many, do whatever you feel comfortable doing to find the culprit.

Cool
 
Old 12-01-2003, 04:14 PM   #7
neubeigh
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the suggestion, I'll keep it on hand for next time.
 
Old 12-02-2003, 02:58 AM   #8
ReefShark
Member
 
Registered: Oct 2003
Location: the Netherlands
Distribution: Arch Linux, Ubuntu server
Posts: 145

Rep: Reputation: 15
Quote:
Originally posted by neubeigh
I have it running according to the instructions at this site:
http://www.lmb.org/temp/linux.htm
Not the most elegant way of doing it (I would advice against getting the client from any location other than Berkeley, but that's just me being paranoid), but it's a usable setup which shouldn't cause any beep-problems. Glad to hear they have gone (for the moment?).

MasterC's advice sounds like the good kind to me; best way to find the cause is to investigate and eliminate possible causes.
 
Old 12-02-2003, 05:58 AM   #9
acidraven
LQ Newbie
 
Registered: Dec 2003
Location: Salem, Oregon
Distribution: Slackware 7 upgraded to 8.1
Posts: 15

Rep: Reputation: 0
2 years ago I was useing Seti@home on a computer that was imporporly cooled and it would cause my computer to spontaiosly turn it self off insted of over heating. I then whent and installed the MB Control panel (Under Windows) and it sat there and after an HR with Seti Running it started to beep and give me worning so I found the problem .. the thing is Seti@home will many times Use all advalible processor and will then overheat the prossor. if your MB or Linux has a Alarm system then it might be telling you that something is up .. Just an idea .. exp if the problem cured it self up becuse you have the case open ..
 
Old 12-02-2003, 06:55 AM   #10
neubeigh
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks acidraven. That might be the case. I had also had an FTP server running which I shut down, and that's when the beeping stopped. So it might just be the processor.
I'll look into that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No beeps from internal speaker? King V Linux - Software 5 06-23-2005 06:41 PM
Beeps during Startup bluefire114 Linux - Laptop and Netbook 2 01-25-2005 02:27 AM
Won't turn on, no beeps jago25_98 Linux - Hardware 6 04-27-2004 07:23 AM
Ctrl key beeps the system speaker? bruno buys Linux - Newbie 1 11-30-2003 06:06 AM
Weird beeps Twiggy794 Linux - Hardware 8 10-30-2003 04:59 PM


All times are GMT -5. The time now is 11:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration